P25 <-> DMR Transcoding


Alec-N1AJW
 

just to confirm since I am reading this on BM.  the bridge should be set to Simplex and default to TS2 for this bridge?  That's how I was taught at least.


Alec
N1AJW


Steve N4IRS
 

Bryan,
Are you saying that P25 traffic coming through the bridge always sends to BM on slot 2?
Can you give me a example of traffic flow?

 Steve

On 8/20/2018 12:51 PM, Bryan Biedenkapp wrote:
Yes, Duplex and Slot One are enabled in the MMDVM_Bridge.ini.

[General]
Callsign=TRCDDMR
Id=8012012
Timeout=180
Duplex=1
Daemon=0

...

[DMR]
Enable=1
Address=xx.xx.xx.xx
Port=12012
Jitter=360
Local=62032
Password=RPT1234
Slot1=1
Slot2=1
Debug=0
 


Steve N4IRS
 

And still traffic from BM slot 1 is going to slot 2?

On 8/20/2018 12:51 PM, Bryan Biedenkapp wrote:
Yes, Duplex and Slot One are enabled in the MMDVM_Bridge.ini.

[General]
Callsign=TRCDDMR
Id=8012012
Timeout=180
Duplex=1
Daemon=0

...

[DMR]
Enable=1
Address=xx.xx.xx.xx
Port=12012
Jitter=360
Local=62032
Password=RPT1234
Slot1=1
Slot2=1
Debug=0
 


Bryan Biedenkapp
 

Yes, Duplex and Slot One are enabled in the MMDVM_Bridge.ini.

[General]
Callsign=TRCDDMR
Id=8012012
Timeout=180
Duplex=1
Daemon=0

...

[DMR]
Enable=1
Address=xx.xx.xx.xx
Port=12012
Jitter=360
Local=62032
Password=RPT1234
Slot1=1
Slot2=1
Debug=0
 


Steve N4IRS
 

Do you have duplex and slot one enabled in MMDVM_Bridge.ini ?

On 8/20/2018 10:24 AM, Bryan Biedenkapp wrote:
Steve,

Yes I did check this, I had it set to false, once set to true, I also realized that the gatewayDmrId and txTg values needed to be set to "0". Only remaining issue I've noticed is that for some reason the MMDVM_Bridge on the DMR side seems to always default to TS 2 regardless of the setting in Analog_Bridge (this is a minor issue as I can rewrite the TS using the HBlink Router software).

73
N2PLL (formerly KD2QGZ)


Bryan Biedenkapp
 

Steve,

Yes I did check this, I had it set to false, once set to true, I also realized that the gatewayDmrId and txTg values needed to be set to "0". Only remaining issue I've noticed is that for some reason the MMDVM_Bridge on the DMR side seems to always default to TS 2 regardless of the setting in Analog_Bridge (this is a minor issue as I can rewrite the TS using the HBlink Router software).

73
N2PLL (formerly KD2QGZ)


Steve N4IRS
 

Bryan,
Make sure in Analog_Bridge.ini (both of them) you have in the [GENERAL] stanza:

exportMetadata = true   

73, Steve N4IRS


On 08/17/2018 09:52 AM, Bryan Biedenkapp wrote:
I've gotten the basics of the transcoding to work on my private testing systems to work (mostly). The configuration I'm using look like this:
[MMDVM with DMR only] <-> [MMDVM_Bridge] <-> [Analog_Bridge] <-> [Analog_Bridge] <-> [MMDVM_Bridge] <-> [P25 Gateway] <-> [P25 Reflector] <-> [P25 Gateway] <-> [MMDVM with P25 only]

I can see traffic from the DMR side pass all the way thru and I do get P25 out. However, I've noticed I seem to lose the originating subscriber/source radio ID and target/destination talkgroup ID. Is there any way to somehow retain this information when transcoding? Or because of the nature of the transcode will this information always be lost?

73s
KD2QGZ


Bryan Biedenkapp
 

I've gotten the basics of the transcoding to work on my private testing systems to work (mostly). The configuration I'm using look like this:
[MMDVM with DMR only] <-> [MMDVM_Bridge] <-> [Analog_Bridge] <-> [Analog_Bridge] <-> [MMDVM_Bridge] <-> [P25 Gateway] <-> [P25 Reflector] <-> [P25 Gateway] <-> [MMDVM with P25 only]

I can see traffic from the DMR side pass all the way thru and I do get P25 out. However, I've noticed I seem to lose the originating subscriber/source radio ID and target/destination talkgroup ID. Is there any way to somehow retain this information when transcoding? Or because of the nature of the transcode will this information always be lost?

73s
KD2QGZ