Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR


Ray Harden
 

After considerable searching the records here I have not found a solution -

The five modules (Reflector, P25Gateway, Analog_BridgeDMR|P25, MMDVM_Host) are all running in their separate terminal spaces as has been directed for Diagnostics here - transmit from P25 radio to P25 repeater registers with P25 Reflector as expected, DMR packets from Brandmeister show up from the DMR side.  However, no audio from either side is present.

I have posted as much .ini and log information as I can as an attachment ... the majority of my time has been to be sure of the BridgeP25 and BridgeDMR ini's - following up on the suggestions of other's experiences, making sure the ports match across as defined in the ports chart -THEY DO!  Many changes according to instructions within the [AMBE_AUDIO] and [USRP] sections, "useEmulator= true/false", "gatewayDmrID=", 'repeaterID=", "aslAudio="AUDIO_UNITY | AUDIO_USE_AGC", "agcGain= 1", "dmrGain= -0.35" sections.  Nothing has worked that has been suggested in the literature here.

Watching the five terminals' activity as well as the logs show data passing as I think may be the proper order on both sides of P25 and DMR.  The MSF5000 radio is an active MMDVM repeater with P25 enabled.

I have a static TalkGroup enabled in Brandmeister for the appropriate RPi hotspot and it passes DMR traffic from TG 3119 to MMDVMHost.

Upon Transmit from the P25 MSF5000 and its P25 TG 31900, data is received in the RPi P25Reflector and registered.

Transmit back to the MSF5000 shows received packets in the logs but no audio is heard, no radio transmit from the actual radio MSF5000.  The logs from here show the packets were received.

Thanks for any suggestions.


Steve N4IRS
 

Ray,
Can you include the Analog_Bridge logs? Also, turn off debug for now.

Steve N4IRS

On 3/5/2019 3:29 PM, Ray Harden wrote:

After considerable searching the records here I have not found a solution -

The five modules (Reflector, P25Gateway, Analog_BridgeDMR|P25, MMDVM_Host) are all running in their separate terminal spaces as has been directed for Diagnostics here - transmit from P25 radio to P25 repeater registers with P25 Reflector as expected, DMR packets from Brandmeister show up from the DMR side.  However, no audio from either side is present.

I have posted as much .ini and log information as I can as an attachment ... the majority of my time has been to be sure of the BridgeP25 and BridgeDMR ini's - following up on the suggestions of other's experiences, making sure the ports match across as defined in the ports chart -THEY DO!  Many changes according to instructions within the [AMBE_AUDIO] and [USRP] sections, "useEmulator= true/false", "gatewayDmrID=", 'repeaterID=", "aslAudio="AUDIO_UNITY | AUDIO_USE_AGC", "agcGain= 1", "dmrGain= -0.35" sections.  Nothing has worked that has been suggested in the literature here.

Watching the five terminals' activity as well as the logs show data passing as I think may be the proper order on both sides of P25 and DMR.  The MSF5000 radio is an active MMDVM repeater with P25 enabled.

I have a static TalkGroup enabled in Brandmeister for the appropriate RPi hotspot and it passes DMR traffic from TG 3119 to MMDVMHost.

Upon Transmit from the P25 MSF5000 and its P25 TG 31900, data is received in the RPi P25Reflector and registered.

Transmit back to the MSF5000 shows received packets in the logs but no audio is heard, no radio transmit from the actual radio MSF5000.  The logs from here show the packets were received.

Thanks for any suggestions.



Ray Harden
 

The data in the log is from two days ago … I will run the test again with debug off.

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Tuesday, March 5, 2019 2:33 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 


Ray Harden
 

For some reason Analog_DMR and Analog_P25 logs are not being updated.

I have included the last P25Reflector and MMDVM logs are interesting.


Ray Harden
 

Please tell us how your DVSwitch interacts with MMDVM Client so I can attempt debug.

Turning my attention to the P25/MMDVM/MSF5000 Client radio:

My Motorola MSF5000/MMDVM system has been a functional P25 repeater for about a year.

  -- MMDVM is running on a RPi at 192.168.3.130

  -- MMDVM DMR Network is enabled: Address=3102.repeater.net, Port 62031 enabled, Port 62032 enabled

  -- MMDVM DMR is NOT enabled

  -- MMDVM P25 is enabled: NAC=293

  --  MMDVM P25 Network is enabled: Gateway Port 42020 enabled,  Local Port 32010 enabled

  --  P25Gateway is enabled: RptrPort Port 32010 enabled, LocalPort 42020 enabled, [Network] Port 42010 enabled

  --  P25Gateway [Network] Startup TG= 31900

  --  P25Hosts file: Includes TG 31900  192.168.3.4  41000, as well as all the other 10xxx (FQDN)  41000 TalkGroups

Is there any other requirement for the MMDVM Client to communicate with your DVSwitch system and back again?

The P25/MMDVM/MSF5000 client and the DVSwitch systems, each running on their own RPi are configured within my Local Area Network domain 192.168.3.xx.  Router is configured to PortForward 41000 TCP/UDP to 192.168.3.130.

Thank you very much for any assistance.

73   w0ray

 


Steve N4IRS
 

Ray,
If I remember correctly You are trying to connect your P25 repeater to DMR. You sent pretty complete config files and logs. I requested to see the logs from the two instances of Analog_Bridge during the test. You should be able to run each instance in the foreground and capture the output or grab the log files.

73, Steve N4IRS

On 3/6/2019 8:52 AM, Ray Harden wrote:

Please tell us how your DVSwitch interacts with MMDVM Client so I can attempt debug.

Turning my attention to the P25/MMDVM/MSF5000 Client radio:

My Motorola MSF5000/MMDVM system has been a functional P25 repeater for about a year.

  -- MMDVM is running on a RPi at 192.168.3.130

  -- MMDVM DMR Network is enabled: Address=3102.repeater.net, Port 62031 enabled, Port 62032 enabled

  -- MMDVM DMR is NOT enabled

  -- MMDVM P25 is enabled: NAC=293

  --  MMDVM P25 Network is enabled: Gateway Port 42020 enabled,  Local Port 32010 enabled

  --  P25Gateway is enabled: RptrPort Port 32010 enabled, LocalPort 42020 enabled, [Network] Port 42010 enabled

  --  P25Gateway [Network] Startup TG= 31900

  --  P25Hosts file: Includes TG 31900  192.168.3.4  41000, as well as all the other 10xxx (FQDN)  41000 TalkGroups

Is there any other requirement for the MMDVM Client to communicate with your DVSwitch system and back again?

The P25/MMDVM/MSF5000 client and the DVSwitch systems, each running on their own RPi are configured within my Local Area Network domain 192.168.3.xx.  Router is configured to PortForward 41000 TCP/UDP to 192.168.3.130.

Thank you very much for any assistance.

73   w0ray

 



Ray Harden
 

Trouble getting the logs … the /var/log/ folder contains both Bridge_DMR and Bridge_P25 logs, one file each, not the usual log files created by days.

 

For some reason the logs are not being created or otherwise certainly not in the /var/log folder.

 

The two files I do find have data from 2019-03-04. I guess it’s possible I did something to stop the logging – have no idea how to get it going again.

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRSP
Sent: Wednesday, March 6, 2019 8:05 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Ray,
If I remember correctly You are trying to connect your P25 repeater to DMR. You sent pretty complete config files and logs. I requested to see the logs from the two instances of Analog_Bridge during the test. You should be able to run each instance in the foreground and capture the output or grab the log files.

73, Steve N4IRS

On 3/6/2019 8:52 AM, Ray Harden wrote:

Please tell us how your DVSwitch interacts with MMDVM Client so I can attempt debug.

Turning my attention to the P25/MMDVM/MSF5000 Client radio:

My Motorola MSF5000/MMDVM system has been a functional P25 repeater for about a year.

  -- MMDVM is running on a RPi at 192.168.3.130

  -- MMDVM DMR Network is enabled: Address=3102.repeater.net, Port 62031 enabled, Port 62032 enabled

  -- MMDVM DMR is NOT enabled

  -- MMDVM P25 is enabled: NAC=293

  --  MMDVM P25 Network is enabled: Gateway Port 42020 enabled,  Local Port 32010 enabled

  --  P25Gateway is enabled: RptrPort Port 32010 enabled, LocalPort 42020 enabled, [Network] Port 42010 enabled

  --  P25Gateway [Network] Startup TG= 31900

  --  P25Hosts file: Includes TG 31900  192.168.3.4  41000, as well as all the other 10xxx (FQDN)  41000 TalkGroups

Is there any other requirement for the MMDVM Client to communicate with your DVSwitch system and back again?

The P25/MMDVM/MSF5000 client and the DVSwitch systems, each running on their own RPi are configured within my Local Area Network domain 192.168.3.xx.  Router is configured to PortForward 41000 TCP/UDP to 192.168.3.130.

Thank you very much for any assistance.

73   w0ray

 

 


Steve N4IRS
 

Run each instance from the command line and capture the output.

On 3/6/2019 10:06 AM, Ray Harden wrote:

Trouble getting the logs … the /var/log/ folder contains both Bridge_DMR and Bridge_P25 logs, one file each, not the usual log files created by days.

 

For some reason the logs are not being created or otherwise certainly not in the /var/log folder.

 

The two files I do find have data from 2019-03-04. I guess it’s possible I did something to stop the logging – have no idea how to get it going again.

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRSP
Sent: Wednesday, March 6, 2019 8:05 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Ray,
If I remember correctly You are trying to connect your P25 repeater to DMR. You sent pretty complete config files and logs. I requested to see the logs from the two instances of Analog_Bridge during the test. You should be able to run each instance in the foreground and capture the output or grab the log files.

73, Steve N4IRS

On 3/6/2019 8:52 AM, Ray Harden wrote:

Please tell us how your DVSwitch interacts with MMDVM Client so I can attempt debug.

Turning my attention to the P25/MMDVM/MSF5000 Client radio:

My Motorola MSF5000/MMDVM system has been a functional P25 repeater for about a year.

  -- MMDVM is running on a RPi at 192.168.3.130

  -- MMDVM DMR Network is enabled: Address=3102.repeater.net, Port 62031 enabled, Port 62032 enabled

  -- MMDVM DMR is NOT enabled

  -- MMDVM P25 is enabled: NAC=293

  --  MMDVM P25 Network is enabled: Gateway Port 42020 enabled,  Local Port 32010 enabled

  --  P25Gateway is enabled: RptrPort Port 32010 enabled, LocalPort 42020 enabled, [Network] Port 42010 enabled

  --  P25Gateway [Network] Startup TG= 31900

  --  P25Hosts file: Includes TG 31900  192.168.3.4  41000, as well as all the other 10xxx (FQDN)  41000 TalkGroups

Is there any other requirement for the MMDVM Client to communicate with your DVSwitch system and back again?

The P25/MMDVM/MSF5000 client and the DVSwitch systems, each running on their own RPi are configured within my Local Area Network domain 192.168.3.xx.  Router is configured to PortForward 41000 TCP/UDP to 192.168.3.130.

Thank you very much for any assistance.

73   w0ray

 

 



Ray Harden
 

Two Analog_Bridge files attached

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 9:08 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Run each instance from the command line and capture the output.

On 3/6/2019 10:06 AM, Ray Harden wrote:

Trouble getting the logs … the /var/log/ folder contains both Bridge_DMR and Bridge_P25 logs, one file each, not the usual log files created by days.

 

For some reason the logs are not being created or otherwise certainly not in the /var/log folder.

 

The two files I do find have data from 2019-03-04. I guess it’s possible I did something to stop the logging – have no idea how to get it going again.

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRSP
Sent: Wednesday, March 6, 2019 8:05 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Ray,
If I remember correctly You are trying to connect your P25 repeater to DMR. You sent pretty complete config files and logs. I requested to see the logs from the two instances of Analog_Bridge during the test. You should be able to run each instance in the foreground and capture the output or grab the log files.

73, Steve N4IRS

On 3/6/2019 8:52 AM, Ray Harden wrote:

Please tell us how your DVSwitch interacts with MMDVM Client so I can attempt debug.

Turning my attention to the P25/MMDVM/MSF5000 Client radio:

My Motorola MSF5000/MMDVM system has been a functional P25 repeater for about a year.

  -- MMDVM is running on a RPi at 192.168.3.130

  -- MMDVM DMR Network is enabled: Address=3102.repeater.net, Port 62031 enabled, Port 62032 enabled

  -- MMDVM DMR is NOT enabled

  -- MMDVM P25 is enabled: NAC=293

  --  MMDVM P25 Network is enabled: Gateway Port 42020 enabled,  Local Port 32010 enabled

  --  P25Gateway is enabled: RptrPort Port 32010 enabled, LocalPort 42020 enabled, [Network] Port 42010 enabled

  --  P25Gateway [Network] Startup TG= 31900

  --  P25Hosts file: Includes TG 31900  192.168.3.4  41000, as well as all the other 10xxx (FQDN)  41000 TalkGroups

Is there any other requirement for the MMDVM Client to communicate with your DVSwitch system and back again?

The P25/MMDVM/MSF5000 client and the DVSwitch systems, each running on their own RPi are configured within my Local Area Network domain 192.168.3.xx.  Router is configured to PortForward 41000 TCP/UDP to 192.168.3.130.

Thank you very much for any assistance.

73   w0ray

 

 

 


Steve N4IRS
 

Observations:
Back off agcGain -> 60 That is way too hot. Bring it down to 5
Do you have the emulator installed?
ls /opt/md380-emu
Is it running?
ps ax | grep md380
Is it listening on the default port (2470)?
netstat -unap | grep md380

If all above are true, on your Analog_Bridge for DMR, turn on the emulator and retest.
Analog_Bridge generates a single log file Analog_Bridge.log by default it goes to /var/log.
The environment variable AnalogBridgeLogDir defines the location of the log file if you want it somewhere else.
The systemd unit file /lib/systemd/system/analog_bridge.system set this variable with:
Environment=AnalogBridgeLogDir=/var/log/dvswitch/Analog_Bridge

If you are starting your 2 instances of Analog_Bridge with system units, you want to point these two environment variable to different directories.

Steve N4IRS 


On 3/6/2019 10:34 AM, Ray Harden wrote:

Two Analog_Bridge files attached

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 9:08 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Run each instance from the command line and capture the output.

On 3/6/2019 10:06 AM, Ray Harden wrote:

Trouble getting the logs … the /var/log/ folder contains both Bridge_DMR and Bridge_P25 logs, one file each, not the usual log files created by days.

 

For some reason the logs are not being created or otherwise certainly not in the /var/log folder.

 

The two files I do find have data from 2019-03-04. I guess it’s possible I did something to stop the logging – have no idea how to get it going again.

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRSP
Sent: Wednesday, March 6, 2019 8:05 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Ray,
If I remember correctly You are trying to connect your P25 repeater to DMR. You sent pretty complete config files and logs. I requested to see the logs from the two instances of Analog_Bridge during the test. You should be able to run each instance in the foreground and capture the output or grab the log files.

73, Steve N4IRS

On 3/6/2019 8:52 AM, Ray Harden wrote:

Please tell us how your DVSwitch interacts with MMDVM Client so I can attempt debug.

Turning my attention to the P25/MMDVM/MSF5000 Client radio:

My Motorola MSF5000/MMDVM system has been a functional P25 repeater for about a year.

  -- MMDVM is running on a RPi at 192.168.3.130

  -- MMDVM DMR Network is enabled: Address=3102.repeater.net, Port 62031 enabled, Port 62032 enabled

  -- MMDVM DMR is NOT enabled

  -- MMDVM P25 is enabled: NAC=293

  --  MMDVM P25 Network is enabled: Gateway Port 42020 enabled,  Local Port 32010 enabled

  --  P25Gateway is enabled: RptrPort Port 32010 enabled, LocalPort 42020 enabled, [Network] Port 42010 enabled

  --  P25Gateway [Network] Startup TG= 31900

  --  P25Hosts file: Includes TG 31900  192.168.3.4  41000, as well as all the other 10xxx (FQDN)  41000 TalkGroups

Is there any other requirement for the MMDVM Client to communicate with your DVSwitch system and back again?

The P25/MMDVM/MSF5000 client and the DVSwitch systems, each running on their own RPi are configured within my Local Area Network domain 192.168.3.xx.  Router is configured to PortForward 41000 TCP/UDP to 192.168.3.130.

Thank you very much for any assistance.

73   w0ray

 

 

 



Ray Harden
 

Yes md380 is running @ 2470, emulator is turned on, retest, have no PTT or audio from MSF500-P25 or transfer to TG3119 @ Brandmeister.

The P25 Gateway terminal screen rolls with hex packets, same for MMDVM_Bridge with packets from Brandmeister.

We must be getting closer - I hope


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Steve N4IRS <szingman@...>
Sent: Wednesday, March 6, 2019 9:50:17 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR
 
Observations:
Back off agcGain -> 60 That is way too hot. Bring it down to 5
Do you have the emulator installed?
ls /opt/md380-emu
Is it running?
ps ax | grep md380
Is it listening on the default port (2470)?
netstat -unap | grep md380

If all above are true, on your Analog_Bridge for DMR, turn on the emulator and retest.
Analog_Bridge generates a single log file Analog_Bridge.log by default it goes to /var/log.
The environment variable AnalogBridgeLogDir defines the location of the log file if you want it somewhere else.
The systemd unit file /lib/systemd/system/analog_bridge.system set this variable with:
Environment=AnalogBridgeLogDir=/var/log/dvswitch/Analog_Bridge

If you are starting your 2 instances of Analog_Bridge with system units, you want to point these two environment variable to different directories.

Steve N4IRS 


On 3/6/2019 10:34 AM, Ray Harden wrote:

Two Analog_Bridge files attached

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 9:08 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Run each instance from the command line and capture the output.

On 3/6/2019 10:06 AM, Ray Harden wrote:

Trouble getting the logs … the /var/log/ folder contains both Bridge_DMR and Bridge_P25 logs, one file each, not the usual log files created by days.

 

For some reason the logs are not being created or otherwise certainly not in the /var/log folder.

 

The two files I do find have data from 2019-03-04. I guess it’s possible I did something to stop the logging – have no idea how to get it going again.

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRSP
Sent: Wednesday, March 6, 2019 8:05 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Ray,
If I remember correctly You are trying to connect your P25 repeater to DMR. You sent pretty complete config files and logs. I requested to see the logs from the two instances of Analog_Bridge during the test. You should be able to run each instance in the foreground and capture the output or grab the log files.

73, Steve N4IRS

On 3/6/2019 8:52 AM, Ray Harden wrote:

Please tell us how your DVSwitch interacts with MMDVM Client so I can attempt debug.

Turning my attention to the P25/MMDVM/MSF5000 Client radio:

My Motorola MSF5000/MMDVM system has been a functional P25 repeater for about a year.

  -- MMDVM is running on a RPi at 192.168.3.130

  -- MMDVM DMR Network is enabled: Address=3102.repeater.net, Port 62031 enabled, Port 62032 enabled

  -- MMDVM DMR is NOT enabled

  -- MMDVM P25 is enabled: NAC=293

  --  MMDVM P25 Network is enabled: Gateway Port 42020 enabled,  Local Port 32010 enabled

  --  P25Gateway is enabled: RptrPort Port 32010 enabled, LocalPort 42020 enabled, [Network] Port 42010 enabled

  --  P25Gateway [Network] Startup TG= 31900

  --  P25Hosts file: Includes TG 31900  192.168.3.4  41000, as well as all the other 10xxx (FQDN)  41000 TalkGroups

Is there any other requirement for the MMDVM Client to communicate with your DVSwitch system and back again?

The P25/MMDVM/MSF5000 client and the DVSwitch systems, each running on their own RPi are configured within my Local Area Network domain 192.168.3.xx.  Router is configured to PortForward 41000 TCP/UDP to 192.168.3.130.

Thank you very much for any assistance.

73   w0ray

 

 

 



Ray Harden
 


Image





From: Steve N4IRS
Sent: Wednesday, March 6, 09:50
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR
To: main@dvswitch.groups.io


Observations:
Back off agcGain -> 60 That is way too hot. Bring it down to 5
Do you have the emulator installed?
ls /opt/md380-emu
Is it running?
ps ax | grep md380
Is it listening on the default port (2470)?
netstat -unap | grep md380

If all above are true, on your Analog_Bridge for DMR, turn on the emulator and retest.
Analog_Bridge generates a single log file Analog_Bridge.log by default it goes to /var/log.
The environment variable AnalogBridgeLogDir defines the location of the log file if you want it somewhere else.
The systemd unit file /lib/systemd/system/analog_bridge.system set this variable with:
Environment=AnalogBridgeLogDir=/var/log/dvswitch/Analog_Bridge

If you are starting your 2 instances of Analog_Bridge with system units, you want to point these two environment variable to different directories.

Steve N4IRS 


On 3/6/2019 10:34 AM, Ray Harden wrote:
Two Analog_Bridge files attached
 
From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 9:08 AM
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR
 
Run each instance from the command line and capture the output.
On 3/6/2019 10:06 AM, Ray Harden wrote:
Trouble getting the logs … the /var/log/ folder contains both Bridge_DMR and Bridge_P25 logs, one file each, not the usual log files created by days.
 
For some reason the logs are not being created or otherwise certainly not in the /var/log folder.
 
The two files I do find have data from 2019-03-04. I guess it’s possible I did something to stop the logging – have no idea how to get it going again.
From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRSP
Sent: Wednesday, March 6, 2019 8:05 AM
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR
 
Ray,
If I remember correctly You are trying to connect your P25 repeater to DMR. You sent pretty complete config files and logs. I requested to see the logs from the two instances of Analog_Bridge during the test. You should be able to run each instance in the foreground and capture the output or grab the log files.

73, Steve N4IRS
On 3/6/2019 8:52 AM, Ray Harden wrote:
Please tell us how your DVSwitch interacts with MMDVM Client so I can attempt debug.
Turning my attention to the P25/MMDVM/MSF5000 Client radio:
My Motorola MSF5000/MMDVM system has been a functional P25 repeater for about a year.
  -- MMDVM is running on a RPi at 192.168.3.130
  -- MMDVM DMR Network is enabled: Address=3102.repeater.net, Port 62031 enabled, Port 62032 enabled
  -- MMDVM DMR is NOT enabled
  -- MMDVM P25 is enabled: NAC=293
  --  MMDVM P25 Network is enabled: Gateway Port 42020 enabled,  Local Port 32010 enabled
  --  P25Gateway is enabled: RptrPort Port 32010 enabled, LocalPort 42020 enabled, [Network] Port 42010 enabled
  --  P25Gateway [Network] Startup TG= 31900
  --  P25Hosts file: Includes TG 31900  192.168.3.4  41000, as well as all the other 10xxx (FQDN)  41000 TalkGroups
Is there any other requirement for the MMDVM Client to communicate with your DVSwitch system and back again?
The P25/MMDVM/MSF5000 client and the DVSwitch systems, each running on their own RPi are configured within my Local Area Network domain 192.168.3.xx.  Router is configured to PortForward 41000 TCP/UDP to 192.168.3.130.
Thank you very much for any assistance.
73   w0ray
 
 
 




Steve N4IRS
 

Do you have debug turned on in MMDV_Bridge or the gateway?  Please show a snip from DMR to P25 from each program. Same time frame on all.

Sent via smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Ray Harden <w0ray@...>
Sent: Wednesday, March 6, 2019 11:57:32 AM
To: main@dvswitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR
 
Yes md380 is running @ 2470, emulator is turned on, retest, have no PTT or audio from MSF500-P25 or transfer to TG3119 @ Brandmeister.

The P25 Gateway terminal screen rolls with hex packets, same for MMDVM_Bridge with packets from Brandmeister.

We must be getting closer - I hope


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Steve N4IRS <szingman@...>
Sent: Wednesday, March 6, 2019 9:50:17 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR
 
Observations:
Back off agcGain -> 60 That is way too hot. Bring it down to 5
Do you have the emulator installed?
ls /opt/md380-emu
Is it running?
ps ax | grep md380
Is it listening on the default port (2470)?
netstat -unap | grep md380

If all above are true, on your Analog_Bridge for DMR, turn on the emulator and retest.
Analog_Bridge generates a single log file Analog_Bridge.log by default it goes to /var/log.
The environment variable AnalogBridgeLogDir defines the location of the log file if you want it somewhere else.
The systemd unit file /lib/systemd/system/analog_bridge.system set this variable with:
Environment=AnalogBridgeLogDir=/var/log/dvswitch/Analog_Bridge

If you are starting your 2 instances of Analog_Bridge with system units, you want to point these two environment variable to different directories.

Steve N4IRS 


On 3/6/2019 10:34 AM, Ray Harden wrote:

Two Analog_Bridge files attached

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 9:08 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Run each instance from the command line and capture the output.

On 3/6/2019 10:06 AM, Ray Harden wrote:

Trouble getting the logs … the /var/log/ folder contains both Bridge_DMR and Bridge_P25 logs, one file each, not the usual log files created by days.

 

For some reason the logs are not being created or otherwise certainly not in the /var/log folder.

 

The two files I do find have data from 2019-03-04. I guess it’s possible I did something to stop the logging – have no idea how to get it going again.

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRSP
Sent: Wednesday, March 6, 2019 8:05 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Ray,
If I remember correctly You are trying to connect your P25 repeater to DMR. You sent pretty complete config files and logs. I requested to see the logs from the two instances of Analog_Bridge during the test. You should be able to run each instance in the foreground and capture the output or grab the log files.

73, Steve N4IRS

On 3/6/2019 8:52 AM, Ray Harden wrote:

Please tell us how your DVSwitch interacts with MMDVM Client so I can attempt debug.

Turning my attention to the P25/MMDVM/MSF5000 Client radio:

My Motorola MSF5000/MMDVM system has been a functional P25 repeater for about a year.

  -- MMDVM is running on a RPi at 192.168.3.130

  -- MMDVM DMR Network is enabled: Address=3102.repeater.net, Port 62031 enabled, Port 62032 enabled

  -- MMDVM DMR is NOT enabled

  -- MMDVM P25 is enabled: NAC=293

  --  MMDVM P25 Network is enabled: Gateway Port 42020 enabled,  Local Port 32010 enabled

  --  P25Gateway is enabled: RptrPort Port 32010 enabled, LocalPort 42020 enabled, [Network] Port 42010 enabled

  --  P25Gateway [Network] Startup TG= 31900

  --  P25Hosts file: Includes TG 31900  192.168.3.4  41000, as well as all the other 10xxx (FQDN)  41000 TalkGroups

Is there any other requirement for the MMDVM Client to communicate with your DVSwitch system and back again?

The P25/MMDVM/MSF5000 client and the DVSwitch systems, each running on their own RPi are configured within my Local Area Network domain 192.168.3.xx.  Router is configured to PortForward 41000 TCP/UDP to 192.168.3.130.

Thank you very much for any assistance.

73   w0ray

 

 

 



Steve N4IRS
 

Turn off debug in each program.
Can you send actual text files?
I do see "No response from 31900, unlinking on the gateway.

On 3/6/2019 12:06 PM, Ray Harden wrote:

Image





From: Steve N4IRS
Sent: Wednesday, March 6, 09:50
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR
Observations:
Back off agcGain -> 60 That is way too hot. Bring it down to 5
Do you have the emulator installed?
ls /opt/md380-emu
Is it running?
ps ax | grep md380
Is it listening on the default port (2470)?
netstat -unap | grep md380

If all above are true, on your Analog_Bridge for DMR, turn on the emulator and retest.
Analog_Bridge generates a single log file Analog_Bridge.log by default it goes to /var/log.
The environment variable AnalogBridgeLogDir defines the location of the log file if you want it somewhere else.
The systemd unit file /lib/systemd/system/analog_bridge.system set this variable with:
Environment=AnalogBridgeLogDir=/var/log/dvswitch/Analog_Bridge

If you are starting your 2 instances of Analog_Bridge with system units, you want to point these two environment variable to different directories.

Steve N4IRS 


On 3/6/2019 10:34 AM, Ray Harden wrote:
Two Analog_Bridge files attached
 
From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 9:08 AM
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR
 
Run each instance from the command line and capture the output.
On 3/6/2019 10:06 AM, Ray Harden wrote:
Trouble getting the logs … the /var/log/ folder contains both Bridge_DMR and Bridge_P25 logs, one file each, not the usual log files created by days.
 
For some reason the logs are not being created or otherwise certainly not in the /var/log folder.
 
The two files I do find have data from 2019-03-04. I guess it’s possible I did something to stop the logging – have no idea how to get it going again.
From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRSP
Sent: Wednesday, March 6, 2019 8:05 AM
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR
 
Ray,
If I remember correctly You are trying to connect your P25 repeater to DMR. You sent pretty complete config files and logs. I requested to see the logs from the two instances of Analog_Bridge during the test. You should be able to run each instance in the foreground and capture the output or grab the log files.

73, Steve N4IRS
On 3/6/2019 8:52 AM, Ray Harden wrote:
Please tell us how your DVSwitch interacts with MMDVM Client so I can attempt debug.
Turning my attention to the P25/MMDVM/MSF5000 Client radio:
My Motorola MSF5000/MMDVM system has been a functional P25 repeater for about a year.
  -- MMDVM is running on a RPi at 192.168.3.130
  -- MMDVM DMR Network is enabled: Address=3102.repeater.net, Port 62031 enabled, Port 62032 enabled
  -- MMDVM DMR is NOT enabled
  -- MMDVM P25 is enabled: NAC=293
  --  MMDVM P25 Network is enabled: Gateway Port 42020 enabled,  Local Port 32010 enabled
  --  P25Gateway is enabled: RptrPort Port 32010 enabled, LocalPort 42020 enabled, [Network] Port 42010 enabled
  --  P25Gateway [Network] Startup TG= 31900
  --  P25Hosts file: Includes TG 31900  192.168.3.4  41000, as well as all the other 10xxx (FQDN)  41000 TalkGroups
Is there any other requirement for the MMDVM Client to communicate with your DVSwitch system and back again?
The P25/MMDVM/MSF5000 client and the DVSwitch systems, each running on their own RPi are configured within my Local Area Network domain 192.168.3.xx.  Router is configured to PortForward 41000 TCP/UDP to 192.168.3.130.
Thank you very much for any assistance.
73   w0ray
 
 
 





Ray Harden
 

Sorry for the delay … took some time to delete the unwanted lines  … both files are close in time segments … I was already in the process before I saw your  message about Debug Off

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 11:28 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Turn off debug in each program.
Can you send actual text files?
I do see "No response from 31900, unlinking on the gateway.


Steve N4IRS
 

OK, here is what I need.
Run MMDVM_Bridge Analog_Bridge_DMR Analog_Bridge_P25 P25Gateway all at the same time. Let everything startup and settle. Give me one transmission from a user with a DMR radio. The give me one transmission with a P25 radio. Capture the output from each program in a file then zip it up and send it.

On 3/6/2019 2:32 PM, Ray Harden wrote:

Sorry for the delay … took some time to delete the unwanted lines  … both files are close in time segments … I was already in the process before I saw your  message about Debug Off

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 11:28 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Turn off debug in each program.
Can you send actual text files?
I do see "No response from 31900, unlinking on the gateway.



Ray Harden
 

Debug on or off, all or which ones?


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Steve N4IRS <szingman@...>
Sent: Wednesday, March 6, 2019 1:40:35 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

OK, here is what I need.
Run MMDVM_Bridge Analog_Bridge_DMR Analog_Bridge_P25 P25Gateway all at the same time. Let everything startup and settle. Give me one transmission from a user with a DMR radio. The give me one transmission with a P25 radio. Capture the output from each program in a file then zip it up and send it.

On 3/6/2019 2:32 PM, Ray Harden wrote:

Sorry for the delay … took some time to delete the unwanted lines  … both files are close in time segments … I was already in the process before I saw your  message about Debug Off

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 11:28 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Turn off debug in each program.
Can you send actual text files?
I do see "No response from 31900, unlinking on the gateway.

 


Steve N4IRS
 

All off

On 3/6/2019 3:00 PM, Ray Harden wrote:

Debug on or off, all or which ones?


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Steve N4IRS <szingman@...>
Sent: Wednesday, March 6, 2019 1:40:35 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

OK, here is what I need.
Run MMDVM_Bridge Analog_Bridge_DMR Analog_Bridge_P25 P25Gateway all at the same time. Let everything startup and settle. Give me one transmission from a user with a DMR radio. The give me one transmission with a P25 radio. Capture the output from each program in a file then zip it up and send it.

On 3/6/2019 2:32 PM, Ray Harden wrote:

Sorry for the delay … took some time to delete the unwanted lines  … both files are close in time segments … I was already in the process before I saw your  message about Debug Off

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 11:28 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Turn off debug in each program.
Can you send actual text files?
I do see "No response from 31900, unlinking on the gateway.

 



Ray Harden
 

Cannot restart test due to P25Reflector gives message on startup:

 

  /cd /usr/local/bin

  ./P25Reflector.sh start /etc/P25Reflector.ini &

         GIVES MSG:  ./P25Reflector.sh   Line 20  1145 segmentation fault:  ./prog  $prog.args

 

I don’t know how to fix this.

 

RayH  w0ray

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 1:41 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

OK, here is what I need.
Run MMDVM_Bridge Analog_Bridge_DMR Analog_Bridge_P25 P25Gateway all at the same time. Let everything startup and settle. Give me one transmission from a user with a DMR radio. The give me one transmission with a P25 radio. Capture the output from each program in a file then zip it up and send it.

On 3/6/2019 2:32 PM, Ray Harden wrote:

Sorry for the delay … took some time to delete the unwanted lines  … both files are close in time segments … I was already in the process before I saw your  message about Debug Off

 

From: main@DVSwitch.groups.io [mailto:main@DVSwitch.groups.io] On Behalf Of Steve N4IRS
Sent: Wednesday, March 6, 2019 11:28 AM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Problem Description: No Audio @ P25 radio, No Audio DMR from Bridge P25 <<-->> DMR

 

Turn off debug in each program.
Can you send actual text files?
I do see "No response from 31900, unlinking on the gateway.

 


Tim Porter
 

i got a question steve? is dvswitch only for node owners> got a node giveing me a hard time over this and am wondering who is rite? can you put a little comment on this for me thanksTim
k4kwq