Topics

HBMonitor help #hblink


ocascante@...
 

Hello, i am newbie triying to install hblink and hbmonitor on Linux Mint 19.
Hblink is running ok but i got this error with hbmonitor:
Traceback (most recent call last):
  File "./web_tables.py", line 627, in <module>
    talkgroup_ids = mk_full_id_dict(PATH, TGID_FILE, 'tgid')
  File "/home/ocascante/.local/lib/python2.7/site-packages/dmr_utils/utils.py", line 118, in mk_full_id_dict
    records = jload(_handle)['results']
  File "/usr/lib/python2.7/json/__init__.py", line 291, in load
    **kw)
  File "/usr/lib/python2.7/json/__init__.py", line 339, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/decoder.py", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/decoder.py", line 380, in raw_decode
    obj, end = self.scan_once(s, idx)
ValueError: Expecting property name: line 7 column 5 (char 101)

Thanks for any help!!


Cort N0MJS <n0mjs@...>
 

Next time it gets pulled down again

If there are any complaints or further posts about it, HBlink itself comes down.


On Mar 22, 2019, at 3:56 PM, ocascante@... wrote:

Hello, i am newbie triying to install hblink and hbmonitor on Linux Mint 19.
Hblink is running ok but i got this error with hbmonitor:
Traceback (most recent call last):
  File "./web_tables.py", line 627, in <module>
    talkgroup_ids = mk_full_id_dict(PATH, TGID_FILE, 'tgid')
  File "/home/ocascante/.local/lib/python2.7/site-packages/dmr_utils/utils.py", line 118, in mk_full_id_dict
    records = jload(_handle)['results']
  File "/usr/lib/python2.7/json/__init__.py", line 291, in load
    **kw)
  File "/usr/lib/python2.7/json/__init__.py", line 339, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/decoder.py", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/decoder.py", line 380, in raw_decode
    obj, end = self.scan_once(s, idx)
ValueError: Expecting property name: line 7 column 5 (char 101)

Thanks for any help!!

--
Cort Buffington
H: +1-785-813-1501
M: +1-785-865-7206






Corey Dean N3FE <n3fe@...>
 

Just a few days ago a post was made about hbmonitor.  Does anyone take the time to look through the message history?

On Fri, Mar 22, 2019 at 4:58 PM <ocascante@...> wrote:
Hello, i am newbie triying to install hblink and hbmonitor on Linux Mint 19.
Hblink is running ok but i got this error with hbmonitor:
Traceback (most recent call last):
  File "./web_tables.py", line 627, in <module>
    talkgroup_ids = mk_full_id_dict(PATH, TGID_FILE, 'tgid')
  File "/home/ocascante/.local/lib/python2.7/site-packages/dmr_utils/utils.py", line 118, in mk_full_id_dict
    records = jload(_handle)['results']
  File "/usr/lib/python2.7/json/__init__.py", line 291, in load
    **kw)
  File "/usr/lib/python2.7/json/__init__.py", line 339, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/decoder.py", line 364, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/decoder.py", line 380, in raw_decode
    obj, end = self.scan_once(s, idx)
ValueError: Expecting property name: line 7 column 5 (char 101)

Thanks for any help!!


Oscar Fonseca <ocascante@...>
 

Thanks for you help!!!


is0hha62@...
 

Hello Dear Cort N0MJS and all.
I have installed HBlink ed HBmonitor on my Raspberry Pi3 B+ and all is working well.
Now i am testing the HBlink3 that uses Python3 , but HBmonitor is not compatible . I have try to install also the python2 packages for compatibility,
but it don't works. Always the some errors on about compatibility .
There is a solution or i must expect a new release of HBmonitor (HBmonitor3) ???
I want use HBlink3 because it has a perfect configuration for XLX , but the monitoring software is a must have for all users of my system.
Can we help me ???
Thanks in advance .
Best regards and 73 de Tony IS0HHA


Steve KC1AWV
 

HBmonitor is unsupported. Please read the README and pay special attention to the first line where it says:

COMPLETELY UNSUPPORTED SOFTWARE - DO NOT ASK FOR SUPPORT OR FEATURES

People seem to be ignoring this, and still expect or request support. Cort N0MJS has warned us in the past about ignoring his messages, please do not request support here.

Steve KC1AWV


psi_admin@...
 

Try this script it will install HBlink and HBmonitor and both working(for me on several different machines incliding Raspberry Pi3 B+ and Raspberry Pi4 B)

https://github.com/kotuk/HBlink_install


SP2ONG Waldek
 

Steve KC1AWV

Okay, clear, but nothing prevents someone from responding to the topic in the hbmonitor if it can help, which is very helpful in monitoring the server's hblink work.
Many people use hbmonitor it and work even at the stage where it was made and it is worth using.

73 Waldek