Topics

Hytera DMR Gateway


Chris WB4ULK
 

I know this isn't a DV Switch product, but figure it works much the same.
I deployed this to connect my Hytera repeaters into my HBlink3 instance.
It has worked very well so far, but I have a small issue and have not been able to find any info on it.

When I first deployed it, I set it up with just a hotspot ID and everything worked great from the test repeater at the house. The only issue was how TG's didn't disconnect after 15 mins. Typical hotspot behavior. I burned it in a couple of weeks at home and then took it to he repeater site.
It is setup to pass our local TG to the cluster only and everything else goes out across BM, using TGRewrite rules, so it logs into my HBLink3 instance and BM 3102.

I had a conversation with one of the BM administrators and he said let him know and he would set the ID up for a repeater.
Thinking about that, I figured "Hey, my repeater ID that is already affiliated would work. The actual repeater is behind the Hytera DMR Gateway instance, so I will have IT log into BM as the old repeater ID."

Once I changed this, it logged in and worked fine, but after awhile, it times out to BM and never comes back.
I am pointing it to BM on port 62030 for MMDVM repeaters with passw0rd. I found this info on the BM site.
I am using repeater ID 311342 which was already under "My Repeaters"

Any Ideas what difference it made once I changed the ID#?

I am posting my configs and logs below, maybe someone could peek at it and figure out what I may change.
Again, it works fine when using a hotspot id like 311372204, but times out using 311342.

Thanks,
Chris

DMRGateway.ini


[General]

Timeout=20

RptAddress=127.0.0.1

RptPort=62032

LocalAddress=127.0.0.1

LocalPort=62039

RuleTrace=0

Daemon=0

Debug=0

 

[Log]

# Logging levels, 0=No logging

DisplayLevel=1

FileLevel=1

FilePath=.

FileRoot=DMRGateway

 

[Voice]

Enabled=1

Language=de_DE

Directory=/opt/DMRGateway/Audio

 

[XLX Network]

Enabled=0

File=/opt/DMRGateway/XLXHosts.txt

Port=62030

Password=passw0rd

ReloadTime=60

# Local=3351

Slot=1

TG=6

Base=64000

Startup=232

Relink=180

Debug=0

Id=123456

 

# Brandmeister

[DMR Network 1]

Enabled=1

Address=?????????

Port=62030

TGRewrite=

PCRewrite=1

PassAllTG=1

PassAllTG=2

PassAllPC=1

Password=???????

Debug=0

Id=311342

Name=BM_United_States_3102

 

# WB4ULK

[DMR Network 2]

Enabled=1

Address=?????????

Port=62036

TGRewrite=2,2,2,2,1

PCRewrite=

Password=passw0rd

Debug=0

Id=311372209

Name=WB4ULK_Network

 

# DMR+ IPSC2 OE2

[DMR Network 3]

Enabled=0

Address=12.234.567.89

Port=55555

Password=PASSWORD

Debug=0

Id=123456

gw_hytera_mmdvm.ini



####################################################################################

## hytera_mmdvm DMRGateway Config by OE1KBC

####################################################################################

 

DMRGateway_address=127.0.0.1

DMRGateway_port=62039

 

DMRGateway_local_address=127.0.0.1

DMRGateway_local_port=62032

 

####################################################################################

## hytera_mmdvm DMRGateway Repeater Ports

####################################################################################

 

Hytera_RPT_PORT=62005

Hytera_RPT_AUDIO_PORT=62006

Hytera_RPT_RDAC_PORT=62007

 

####################################################################################

## hytera_mmdvm DMRGateway Location

####################################################################################

 

Location_Name=Columbus, GA

Location_Latitude=+47.1234

Location_Longitude=+08.1234

Location_Homepage=http://www.wb4ulk.com

Location_Watt=50

Location_CC=01

 

####################################################################################

# sysop mailaddress and DMR ID

####################################################################################

 

SYSOPEMAIL=chood73@...

SYSOP_ID=3113722

 

 Log

M: 2019-06-17 12:29:53.121 BM_United_States_3102, Opening DMR Network

E: 2019-06-17 12:31:03.146 BM_United_States_3102, Connection to the master has timed out, retrying connection

M: 2019-06-17 12:31:03.146 BM_United_States_3102, Closing DMR Network

M: 2019-06-17 12:31:03.146 BM_United_States_3102, Opening DMR Network

E: 2019-06-17 12:32:13.170 BM_United_States_3102, Connection to the master has timed out, retrying connection

M: 2019-06-17 12:32:13.170 BM_United_States_3102, Closing DMR Network

M: 2019-06-17 12:32:13.171 BM_United_States_3102, Opening DMR Network

 

 


Joshua Nulton
 

Completely unrelated, but I just watched one of your videos this morning while doing dishes and commented. You're putting out great content that's easy for a beginner to follow, I like that. Though I'm not a beginner, when I watch other people's videos I try to imagine my father following the video. I admire when someone can communicate as well as you do. I hope you keep up the work.


On Mon, Jun 17, 2019, 7:52 AM Chris WB4ULK via Groups.Io <chood73=yahoo.com@groups.io> wrote:
I know this isn't a DV Switch product, but figure it works much the same.
I deployed this to connect my Hytera repeaters into my HBlink3 instance.
It has worked very well so far, but I have a small issue and have not been able to find any info on it.

When I first deployed it, I set it up with just a hotspot ID and everything worked great from the test repeater at the house. The only issue was how TG's didn't disconnect after 15 mins. Typical hotspot behavior. I burned it in a couple of weeks at home and then took it to he repeater site.
It is setup to pass our local TG to the cluster only and everything else goes out across BM, using TGRewrite rules, so it logs into my HBLink3 instance and BM 3102.

I had a conversation with one of the BM administrators and he said let him know and he would set the ID up for a repeater.
Thinking about that, I figured "Hey, my repeater ID that is already affiliated would work. The actual repeater is behind the Hytera DMR Gateway instance, so I will have IT log into BM as the old repeater ID."

Once I changed this, it logged in and worked fine, but after awhile, it times out to BM and never comes back.
I am pointing it to BM on port 62030 for MMDVM repeaters with passw0rd. I found this info on the BM site.
I am using repeater ID 311342 which was already under "My Repeaters"

Any Ideas what difference it made once I changed the ID#?

I am posting my configs and logs below, maybe someone could peek at it and figure out what I may change.
Again, it works fine when using a hotspot id like 311372204, but times out using 311342.

Thanks,
Chris

DMRGateway.ini


[General]

Timeout=20

RptAddress=127.0.0.1

RptPort=62032

LocalAddress=127.0.0.1

LocalPort=62039

RuleTrace=0

Daemon=0

Debug=0

 

[Log]

# Logging levels, 0=No logging

DisplayLevel=1

FileLevel=1

FilePath=.

FileRoot=DMRGateway

 

[Voice]

Enabled=1

Language=de_DE

Directory=/opt/DMRGateway/Audio

 

[XLX Network]

Enabled=0

File=/opt/DMRGateway/XLXHosts.txt

Port=62030

Password=passw0rd

ReloadTime=60

# Local=3351

Slot=1

TG=6

Base=64000

Startup=232

Relink=180

Debug=0

Id=123456

 

# Brandmeister

[DMR Network 1]

Enabled=1

Address=?????????

Port=62030

TGRewrite=

PCRewrite=1

PassAllTG=1

PassAllTG=2

PassAllPC=1

Password=???????

Debug=0

Id=311342

Name=BM_United_States_3102

 

# WB4ULK

[DMR Network 2]

Enabled=1

Address=?????????

Port=62036

TGRewrite=2,2,2,2,1

PCRewrite=

Password=passw0rd

Debug=0

Id=311372209

Name=WB4ULK_Network

 

# DMR+ IPSC2 OE2

[DMR Network 3]

Enabled=0

Address=12.234.567.89

Port=55555

Password=PASSWORD

Debug=0

Id=123456

gw_hytera_mmdvm.ini



####################################################################################

## hytera_mmdvm DMRGateway Config by OE1KBC

####################################################################################

 

DMRGateway_address=127.0.0.1

DMRGateway_port=62039

 

DMRGateway_local_address=127.0.0.1

DMRGateway_local_port=62032

 

####################################################################################

## hytera_mmdvm DMRGateway Repeater Ports

####################################################################################

 

Hytera_RPT_PORT=62005

Hytera_RPT_AUDIO_PORT=62006

Hytera_RPT_RDAC_PORT=62007

 

####################################################################################

## hytera_mmdvm DMRGateway Location

####################################################################################

 

Location_Name=Columbus, GA

Location_Latitude=+47.1234

Location_Longitude=+08.1234

Location_Homepage=http://www.wb4ulk.com

Location_Watt=50

Location_CC=01

 

####################################################################################

# sysop mailaddress and DMR ID

####################################################################################

 

SYSOPEMAIL=chood73@...

SYSOP_ID=3113722

 

 Log

M: 2019-06-17 12:29:53.121 BM_United_States_3102, Opening DMR Network

E: 2019-06-17 12:31:03.146 BM_United_States_3102, Connection to the master has timed out, retrying connection

M: 2019-06-17 12:31:03.146 BM_United_States_3102, Closing DMR Network

M: 2019-06-17 12:31:03.146 BM_United_States_3102, Opening DMR Network

E: 2019-06-17 12:32:13.170 BM_United_States_3102, Connection to the master has timed out, retrying connection

M: 2019-06-17 12:32:13.170 BM_United_States_3102, Closing DMR Network

M: 2019-06-17 12:32:13.171 BM_United_States_3102, Opening DMR Network

 

 


Chris WB4ULK
 

Well, thank you! Now if I can get the rest of it working. Lol


Jake Litwin
 

Hi Chris,

Not sure if you're still following this thread. Great video on this! I had a similar problem but found the solution. It's been working nicely.

DMRGateway.ini


[General]

Timeout=0  <----- Changed to Zero

 


Chris K7AZ
 

Hi Jake, I am still following.  
Will try zero as you suggest.  
Was there a link to the video?

When I go to use transcoder after a several day unused period, I find I have to reboot the ASL system.  Have you heard of similiar ?   This is running on a VM platform.  

Thanks,
Chris K7AZ 



Sent from my Verizon, Samsung Galaxy smartphone


-------- Original message --------
From: Jake Litwin <litwinjwi@...>
Date: 12/9/19 20:43 (GMT-08:00)
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] Hytera DMR Gateway

Hi Chris,

Not sure if you're still following this thread. Great video on this! I had a similar problem but found the solution. It's been working nicely.

DMRGateway.ini


[General]

Timeout=0  <----- Changed to Zero

 


Marco IW0RED
 
Edited

Hi, 
I am trying to connect my hytera repeater with hytera dmr gateway (I had followed the video) but it doesn't work. 
The error is:
./gw_hytera_mmdvm: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory
I checked with apt but I can't find  libcrypto.so.1.0.0
What can I do?
73 Marco IW0RED


EA5GVK Joaquin
 

Hi Marco, it is version linux.
I have running hytera gw mmdvm, perfect.
the connection to the XLX by mmdvm, the audio is cut, in the direction of the XLX to the Repeater Hytera rd625 PERFECT.
BUT IN SENSE REPEATER TO XLX, THE AUDIO IS CUTTED TWO SECONDS TO BEGIN.
CAN YOU HELP OR GUIDE ME?
thanks.
Happy New Year.
PD: Firmware rd625 hytera A9.00.10.100.iM


Marco IW0RED
 

Hi Joaquin, I don't have one raspberry 3 (it is too old) but only one
raspberry 3+ that doesn't run debian Jessie.
Do you have the source code of the hytera gw mmdvm software?
I'm sorry but I don't use the mmdvm to xlx bridge.
73 Marco IW0RED.
Happy New Year.

On Wed, Dec 25, 2019 at 11:06 AM EA5GVK Joaquin <ea5gvk@...> wrote:

Hi Marco, it is version linux.
I have running hytera gw mmdvm, perfect.
the connection to the XLX by mmdvm, the audio is cut, in the direction of the XLX to the Repeater Hytera rd625 PERFECT.
BUT IN SENSE REPEATER TO XLX, THE AUDIO IS CUTTED TWO SECONDS TO BEGIN.
CAN YOU HELP OR GUIDE ME?
thanks.
Happy New Year.
PD: Firmware rd625 hytera A9.00.10.100.iM
--
Marco Brunozzi

Tel. +14152360004
Cel. +393483343274
Skype: marco.brunozzi
Twitter: marcobrunozzi
---------------------------------------


EA5GVK Joaquin
 

I have tried the hytera gw with the dmrgateway. AND IT WORKS PERFECTLY TO CONNECT TO BRANDMEISTER AND DMR +
BUT HBLINK HAS PROBLEMS:
If the TG of the HBLINK, in turn is linked to other systems, for example to an XLX, the audio in the direction of the HBLINK to XLX does not come out. However, in the sense of XLX to HBLINK, yes.
That is

HYTERA-GW -> DMRGATEWAY -> HBLINK - TGLINK TO XLX -> DOES NOT WORK.

AND HOWEVER TO THE CONTRARY IF

HBLINK-TG LINK TO XLX -> DMRGATEWAY -> HYTERA-GW -> WORK PERFECTLY.

CAN SOMEBODY HELP ME.


Kim-Benjamin Lütkemeier
 
Edited

Someone has a solution for this?
./gw_hytera_mmdvm: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory
I checked with apt but I can't find  libcrypto.so.1.0.0


I Try to install it on a Pi3+ with raspian buster


Steve N4IRS
 

On 1/10/2020 2:38 PM, Kim-Benjamin Lütkemeier via Groups.Io wrote:

[Edited Message Follows]

Someone has a solution for this?
./gw_hytera_mmdvm: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory
I checked with apt but I can't find  libcrypto.so.1.0.0


I Try to install it on a Pi3+ with raspian buster


Adrian Fewster <vk4tux@...>
 

Try

sudo apt-get install libssl1.0.0 libssl-dev --reinstall


On 11/1/20 5:38 am, Kim-Benjamin Lütkemeier via Groups.Io wrote:
error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file


KK4ZMG Richard
 

I am having some difficulties getting gw_hytera_mmdvm to work on a raspberry pi 3 running Rasbian buster. It appears to be looking for an old version of openssh-1.0.0 but buster only has openssl-1.1  so it cannot find a bunch of the library.  Is there a way to update the gw_hytera_mmdvm to change it to look for the newer version of openssl?

Thanks
Richard KK4zmg


Steve N4IRS
 

Richard,
We have nothing to do with gw_hytera_mmdvm. I suggest you check with the author. You might be able to so a symlink to fool gw_hytera_mmdvm.

Steve N4IRS

On 5/5/20 5:07 PM, KK4ZMG Richard via groups.io wrote:
I am having some difficulties getting gw_hytera_mmdvm to work on a raspberry pi 3 running Rasbian buster. It appears to be looking for an old version of openssh-1.0.0 but buster only has openssl-1.1  so it cannot find a bunch of the library.  Is there a way to update the gw_hytera_mmdvm to change it to look for the newer version of openssl?

Thanks
Richard KK4zmg


KK4ZMG Richard
 

That's what I kinda figured. Was hoping some one else ran into this. Ill try to do the sim link.  Thanks


Steve N4IRS
 

No promise that it will work, just what I would try.

On 5/5/20 5:39 PM, KK4ZMG Richard via groups.io wrote:
That's what I kinda figured. Was hoping some one else ran into this. Ill try to do the sim link.  Thanks


Dexter Harroo
 

Hi Steve can you provide info, I know it can be done, but I'm scouring the forum and I just can't find the info I need. PS see below.

Hi guys I hope I"m in the right group, I am building a multimode system,  ASL <-----> DMR <-----> YSF <------> P25 <------> DStar, and i will like to use DVSwitch mobile to connect to it, can anyone point me to where i will find information  to achieve this?
I already have ASL linked to DMR and DMR linked YSF working. Do I use HBlink for the XLX to DMR connection, and How do I connect to these Using DVswitch Mobile on my phone?


Best 73
Dexter Harroo
        9Y4C


On Tue, May 5, 2020, 17:29 Steve N4IRS <szingman@...> wrote:
Richard,
We have nothing to do with gw_hytera_mmdvm. I suggest you check with the author. You might be able to so a symlink to fool gw_hytera_mmdvm.

Steve N4IRS

On 5/5/20 5:07 PM, KK4ZMG Richard via groups.io wrote:
I am having some difficulties getting gw_hytera_mmdvm to work on a raspberry pi 3 running Rasbian buster. It appears to be looking for an old version of openssh-1.0.0 but buster only has openssl-1.1  so it cannot find a bunch of the library.  Is there a way to update the gw_hytera_mmdvm to change it to look for the newer version of openssl?

Thanks
Richard KK4zmg


Steve N4IRS
 

Someone posted info on this. The idea is to use ASL to bridge everything. Setup a node for each mode and use ASL to mix them.

On 5/5/20 6:17 PM, Dexter Harroo wrote:
Hi Steve can you provide info, I know it can be done, but I'm scouring the forum and I just can't find the info I need. PS see below.

Hi guys I hope I"m in the right group, I am building a multimode system,  ASL <-----> DMR <-----> YSF <------> P25 <------> DStar, and i will like to use DVSwitch mobile to connect to it, can anyone point me to where i will find information  to achieve this?
I already have ASL linked to DMR and DMR linked YSF working. Do I use HBlink for the XLX to DMR connection, and How do I connect to these Using DVswitch Mobile on my phone?


Best 73
Dexter Harroo
        9Y4C

On Tue, May 5, 2020, 17:29 Steve N4IRS <szingman@...> wrote:
Richard,
We have nothing to do with gw_hytera_mmdvm. I suggest you check with the author. You might be able to so a symlink to fool gw_hytera_mmdvm.

Steve N4IRS

On 5/5/20 5:07 PM, KK4ZMG Richard via groups.io wrote:
I am having some difficulties getting gw_hytera_mmdvm to work on a raspberry pi 3 running Rasbian buster. It appears to be looking for an old version of openssh-1.0.0 but buster only has openssl-1.1  so it cannot find a bunch of the library.  Is there a way to update the gw_hytera_mmdvm to change it to look for the newer version of openssl?

Thanks
Richard KK4zmg



Dexter Harroo
 

So I'm going to need a node for dmr one for ysf one for p25 and one for dstar. 
Thanks I will continue looking around for detailed info

Best 73
Dexter Harroo
        9Y4C


On Tue, May 5, 2020, 18:24 Steve N4IRS <szingman@...> wrote:
Someone posted info on this. The idea is to use ASL to bridge everything. Setup a node for each mode and use ASL to mix them.

On 5/5/20 6:17 PM, Dexter Harroo wrote:
Hi Steve can you provide info, I know it can be done, but I'm scouring the forum and I just can't find the info I need. PS see below.

Hi guys I hope I"m in the right group, I am building a multimode system,  ASL <-----> DMR <-----> YSF <------> P25 <------> DStar, and i will like to use DVSwitch mobile to connect to it, can anyone point me to where i will find information  to achieve this?
I already have ASL linked to DMR and DMR linked YSF working. Do I use HBlink for the XLX to DMR connection, and How do I connect to these Using DVswitch Mobile on my phone?


Best 73
Dexter Harroo
        9Y4C

On Tue, May 5, 2020, 17:29 Steve N4IRS <szingman@...> wrote:
Richard,
We have nothing to do with gw_hytera_mmdvm. I suggest you check with the author. You might be able to so a symlink to fool gw_hytera_mmdvm.

Steve N4IRS

On 5/5/20 5:07 PM, KK4ZMG Richard via groups.io wrote:
I am having some difficulties getting gw_hytera_mmdvm to work on a raspberry pi 3 running Rasbian buster. It appears to be looking for an old version of openssh-1.0.0 but buster only has openssl-1.1  so it cannot find a bunch of the library.  Is there a way to update the gw_hytera_mmdvm to change it to look for the newer version of openssl?

Thanks
Richard KK4zmg



Steve N4IRS
 

Dexter,
Since you already started a thread asking this, I would suggest you keep your questions there. This thread had to do with a Hytera Gateway.
I added some info to your thread.

Steve N4IRS

On 5/5/20 6:17 PM, Dexter Harroo wrote:
Hi Steve can you provide info, I know it can be done, but I'm scouring the forum and I just can't find the info I need. PS see below.

Hi guys I hope I"m in the right group, I am building a multimode system,  ASL <-----> DMR <-----> YSF <------> P25 <------> DStar, and i will like to use DVSwitch mobile to connect to it, can anyone point me to where i will find information  to achieve this?
I already have ASL linked to DMR and DMR linked YSF working. Do I use HBlink for the XLX to DMR connection, and How do I connect to these Using DVswitch Mobile on my phone?


Best 73
Dexter Harroo
        9Y4C

On Tue, May 5, 2020, 17:29 Steve N4IRS <szingman@...> wrote:
Richard,
We have nothing to do with gw_hytera_mmdvm. I suggest you check with the author. You might be able to so a symlink to fool gw_hytera_mmdvm.

Steve N4IRS

On 5/5/20 5:07 PM, KK4ZMG Richard via groups.io wrote:
I am having some difficulties getting gw_hytera_mmdvm to work on a raspberry pi 3 running Rasbian buster. It appears to be looking for an old version of openssh-1.0.0 but buster only has openssl-1.1  so it cannot find a bunch of the library.  Is there a way to update the gw_hytera_mmdvm to change it to look for the newer version of openssl?

Thanks
Richard KK4zmg