Topics

Starting MMDVM_Bridge #mmdvm_bridge


Dexter Harroo
 

Hello Guys,
I try my best to follow instructions and adhere to protocols, but i need your assistance as I have come to a brick wall, I used the Git clone method to get the MMDVM_Bridge package, i followed the the examples for configuring MMDVM_Bridge,ini and DVSwitch.ini, when its time to run the program I use "./MMDVM_Bridge MMDVM_Bridge.ini" but i get an error, please see below for the error

root@depifactory:/opt# ./MMDVM_Bridge MMDVM_Bridge.ini
bash: ./MMDVM_Bridge: Is a directory

Can someone assist me with this issue, i dont know what I am doing wrong


Steve KC1AWV
 

First do this: cd MMDVM_Bridge

Then ./MMDVM_Bridge MMDVM_Bridge.ini

You're outside the directory the executable is in. Like trying to start a car from outside the driver's door ;)

Steve KC1AWV


On Tue, Jun 18, 2019 at 1:00 PM Dexter Harroo <dex.9y4c@...> wrote:
Hello Guys,
I try my best to follow instructions and adhere to protocols, but i need your assistance as I have come to a brick wall, I used the Git clone method to get the MMDVM_Bridge package, i followed the the examples for configuring MMDVM_Bridge,ini and DVSwitch.ini, when its time to run the program I use "./MMDVM_Bridge MMDVM_Bridge.ini" but i get an error, please see below for the error

root@depifactory:/opt# ./MMDVM_Bridge MMDVM_Bridge.ini
bash: ./MMDVM_Bridge: Is a directory

Can someone assist me with this issue, i dont know what I am doing wrong



--
Steve Miller
KC1AWV


Steve N4IRS
 

Depending on where you installed MMDVM_Bridge you should see the executable and the .ini file. If you don't you can not run ./MMDVM_Bridge. The ./ tells Linux, run the program named MMDVM_Bridge in the current directory.

Steve N4IRS

On 6/18/2019 1:00 PM, Dexter Harroo wrote:
Hello Guys,
I try my best to follow instructions and adhere to protocols, but i need your assistance as I have come to a brick wall, I used the Git clone method to get the MMDVM_Bridge package, i followed the the examples for configuring MMDVM_Bridge,ini and DVSwitch.ini, when its time to run the program I use "./MMDVM_Bridge MMDVM_Bridge.ini" but i get an error, please see below for the error

root@depifactory:/opt# ./MMDVM_Bridge MMDVM_Bridge.ini
bash: ./MMDVM_Bridge: Is a directory

Can someone assist me with this issue, i dont know what I am doing wrong


JJ Cummings
 

the error "bash: ./MMDVM_Bridge: Is a directory" should be a good clue.  This tells you that you are trying to run a directory as an application.  So you need to go into the actual directory where the binary MMDVM_Bridge exists and run it from there, or supply the full path to the binary and to the ini file...

Or, if the binary is in your PATH somewhere you don't need the ./ (this is the most likely case) but will need to provide the full path to the ini unless it's in your CWD...

JJC

On Tue, Jun 18, 2019 at 11:00 AM Dexter Harroo <dex.9y4c@...> wrote:
Hello Guys,
I try my best to follow instructions and adhere to protocols, but i need your assistance as I have come to a brick wall, I used the Git clone method to get the MMDVM_Bridge package, i followed the the examples for configuring MMDVM_Bridge,ini and DVSwitch.ini, when its time to run the program I use "./MMDVM_Bridge MMDVM_Bridge.ini" but i get an error, please see below for the error

root@depifactory:/opt# ./MMDVM_Bridge MMDVM_Bridge.ini
bash: ./MMDVM_Bridge: Is a directory

Can someone assist me with this issue, i dont know what I am doing wrong


Steve N4IRS
 

But I have remote start....

On 6/18/2019 1:04 PM, Steve KC1AWV wrote:
First do this: cd MMDVM_Bridge

Then ./MMDVM_Bridge MMDVM_Bridge.ini

You're outside the directory the executable is in. Like trying to start a car from outside the driver's door ;)

Steve KC1AWV

On Tue, Jun 18, 2019 at 1:00 PM Dexter Harroo <dex.9y4c@...> wrote:
Hello Guys,
I try my best to follow instructions and adhere to protocols, but i need your assistance as I have come to a brick wall, I used the Git clone method to get the MMDVM_Bridge package, i followed the the examples for configuring MMDVM_Bridge,ini and DVSwitch.ini, when its time to run the program I use "./MMDVM_Bridge MMDVM_Bridge.ini" but i get an error, please see below for the error

root@depifactory:/opt# ./MMDVM_Bridge MMDVM_Bridge.ini
bash: ./MMDVM_Bridge: Is a directory

Can someone assist me with this issue, i dont know what I am doing wrong


--
Steve Miller
KC1AWV


Steve KC1AWV
 

Oh damn, I didn't think of that. But if you had remote start you'd be executing /opt/MMDVM_Bridge/MMDVM_Bridge - ha!

You can tell when an issue is easy to resolve, there's a dozen people offering assistance!


On Tue, Jun 18, 2019 at 1:05 PM Steve N4IRS <szingman@...> wrote:
But I have remote start....

On 6/18/2019 1:04 PM, Steve KC1AWV wrote:
First do this: cd MMDVM_Bridge

Then ./MMDVM_Bridge MMDVM_Bridge.ini

You're outside the directory the executable is in. Like trying to start a car from outside the driver's door ;)

Steve KC1AWV

On Tue, Jun 18, 2019 at 1:00 PM Dexter Harroo <dex.9y4c@...> wrote:
Hello Guys,
I try my best to follow instructions and adhere to protocols, but i need your assistance as I have come to a brick wall, I used the Git clone method to get the MMDVM_Bridge package, i followed the the examples for configuring MMDVM_Bridge,ini and DVSwitch.ini, when its time to run the program I use "./MMDVM_Bridge MMDVM_Bridge.ini" but i get an error, please see below for the error

root@depifactory:/opt# ./MMDVM_Bridge MMDVM_Bridge.ini
bash: ./MMDVM_Bridge: Is a directory

Can someone assist me with this issue, i dont know what I am doing wrong


--
Steve Miller
KC1AWV



--
Steve Miller
KC1AWV


Dexter Harroo
 

root@depifactory:/opt/MMDVM_Bridge# ./MMDVM_Bridge MMDVM_Bridge.ini
bash: ./MMDVM_Bridge: No such file or directory
root@depifactory:/opt/MMDVM_Bridge# dir
bin DVSwitch.ini MMDVM_Bridge.ini README.md

This is what happened when i run it from the directory MMDVM_Bridge
did a Dir this is what See, also How does remote start work


Steve KC1AWV
 

Ohhhh. I overlooked that you git cloned the repo. Ok, you will need to move one of the binaries from /opt/MMDVM_Bridge/bin to the parent folder.

cd /opt/MMDVM_Bridge
mv bin/MMDVM_Bridge .

That space and period at the end of the mv command is important.

Then try running MMDVM_Bridge using ./MMDVM_Bridge MMDVM_Bridge.ini

The remote start comment is just a little joke.

On Tue, Jun 18, 2019 at 1:13 PM Dexter Harroo <dex.9y4c@...> wrote:
root@depifactory:/opt/MMDVM_Bridge# ./MMDVM_Bridge MMDVM_Bridge.ini
bash: ./MMDVM_Bridge: No such file or directory
root@depifactory:/opt/MMDVM_Bridge# dir
bin DVSwitch.ini MMDVM_Bridge.ini README.md

This is what happened when i run it from the directory MMDVM_Bridge
did a Dir this is what See, also How does remote start work



--
Steve Miller
KC1AWV


Steve N4IRS
 

Dexter,
The github repository is not intended for installation. It is where I place replacement executables before I include them in the apt package.
I really suggest you use the apt package.
See here <https://dvswitch.groups.io/g/main/message/1224>
My comment about "remote start" was a joke based on Steve's starting a car comment.

Steve N4IRS


On 6/18/2019 1:13 PM, Dexter Harroo wrote:
root@depifactory:/opt/MMDVM_Bridge# ./MMDVM_Bridge MMDVM_Bridge.ini
bash: ./MMDVM_Bridge: No such file or directory
root@depifactory:/opt/MMDVM_Bridge# dir
bin DVSwitch.ini MMDVM_Bridge.ini README.md

This is what happened when i run it from the directory MMDVM_Bridge
did a Dir this is what See, also How does remote start work


Dexter Harroo
 

I only see 2 files in the MMDVM_Bridge.ini and DVSwitch.ini
do i have to do a reinstall to get the other file?


Steve KC1AWV
 

No, you have a folder called bin in the same directory, that's where the binary executable files are. You need to move one of the files in that child folder up to the parent folder before you can run the command you are using to execute the program.

On Tue, Jun 18, 2019 at 1:21 PM Dexter Harroo <dex.9y4c@...> wrote:
I only see 2 files in the MMDVM_Bridge.ini and DVSwitch.ini
do i have to do a reinstall to get the other file?



--
Steve Miller
KC1AWV


Dexter Harroo
 

Thanks Steve, trying that now


Dexter Harroo
 
Edited

So i have another question, I'm Trying to Link TGIG TG 969 to YSF reflector 53636 do i have to add the TGIF network information in the MMDVM_Bridge.ini file?
[DMR Network]
Enable=1
Address=hblink.dvswitch.org do i replace this with tgif.network ?
Port=62031
Jitter=360
Local=62032
Password=passw0rd
Slot1=0
Slot2=1
Debug=0


Steve N4IRS
 

Yes you do.

On 6/18/2019 2:38 PM, Dexter Harroo wrote:
So i have another question, I'm Trying to Link TGIG TG 969 to YSF reflector 53636 do i have to add the TGIF network information in the MMDVM_Bridge.ini file?
[DMR Network]
Enable=1
Address=hblink.dvswitch.org do i replace this with tgif.net?
Port=62031
Jitter=360
Local=62032
Password=passw0rd
Slot1=0
Slot2=1
Debug=0


Dexter Harroo
 

and where do i put the TG number ?
Does that go in the DVSwitch.ini 


Steve N4IRS
 

Yes,
In the [YSF} stanza under Export TG

On 6/18/2019 2:53 PM, Dexter Harroo wrote:
and where do i put the TG number ?
Does that go in the DVSwitch.ini 


Steve N4IRS
 

On 6/18/2019 2:53 PM, Dexter Harroo wrote:
and where do i put the TG number ?
Does that go in the DVSwitch.ini 


Dexter Harroo
 

I dont want to be a pain but this is what happens when i run MMDVM_Bridge

: 2019-06-18 19:10:16.804 Error returned from sendto, err: 22
2019-06-18 19:10:21.811 Error returned from sendto, err: 22
2019-06-18 19:10:26.822 Error returned from sendto, err: 22
2019-06-18 19:10:31.833 Error returned from sendto, err: 22


Steve N4IRS
 

That is a IP error. Please post your [DMR Network] stanza from MMDVM_Bridge.ini

On 6/18/2019 3:15 PM, Dexter Harroo wrote:
I dont want to be a pain but this is what happens when i run MMDVM_Bridge

: 2019-06-18 19:10:16.804 Error returned from sendto, err: 22
2019-06-18 19:10:21.811 Error returned from sendto, err: 22
2019-06-18 19:10:26.822 Error returned from sendto, err: 22
2019-06-18 19:10:31.833 Error returned from sendto, err: 22


Steve KC1AWV
 

Check your MMDVM_Bridge.ini to see if you used a domain name for DMRNetwork instead of the IP. If true, switch to IP address and try again.

On Tue, Jun 18, 2019 at 3:15 PM Dexter Harroo <dex.9y4c@...> wrote:
I dont want to be a pain but this is what happens when i run MMDVM_Bridge

: 2019-06-18 19:10:16.804 Error returned from sendto, err: 22
2019-06-18 19:10:21.811 Error returned from sendto, err: 22
2019-06-18 19:10:26.822 Error returned from sendto, err: 22
2019-06-18 19:10:31.833 Error returned from sendto, err: 22



--
Steve Miller
KC1AWV