Topics

ASL Analog_Bridge and dvswitch.sh #analog_bridge


Ed W8VT
 

When changing digital modes via dvswitch.sh is there a way to set the audio levels for each mode. Not using DVSM with this installation.

Ed W8VT


Steve N4IRS
 

Ed,
Not as of today, but it is planned for SOON.

Steve N4IRS

On 12/9/2019 12:56 PM, Ed W8VT wrote:
When changing digital modes via dvswitch.sh is there a way to set the audio levels for each mode. Not using DVSM with this installation.

Ed W8VT


Steve N4IRS
 
Edited

Ed,
In thinking about you question, you can change audio levels. You will have scripts for each mode so, add:
dvswitch.sh tlvAudio gain {value} # Set AMBE audio gain
dvswitch.sh usrpAudio gain {value} # Set PCM audio gain

Where value is .1 to 10
1 = unity gain
2 = twice unity 
.5 half unity gain


Ed W8VT
 

Thanks Steve. I'll give it a try tomorrow.

Ed W8VT


Ed W8VT
 

Steve,
Was just playing with this and can not get the levels to change. The original setup was just for DMR so I had those audio parameters in AB.ini. Commented those out and now the gain numbers change (when queried by dvswitch.ini) but shows mode as unity. Restored use_audio_gain back in AB.ini and tried again. Mode now says gain but levels default to -20.0 and do not change. 

Obviously I've done something silly somewhere.

Ed W8VT


Steve N4IRS
 

Ed,
I did steer you wrong a bit.
The command syntax is:
./dvswitch.sh tlvAudio AUDIO_USE_GAIN 1.1
./dvswitch.sh usrpAudio AUDIO_USE_GAIN .93

Valid options are:
(AUDIO_UNITY|AUDIO_USE_AGC|AUDIO_USE_GAIN|AUDIO_USE_BPF)

You will see the change reflected in the AB log and in the AB json file in /tmp
Assuming you are using port 12345, you will find a file in /tmp named:
ABInfo_12345.json
This contains all current setting in use by AB.

Steve N4IRS

On 12/15/19 4:12 PM, Ed W8VT wrote:
Steve,
Was just playing with this and can not get the levels to change. The original setup was just for DMR so I had those audio parameters in AB.ini. Commented those out and now the gain numbers change (when queried by dvswitch.ini) but shows mode as unity. Restored use_audio_gain back in AB.ini and tried again. Mode now says gain but levels default to -20.0 and do not change. 

Obviously I've done something silly somewhere.

Ed W8VT


Ed W8VT
 

Steve,
That did the trick, works great now.
Thanks!

Ed W8VT


Steve N4IRS
 

Ed,
That's great to hear.
 Going forward, the plan is to add the audio level values to DVSwitch.ini so that when a mode is selected, dvswitch.sh gets the value from the mode stanza. That way you can have different values for each mode and have the value applied when you switch modes.

73, Steve N4IRS

On 12/15/19 6:37 PM, Ed W8VT wrote:
Steve,
That did the trick, works great now.
Thanks!

Ed W8VT