MMDVM to ASL bridge #mmdvm_bridge


john.brazel225@...
 

I’m running ASL with mmdvm bridge installed. I have everything working pretty good, however, the audio level adjustments don’t seem to be helping me. Audio from DMR to asl (echolink) seems to be great, but audio from asl (echolink) to DMR seems to be rather awful. It’s way too hot going out to DMR. Any ideas on how to possibly lower the audio? As stated above, the audio setting doesn’t seem to make any difference at all. Heck, I think I’ve even tried negative amounts, and still get the same result. Any help?


Steve N4IRS
 

John,
In Analog_Bridge.ini see the [USRP] stanzas
tlvAudio = AUDIO_USE_GAIN
tlvGain = 0.35                          ; Gain factor of audio from ASL (0.0-1.0)

This should reduce the audio from ASL to DMR

73, Steve N4IRS

On 4/8/20 9:19 PM, john.brazel225@... wrote:
I’m running ASL with mmdvm bridge installed. I have everything working pretty good, however, the audio level adjustments don’t seem to be helping me. Audio from DMR to asl (echolink) seems to be great, but audio from asl (echolink) to DMR seems to be rather awful. It’s way too hot going out to DMR. Any ideas on how to possibly lower the audio? As stated above, the audio setting doesn’t seem to make any difference at all. Heck, I think I’ve even tried negative amounts, and still get the same result. Any help?


john.brazel225@...
 

Steve,

Thays where I run into the issue of it not changing. I can alter those settings and the end result is still the same. The DMR side being way overdriven when there is traffic coming from asl. I have tried multiple time, with numerous settings, and even tried reboots after making changes. Still poor audio quality on the DMR side. 


JJ Cummings
 

John..

You need to change the gain type (if you havn't) from the default to AUDIO_USE_GAIN.. then the changes will work, make big changes at first and smaller as you get closer to an acceptable level.  You'll need to restart the Analog_Bridge process every time that you make a change to test.

aslAudio = AUDIO_USE_GAIN        ; Audio to ASL (AUDIO_UNITY, AUDIO_USE_AGC, AUDIO_USE_GAIN)
agcGain = 1.65                   ; Gain (in db) of the AGC filter
dmrAudio = AUDIO_USE_GAIN         ; Audio from ASL (AUDIO_UNITY, AUDIO_GAIN, AUDIO_BPF)
dmrGain = 0.31                  ; Gain factor of audio from ASL (0.0-1.0)


On Wed, Apr 8, 2020 at 9:06 PM <john.brazel225@...> wrote:
Steve,

Thays where I run into the issue of it not changing. I can alter those settings and the end result is still the same. The DMR side being way overdriven when there is traffic coming from asl. I have tried multiple time, with numerous settings, and even tried reboots after making changes. Still poor audio quality on the DMR side. 


john.brazel225@...
 

JJ,

Thanks for that. I’ll be back at the office in the morning and will give that a try.