ASL to DMR - not receiving inbound traffic


Gerry Filby
 

Thanks again Brad - I found my mistake in the AMBE_AUDIO section - once I put my DMR ID as the "gatewayDmrId" all started working correctly.

Thanks for your note on making the TG static - I ended removing that and I'm finding that the "auto-static" seems to work really well, the connection to the TG has stayed in place for several hours.

Cheers!

Gerry,
W6WNG


Brad N8PC
 

did you set the talk group on brandmeister as static? if not it will not stay connected.

On 11/18/2020 3:55 PM, Gerry Filby wrote:
Thanks for the response Brad !

I tried that and it stopped working altogether.  I looked in /opt/MMDV_Bridge/DVSwitch.ini and TX/RX are defined:

[DMR]

Address = 127.0.0.1             ; Address to send AMBE TLV frames to (export)

TXPort = 31100                  ; Port to send AMBE TLV frames to (export)

RXPort = 31103                  ; Port to listen on (import)

Slot = 2                        ; Export slot

ExportTG = 0                    ; Which TG to export

TalkerAlias = Roger Nowhere Il. DVSWITCH


So I'm assuming that needs to be reversed in Analog_Bridge.ini ? - Tx goes to Rx and visa versa:

[AMBE_AUDIO]

address = 127.0.0.1                     ; IP address of xx_Bridge

txPort = 31103                          ; Transmit TLV frames to partner on this port

rxPort = 31100                          ; Listen for TLV frames from partner on this port

ambeMode = DMR                          ; DMR, DMR_IPSC, DSTAR, NXDN, P25, YSFN, YSFW (encode PCM to this format)

minTxTimeMS = 2500                      ; Minimum time in MS for hang delay (0-10000)


I'm getting traffic from the TG 91, but only if I momentarily click my PTT on the analog side whilst a 3rd party is speaking in the TG.  If the 3rd party in the TG stops an restarts their over, I don't resume receiving their traffic from the TG.

g


Gerry Filby
 

Thanks for the response Brad !

I tried that and it stopped working altogether.  I looked in /opt/MMDV_Bridge/DVSwitch.ini and TX/RX are defined:

[DMR]

Address = 127.0.0.1             ; Address to send AMBE TLV frames to (export)

TXPort = 31100                  ; Port to send AMBE TLV frames to (export)

RXPort = 31103                  ; Port to listen on (import)

Slot = 2                        ; Export slot

ExportTG = 0                    ; Which TG to export

TalkerAlias = Roger Nowhere Il. DVSWITCH


So I'm assuming that needs to be reversed in Analog_Bridge.ini ? - Tx goes to Rx and visa versa:

[AMBE_AUDIO]

address = 127.0.0.1                     ; IP address of xx_Bridge

txPort = 31103                          ; Transmit TLV frames to partner on this port

rxPort = 31100                          ; Listen for TLV frames from partner on this port

ambeMode = DMR                          ; DMR, DMR_IPSC, DSTAR, NXDN, P25, YSFN, YSFW (encode PCM to this format)

minTxTimeMS = 2500                      ; Minimum time in MS for hang delay (0-10000)


I'm getting traffic from the TG 91, but only if I momentarily click my PTT on the analog side whilst a 3rd party is speaking in the TG.  If the 3rd party in the TG stops an restarts their over, I don't resume receiving their traffic from the TG.

g


Brad N8PC
 

Gerry in your Analog_bridge.ini under Ambe_Audio set your ports to tx=31100 Rx=31103 then it will work

On 11/17/2020 7:13 PM, Gerry Filby wrote:
Hi Folks,

I've worked through the "ASL to DMR Bridge How To" pdf and I think I have things more or less set up - I get the expected CLI output when running MMDVM_Bridge and Analog_Bridge in the foreground per the doc.

I'm connecting to TG 91 (Worlwide) in Analog_bridge.ini thusly:

[AMBE_AUDIO]

address = 127.0.0.1                     ; IP address of xx_Bridge

txPort = 31103                          ; Transmit TLV frames to partner on this port

rxPort = 31100                          ; Listen for TLV frames from partner on this port

ambeMode = DMR                          ; DMR, DMR_IPSC, DSTAR, NXDN, P25, YSFN, YSFW (encode PCM to this f$

minTxTimeMS = 2500                      ; Minimum time in MS for hang delay (0-10000)

 

; The metadata below is used when ASL is the source since it does not have any concept of digital modes

gatewayDmrId = 310307899                        ; ID to use when transmitting from Analog_Bridge

repeaterID = 310307801                          ; ID of source repeater

txTg = 91                                ; TG to use for all frames sent from Analog_Bridge -> xx_Bridge

txTs = 2                                ; Slot to use for frames sent from Analog_Bridge -> xx_Bridge

colorCode = 1

I'm monitoring the TG from a separate Pi-Star hotspot's dashboard.  When there's an ongoing transmission from a 3rd party and I hit the PTT on my analog radio and release, the connection starts up and I hear 3rd party on my analog radio listening on the ASL side.  However, if the 3rd party stops transmitting and a second 3rd party begins transmitting I don't hear their transmission until I hit the PTT momentarily on my analog radio again.  Also, when I hit the PTT on my analog radio I don't see the traffic pop up on the Pi-Star dashboard.

I'm a total newb at this so just hoping for a pointer as to where to start looking.

Best,
Gerry.
W6WNG



Gerry Filby
 

Hi Folks,

I've worked through the "ASL to DMR Bridge How To" pdf and I think I have things more or less set up - I get the expected CLI output when running MMDVM_Bridge and Analog_Bridge in the foreground per the doc.

I'm connecting to TG 91 (Worlwide) in Analog_bridge.ini thusly:

[AMBE_AUDIO]

address = 127.0.0.1                     ; IP address of xx_Bridge

txPort = 31103                          ; Transmit TLV frames to partner on this port

rxPort = 31100                          ; Listen for TLV frames from partner on this port

ambeMode = DMR                          ; DMR, DMR_IPSC, DSTAR, NXDN, P25, YSFN, YSFW (encode PCM to this f$

minTxTimeMS = 2500                      ; Minimum time in MS for hang delay (0-10000)

 

; The metadata below is used when ASL is the source since it does not have any concept of digital modes

gatewayDmrId = 310307899                        ; ID to use when transmitting from Analog_Bridge

repeaterID = 310307801                          ; ID of source repeater

txTg = 91                                ; TG to use for all frames sent from Analog_Bridge -> xx_Bridge

txTs = 2                                ; Slot to use for frames sent from Analog_Bridge -> xx_Bridge

colorCode = 1

I'm monitoring the TG from a separate Pi-Star hotspot's dashboard.  When there's an ongoing transmission from a 3rd party and I hit the PTT on my analog radio and release, the connection starts up and I hear 3rd party on my analog radio listening on the ASL side.  However, if the 3rd party stops transmitting and a second 3rd party begins transmitting I don't hear their transmission until I hit the PTT momentarily on my analog radio again.  Also, when I hit the PTT on my analog radio I don't see the traffic pop up on the Pi-Star dashboard.

I'm a total newb at this so just hoping for a pointer as to where to start looking.

Best,
Gerry.
W6WNG