Restarting DVSwitch Services


g8ptn@...
 
Edited

Hi Steve, 

Thanks again for the quick response.

All understood. The tune method is effectively what happens when switching via the DVSM App. When switching using this method the MMDVM_Bridge.ini DMR Address path does not get updated.

When switching the server from the DVSwitch “dvs” menu option, the  MMDVM_Bridge.ini DMR Address path does get updated.

Regards,
  Dave

 


Steve N4IRS
 

Dave,
There are two ways to switch servers:
1: edit MMDVM_Bridge.ini and restart MMDVM_Bridge
2: With a tune command: "password@server:port:options"
   
TGIF = "passw0rd@...:62031"
Brandmeister = "passw0rd@...:62031"
DMR_PLUS = "passw0rd@...:55555:StartRef=4649;RelinkTime=60;UserLink=1"

Hope this helps,
Steve N4IRS


On 12/28/20 6:56 AM, g8ptn@... wrote:

Hi Steve, 

After investigating further, the issue only occurs when switching server using the DVSM App.

Switching server in the “dvs” menu updates the MMDVM_Bridge.ini file with the selected address, but not when making the selection using DVSM App.

Regards,

   Dave



g8ptn@...
 

Hi Steve, 

After investigating further, the issue only occurs when switching server using the DVSM App.

Switching server in the “dvs” menu updates the MMDVM_Bridge.ini file with the selected address, but not when making the selection using DVSM App.

Regards,

   Dave


g8ptn@...
 

Hi Steve,

Thanks for the reply. Yes, I understand how to select the server in dvs menus.


The servers I have defined under the “Change Default DMR Server” are as follows.

1. Brandmeister

2. TGIF

 

3. HB_GB_FreeDMR_DMO

The servers I am currently using are 1 and 3.

What I have observed is that after selecting 1 (Brandmeister), restarting services via the "dvs" menu “Restart DVSwitch Services” or using the “Drop Dynamic TGs” in the DVSM App, the DMR server always returns to the “HB_GB_FreeDMR_DMO” server.

After further inspection, following “Restart DVSwitch Services” or using the “Drop Dynamic TGs”, the server is set to the address defined in the MMDVM_Bridge.ini file (see extract below).

[DMR Network]

Enable=1

Address=hotspots.freedmr.uk

Port=62031

I am not sure if this is an issue now DVSwitch server is in “Advanced Macro Configuration” mode, since I initially noticed the issue when using the “Drop Dynamic TGs” in the DVSM App.

It seems that the MMDVM_Bridge.ini is not updated with the selected server address, but I am not sure if this was the case or not prior to switching to the “Advanced Macro Configuration” mode.

This is not a major issue since now I know what is happening, I can manually switch server following a restart of the services.


Regards,

   Dave


Steve N4IRS
 

You can define the default DMR server using the dvs menu.
Advanced Configuration / Additional DMR Networks / Change Default DMR Server
You can find the result in the [DMR Network] section.

Steve N4IRS

On 12/27/20 12:45 PM, g8ptn@... wrote:
Hi,

I have noticed that when restarting services via the "dvs" menu “Restart DVSwitch Services” or using the “Drop Dynamic TGs” in the DVSM App, the DMR server always returns to a particular server.


When restarting DVSwitch services, what determines what DMR server is selected?

Regards,
   Dave



g8ptn@...
 

Hi,

I have noticed that when restarting services via the "dvs" menu “Restart DVSwitch Services” or using the “Drop Dynamic TGs” in the DVSM App, the DMR server always returns to a particular server.


When restarting DVSwitch services, what determines what DMR server is selected?

Regards,
   Dave