DVSwitch Dashboard


Peter Buckley
 

Steve,

With your help got the "connect to Allstar node at boot time" working.

Edits only needed inside  rpt.conf
(below what is working for me now)

Under 
[46141]
startup_macro_delay=20      ;this turns out to be very important
startup_macro = *52

[macro]
2=*7345479#      ;this is what I added  trying to get my Allstar 46141 to connect to Node 45479
;1 = *32011#
;2 = *12001*12011*12043*12040*12050*12060*12009*12002*12003*12004*1113*12030#
;3 = *32001*32011*32050*32030*32060#

In rpt.conf  under    ; Mandatory Command Codes   ;I added

73= ilink,13      ;this is intended to be a permanent connection

The trick above prevents me from (at boot time)
Having to login as  dvswitch
Then run   sudo als-menu
The go to:  5 in the Menu   (ASL Asterisk CLI)
then type     CLI*>    rpt fun 46141 *345479

Thanks!   73s
-pete


Steve N4IRS
 

2=*7345479#      ;this is what I added  trying to get my Allstar 46141 to connect to Node 45479

hmmm,
I think this should be:
2=*345479#      ;this is what I added  trying to get my Allstar 46141 to connect to Node 45479

Unless You have *73 defined as something else

On 2/16/2021 11:53 AM, Peter Buckley via groups.io wrote:
Thanks Steve - TCP port 8080 it is and now forwarding through my firewall.

Q.)  How to make Allstar automatically connect to another Allstar Node at boot up?
(below rpt.conf doesn't work)

I edited  rpt.conf

Under [46141]
startup_macro_delay=20
startup_macro = *52

[macro46141]
2=*7345479#      ;this is what I added  trying to get my Allstar 46141 to connect to Node 45479
;1 = *32011#
;2 = *12001*12011*12043*12040*12050*12060*12009*12002*12003*12004*1113*12030#
;3 = *32001*32011*32050*32030*32060#


Peter Buckley
 

Thanks Steve - TCP port 8080 it is and now forwarding through my firewall.

Q.)  How to make Allstar automatically connect to another Allstar Node at boot up?
(below rpt.conf doesn't work)

I edited  rpt.conf

Under [46141]
startup_macro_delay=20
startup_macro = *52

[macro46141]
2=*7345479#      ;this is what I added  trying to get my Allstar 46141 to connect to Node 45479
;1 = *32011#
;2 = *12001*12011*12043*12040*12050*12060*12009*12002*12003*12004*1113*12030#
;3 = *32001*32011*32050*32030*32060#


Steve N4IRS
 

Pete,
Good to hear you are working.
The audio is on TCP port 8080

The "TG WB2QGZ" is a bug, that should be fixed in the image but I guess not. I'll look at it and make sure the bug is filed in a update.

Steve N4IRS

On 2/16/2021 10:02 AM, Peter Buckley via groups.io wrote:
Steve etal - got your new image file working.

Just using the DMR <---> Allstar gateway only.  Rpi3 has no Radio attached.

Please see attached JPG.
Re:  RX Monitor on DVSwitch Dashboard

Audio works from web page when I'm on the same IP Subnet.
Q.)  What TCP? UDP Ports do I need to forward at my Firewall so I can hear the audio when I'm at a remote location.

Second Q.)  Please see attached JPG -
Re:  Gateway Activity and Target
Q.)  I have no clue where DVSwitch Dashboard is getting the WB2QGZ call.  What config file is this coming from?
I have a simple setup - BM/TG 31085 and Allstar connection to 45479 (this is working)
Thanks to all.
Great work on that new image file, Steve.
73s  -pete  N0ECT


Peter Buckley
 

Steve etal - got your new image file working.

Just using the DMR <---> Allstar gateway only.  Rpi3 has no Radio attached.

Please see attached JPG.
Re:  RX Monitor on DVSwitch Dashboard

Audio works from web page when I'm on the same IP Subnet.
Q.)  What TCP? UDP Ports do I need to forward at my Firewall so I can hear the audio when I'm at a remote location.

Second Q.)  Please see attached JPG -
Re:  Gateway Activity and Target
Q.)  I have no clue where DVSwitch Dashboard is getting the WB2QGZ call.  What config file is this coming from?
I have a simple setup - BM/TG 31085 and Allstar connection to 45479 (this is working)
Thanks to all.
Great work on that new image file, Steve.
73s  -pete  N0ECT