pyUC Client Installation issue


JerryL
 

Hello Ken, Mike and Ed,

Thank you for the replies.  I'm stil trying to get the pyUC going properly.  No luck so far.  Maybe I'll have better luck with the hUC.  I haven't tried that one yet.  It looks more challenging than the hUC.  Besides the Mint 18.3, pyUC.py, updates on everything, the following is what I have loaded or appears to work or doesnt work:

Linux  sound settings from left to right:

Playback -ALSA plug-in (python 3.5): ALSA playback (when someone is transmitting, I hear audio from my USB headset and the sound bar is active).

Recording -ALSA plug-in (python 3.5): ALSA Capured from -Headset, Analog Mono (No activity on the sound bar unless I tap on the mic).

Output Device -headphones (when someone is transmitting, I hear audio from my USB headset and the sound bar is active).

Input Devise -Monitor Headset, Analog Stereo (when someone is transmitting, I hear audio from my USB headset and the sound bar is active).
                     -Headset Analog Mono (No activity on the sound bar unless I tap on the mic).

Configuration -Headset (selected) Analog Stero Output + Analog Mono Input


Software, Synaptic says I have the following loaded: python-beautifulsoap 3.2.1.1 & python3-bs4  (also python 2.7  & 3.5 are loaded)

pyUC -the audio seems to be fine (World Wide), the functionality seems to work, except the connect/discnnect buttons.  Still no audio out (TX).  I am still getting the scrolling error message described in my first post.

Thanks again for your help.  Jerry Long, KB3OIL





Ed Liddle
 

I installed it on Ubuntu and ran into the same problem. This should help with mint.
https://www.crummy.com/software/BeautifulSoup/bs4/doc/

If you’re using a recent version of Debian or Ubuntu Linux, you can install Beautiful Soup with the system package manager:

$ apt-get install python-bs4 (for Python 2)

$ apt-get install python3-bs4 (for Python 3)

73,

Ed


On Thu, Feb 25, 2021, 18:09 Mike Zingman - N4IRR <mike.zingman@...> wrote:
All python code is open source. The pyaudio module witten in C /C++ is on git. Sorry I do not have the link on hand. When pyaudio was written ALSA was the standard audio subsystem. But many distros have moved on. 

A quick Google search finds a pyaudio alternative as: 
https://python-sounddevice.readthedocs.io/en/0.4.1/
But I have not looked into it as a replacement. 

Mike


Mike Zingman - N4IRR
 

All python code is open source. The pyaudio module witten in C /C++ is on git. Sorry I do not have the link on hand. When pyaudio was written ALSA was the standard audio subsystem. But many distros have moved on. 

A quick Google search finds a pyaudio alternative as: 
https://python-sounddevice.readthedocs.io/en/0.4.1/
But I have not looked into it as a replacement. 

Mike


JerryL
 

Hi Ken,
Thanks for another reply.  I've looked for a way to make ALSA my default rather than Pulse and not found it.  Sometimes looking for Web help on Linux is painful.  You get lots of different suggestions, some involving pages of code, conflicting suggestions, or lots of stuff that others say doesn't work, etc.  I just don't know enough about Linux to figure out what I should be doing.  However, I have read Steve's message about hUC running through HTML.  That seems like it's going to be the path of the least resistance for now.  Hurrah to Steve N4IRS and others that are putting all this wonderful software together.

I also have been looking inside pyUC.py for an answer.  There seems to be an answer somewhere in their code.   I don't know if you've ventured inside that one or the pyUC.ini file.  The comments following the code are very well documented and are clear enough to understand.  What I'd really like to do is take a look inside the installed 'python-pyaudio' file, but I couldn't find where it is hidden. 

Oh well, I'm waiting for the hUC.  Thanks for your help.

Jerry, KB3OIL


Ken Kayser
 

HI Jerry,

I believe ALSA comes standard on all release of Linux.  It was the standard audio interface before Pulse.  Try disabling Pulse and see if that works.  Hopefully, your other audio programs aren't using it.

pyUC is my go to client.  However, if you can't get it to run, don't fret.  The boys are close to releasing hUC which is the HTML version.  Runs on all browsers on all platforms (including ios!). The scheduled release date is early March so keep on I on this forum.

73,  Ken


JerryL
 

HI Ken,
Thanks for the reply.  I'm running on the computer installed Mint 18.3, not a virtual machine.  I think I am running with Pulse.  I have not seen ALSA on anything.  I guess you think I should either load ALSA or find how to enable it if it is installed and then disable Pulse.  I am running several audio programs (RX/TX).  None seem to be bothered by Pulse, but I'll give ALSA a try.  It certainly looks like the pyUC Client is worth getting to work.  I want to use that with my Python Server (Installation Guide Appendix E)  loaded on Mint 18.3.  My DVswitch Raspberry/Android installations are working perfectly.  Thanks for your help.  ~Jerry


Ken Kayser
 

Hi Jerry,  What hardware platform are you running?  Is Mint running as the base OS or is it a virtual machine?  I believe the issue you are having stems from ALSA not being the primary audio subsystem in your environment.  If you have Pulse Audio running, try disabling it unless you are using it for something else.  There are various posts on how do disable Pulse Audio.  On some systems you can just delete it.  But doing that on Mint is not recommended.  Hope this helps.


JerryL
 

Hi Steve,

I am running Mint 18.3 because that is the last version that can run Allstar's Web Transceiver.  I don't think I'd have a problem if I was running Mint 19 or 20.  They have an more recent version of python from what I understand.

Initially I installed the pyUC Client per pages B-4 & B-5 in the 45 page Installation and User Guide.  I got a 'bs4' module not found error.  Mint 18.3's contains python3.5.  I found where I could install bs4 with the command sudo apt-get install bs4.  After doing that the pyUC Client popped on the screen along with a terminal screen behind it scrolling the following error message:

(the date and time every second plus) - TX thread:read() got an unexpected keyword argument 'exception-on overflow;

I was able to hear very good audio from my Logitech USB headset while connected to 91 World Wide.   However I could not transmit.  Mint 18.3 nor the pyUC Client did not see/recognize the TX microphone in the headset.

Is there a fix for this?

Jerry Long, KB3OIL