DVSwitch and MMDVM_Bridge update via Repository (stretch)


David BV3UN
 

Dear All
i had install DVswitch and MMDVM_Bridge via Repository on 2019 ,now i want to want to upgrade them to last version after apt-get update ; apt-get upgrade 
it sill no new version on  Repository (stretch) ,so please tell me how can i do this upgrade 

i still in stretch .thanks 


Steve N4IRS
 

David,
I would first backup your data before you attempt this. I can not promise everything will go well.

in /etc/apt/sources.list.d you will find a file named allstarlink.list or dvswitch.list. There should only be one file.
replace all occurrences of the word stretch with buster
save the file
apt update
apt upgrade

test
if you have a problem I suggest you use the new DVSwitch Image for the RPI and either eit the files or use the dvs menu. The dvs menu is very easy to get a server running and upgradeable in the future.

Steve N4IRS
 

On 3/4/21 6:52 PM, David via groups.io wrote:
Dear All
i had install DVswitch and MMDVM_Bridge via Repository on 2019 ,now i want to want to upgrade them to last version after apt-get update ; apt-get upgrade 
it sill no new version on  Repository (stretch) ,so please tell me how can i do this upgrade 

i still in stretch .thanks 


David BV3UN
 

Hi Steve
thanks ,By the way is it suggest to download last  MMDVM Bridge binary directly  then replace old one ?


Steve N4IRS
 

You can if all you want to do is upgrade MMDVM_Bridge

On 3/4/21 9:10 PM, David via groups.io wrote:
Hi Steve
thanks ,By the way is it suggest to download last  MMDVM Bridge binary directly  then replace old one ?