DVSwitch server shutdown


IK7VXC Mike
 

On Tue, Apr 27, 2021 at 05:47 PM, Steve N4IRS wrote:
The purpose of netcheck is to keep services from starting until it senses the internet connection (google.com) is stable.
Ok. Now THAT make more sense to me. Since I ran out of router ports, I connected the raspberry on my second ethernet card of my computer, connected in bridge with the first one that gets the line from the router. Maybe this creates some delay in the start up of the services (a wild guess anyway).

Thank you Steve for your promptness and availability.

IK7VXC Mike


Steve N4IRS
 

OK,
That makes more sense. The purpose of netcheck is to keep services from starting until it senses the internet connection (google.com) is stable.
NetCheck starting: [17:31:26.982]    Netcheck has started
NetCheck: Success [17:31:36.369]    Internet connectivity is good. Just less then 10 seconds

Starting NXDNParrot: [17:31:36.375]
Starting NXDNGateway: [17:31:36.381]
Starting ircDDBGateway: [17:31:36.390]
Starting MMDVM_Bridge: [17:31:36.400]
Starting Web Proxy: [17:31:36.406]
Starting YSFParrot: [17:31:36.415]
Starting P25Gateway: [17:31:36.424]
Starting P25Parrot: [17:31:36.432]
Starting Quantar_Bridge: [17:31:36.439]
Starting Analog_Bridge: [17:31:36.442]
Starting YSFGateway: [17:31:36.451]

Last service started at [17:31:36.451]
At this point, the system should be up and available.

Steve

On 4/27/2021 11:39 AM, IK7VXC Mike wrote:
Alright Steve. Apparently I had to be patient and wait for 5 minutes. The system went back online just fine, this time. Here is the content of netcheck:

Starting md380-emu: [17:31:14.244]
Starting NetCheck in systemd: [17:31:26.904]
 
NetCheck starting: [17:31:26.982]
 
Modalità spider abilitata. Controllare se il file remoto esiste.
--2021-04-27 17:31:27--  https://google.com/robots.txt
Risoluzione di google.com (google.com)... 142.250.180.142, 2a00:1450:4002:404::200e
Connessione a google.com (google.com)|142.250.180.142|:443... non riuscito: Nessun instradamento per l'host.
Connessione a google.com (google.com)|2a00:1450:4002:404::200e|:443... non riuscito: La rete non è raggiungibile.
 
Modalità spider abilitata. Controllare se il file remoto esiste.
--2021-04-27 17:31:35--  https://google.com/robots.txt
Risoluzione di google.com (google.com)... 142.250.180.142, 2a00:1450:4002:404::200e
Connessione a google.com (google.com)|142.250.180.142|:443... connesso.
Richiesta HTTP inviata, in attesa di risposta... 301 Moved Permanently
Modalità spider abilitata. Controllare se il file remoto esiste.
--2021-04-27 17:31:36--  https://www.google.com/robots.txt
Risoluzione di www.google.com (www.google.com)... 216.58.198.4, 2a00:1450:4002:807::2004
Connessione a www.google.com (www.google.com)|216.58.198.4|:443... connesso.
Richiesta HTTP inviata, in attesa di risposta... 200 OK
Lunghezza: 7212 (7,0K) [text/plain]
Il file remoto esiste.
 
wget returned: No problems occurred (0) [17:31:36.360]
 
NetCheck: Success [17:31:36.369]
Starting NXDNParrot: [17:31:36.375]
Starting NXDNGateway: [17:31:36.381]
Starting ircDDBGateway: [17:31:36.390]
Starting MMDVM_Bridge: [17:31:36.400]
Starting Web Proxy: [17:31:36.406]
Starting YSFParrot: [17:31:36.415]
Starting P25Gateway: [17:31:36.424]
Starting P25Parrot: [17:31:36.432]
Starting Quantar_Bridge: [17:31:36.439]
Starting Analog_Bridge: [17:31:36.442]
Starting YSFGateway: [17:31:36.451]

IK7VXC Mike
 


IK7VXC Mike
 

Alright Steve. Apparently I had to be patient and wait for 5 minutes. The system went back online just fine, this time. Here is the content of netcheck:

Starting md380-emu: [17:31:14.244]
Starting NetCheck in systemd: [17:31:26.904]
 
NetCheck starting: [17:31:26.982]
 
Modalità spider abilitata. Controllare se il file remoto esiste.
--2021-04-27 17:31:27--  https://google.com/robots.txt
Risoluzione di google.com (google.com)... 142.250.180.142, 2a00:1450:4002:404::200e
Connessione a google.com (google.com)|142.250.180.142|:443... non riuscito: Nessun instradamento per l'host.
Connessione a google.com (google.com)|2a00:1450:4002:404::200e|:443... non riuscito: La rete non è raggiungibile.
 
Modalità spider abilitata. Controllare se il file remoto esiste.
--2021-04-27 17:31:35--  https://google.com/robots.txt
Risoluzione di google.com (google.com)... 142.250.180.142, 2a00:1450:4002:404::200e
Connessione a google.com (google.com)|142.250.180.142|:443... connesso.
Richiesta HTTP inviata, in attesa di risposta... 301 Moved Permanently
Posizione: https://www.google.com/robots.txt [segue]
Modalità spider abilitata. Controllare se il file remoto esiste.
--2021-04-27 17:31:36--  https://www.google.com/robots.txt
Risoluzione di www.google.com (www.google.com)... 216.58.198.4, 2a00:1450:4002:807::2004
Connessione a www.google.com (www.google.com)|216.58.198.4|:443... connesso.
Richiesta HTTP inviata, in attesa di risposta... 200 OK
Lunghezza: 7212 (7,0K) [text/plain]
Il file remoto esiste.
 
wget returned: No problems occurred (0) [17:31:36.360]
 
NetCheck: Success [17:31:36.369]
Starting NXDNParrot: [17:31:36.375]
Starting NXDNGateway: [17:31:36.381]
Starting ircDDBGateway: [17:31:36.390]
Starting MMDVM_Bridge: [17:31:36.400]
Starting Web Proxy: [17:31:36.406]
Starting YSFParrot: [17:31:36.415]
Starting P25Gateway: [17:31:36.424]
Starting P25Parrot: [17:31:36.432]
Starting Quantar_Bridge: [17:31:36.439]
Starting Analog_Bridge: [17:31:36.442]
Starting YSFGateway: [17:31:36.451]

IK7VXC Mike
 


Steve N4IRS
 

No,
It does not matter. Delete netcheck, reboot, wait 5 minutes, post netcheck.

On 4/27/2021 11:27 AM, IK7VXC Mike wrote:
Yes. But I can attach the same file AFTER manually restarting everything ..


IK7VXC Mike
 

Yes. But I can attach the same file AFTER manually restarting everything ..


Steve N4IRS
 

Is that the end of netcheck?

On 4/27/2021 11:16 AM, IK7VXC Mike wrote:
dvswitch@dvswitch-server:~ $ sudo su
root@dvswitch-server:/home/dvswitch# systemctl status mmdvm_bridge
● mmdvm_bridge.service - MMDVM_Bridge Service
   Loaded: loaded (/lib/systemd/system/mmdvm_bridge.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
root@dvswitch-server:/home/dvswitch#

Starting md380-emu: [17:12:05.057]
Starting NetCheck in systemd: [17:12:16.526]
 
NetCheck starting: [17:12:16.599]
 
Modalità spider abilitata. Controllare se il file remoto esiste.
--2021-04-27 17:12:17--  https://google.com/robots.txt
Risoluzione di google.com (google.com)... 142.250.180.142, 2a00:1450:4002:804::200e
Connessione a google.com (google.com)|142.250.180.142|:443... 

Thanks
IK7VXC Mike


IK7VXC Mike
 

dvswitch@dvswitch-server:~ $ sudo su
root@dvswitch-server:/home/dvswitch# systemctl status mmdvm_bridge
● mmdvm_bridge.service - MMDVM_Bridge Service
   Loaded: loaded (/lib/systemd/system/mmdvm_bridge.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
root@dvswitch-server:/home/dvswitch#

Starting md380-emu: [17:12:05.057]
Starting NetCheck in systemd: [17:12:16.526]
 
NetCheck starting: [17:12:16.599]
 
Modalità spider abilitata. Controllare se il file remoto esiste.
--2021-04-27 17:12:17--  https://google.com/robots.txt
Risoluzione di google.com (google.com)... 142.250.180.142, 2a00:1450:4002:804::200e
Connessione a google.com (google.com)|142.250.180.142|:443... 

Thanks
IK7VXC Mike


Steve N4IRS
 

So,
It looks like MB is starting fine. Maybe the dashboard is confused.
Try this:
delete /var/log/netcheck
reboot
login via ssh and as root:
systemctl status mmdvm_bridge
post the results
and post the contents ov /var/log/netcheck

Steve

On 4/27/2021 10:51 AM, IK7VXC Mike wrote:
Ok Steve. the mmdvm is a directory with a bunch of log files. I've added the ones that made sense ... to me at least. Anyway as soon I rebooted the system I got this on the monit page:
https://ibb.co/ww04vvc   yiiikes!!!
I had to manually restart each one.

I do hope the attached files are the right ones. Otherwise I'm ready to run some more tests.

Thank you
IK7VXC Mike


IK7VXC Mike
 

Ok Steve. the mmdvm is a directory with a bunch of log files. I've added the ones that made sense ... to me at least. Anyway as soon I rebooted the system I got this on the monit page:
https://ibb.co/ww04vvc   yiiikes!!!
I had to manually restart each one.

I do hope the attached files are the right ones. Otherwise I'm ready to run some more tests.

Thank you
IK7VXC Mike


Steve N4IRS
 

/var/log/mmdvm

On 4/27/2021 10:18 AM, IK7VXC Mike wrote:
Ehm .. a little help here. Where do I find the log files?

Mike IK7VXC


IK7VXC Mike
 

Ehm .. a little help here. Where do I find the log files?

Mike IK7VXC


Steve N4IRS
 

So,
You did not need to reconfigure the system. That is good. Now the question is, why is MB not starting properly. Once you reboot and before you restart MB, grab the log and post it.

Steve N4IRS

On 4/27/2021 10:10 AM, IK7VXC Mike wrote:
Ok. I did another reboot this time from the Monit page. Again the system came up fine with all OKs in green on the monit page. But, again, I could not log in and - like you can see in the picture at my previous message - the network modes are all in red.

I then restarted the MMDVM_Bridge which had the OK in green (from the Monit page) and this time the system went back online.

IK7VXC Mike


IK7VXC Mike
 
Edited

Ok. I did another reboot this time from the Monit page. Again the system came up fine with all OKs in green on the monit page. But, again, I could not log in and - like you can see in the picture at my previous message - the network modes are all in red.

I then restarted the MMDVM_Bridge which had the status OK in green (from the Monit page) and this time the system went back online.

IK7VXC Mike

PS Please instruct on how to provide the AB and MB files. Thank you


Steve N4IRS
 

Well,
I would like to see the MB, and AB files before and after a reboot. When you say does not come up completely, is that because you can't login or the services are not starting?

On 4/27/21 6:09 AM, IK7VXC Mike wrote:
Steve, I don't know what to say. It's just that. After reboot the system doesn't come up completely (in fact I can't log in with the client). Until I run the configuration script.


IK7VXC Mike
 

Steve, I don't know what to say. It's just that. After reboot the system doesn't come up completely (in fact I can't log in with the client). Until I run the configuration script.


Steve N4IRS
 

Mike,
There is no reason you should have to run the configuration script because you reboot.

On 4/27/21 2:26 AM, IK7VXC Mike wrote:
Sorry Steve but that trick doesn't work. At reboot I still get the red light on the dashboard (see pic https://ibb.co/bvndwQb) and need to go through the Initial Configuration script again. Oh well .. I guess I'll have to leave it on 24/7 .. I can live with that.

Cheers
Mike IK7VXC


IK7VXC Mike
 

Sorry Steve but that trick doesn't work. At reboot I still get the red light on the dashboard (see pic https://ibb.co/bvndwQb) and need to go through the Initial Configuration script again. Oh well .. I guess I'll have to leave it on 24/7 .. I can live with that.

Cheers
Mike IK7VXC


IK7VXC Mike
 

Thank you Steve, I will try that!

Mike IK7VXC


Steve N4IRS
 

As root:
shutdown

Steve N4IRS

On 4/26/21 2:34 AM, IK7VXC Mike wrote:
Hi, I've been using DVSwitch server for a while now and everything is good.

However I can't seem to find a way to gently shut it down when I want to. Either if I use the shutdown menu or just pull the plug, at next reboot I'm forced to go through the Initial Configuration script to make it work again.

Is there a proper way to shut down the raspberry?
Thank you
IK7VXC Mike


IK7VXC Mike
 

Hi, I've been using DVSwitch server for a while now and everything is good.

However I can't seem to find a way to gently shut it down when I want to. Either if I use the shutdown menu or just pull the plug, at next reboot I'm forced to go through the Initial Configuration script to make it work again.

Is there a proper way to shut down the raspberry?
Thank you
IK7VXC Mike