DMR Master?


Bryan Johnson
 

Thanks John. But I'm running Hamvoip, not Allstarlink build. Hamvoip solved issues with my setup that Allstarlink could not. Mainly having to turn off all telemetry to prevent "ping pong" between my link radio and repeater. The new Hamvoip pre-release solved the issue so I could change back to duplex=1 and regain all telemetry, courtesy tones, AutoSky, etc. Unfortunately, I could not find an easy way to install DVS server on the same rpi as Hamvoip server, so I opted to use a second rpi 3b+ for now. When someone documents an easy way to install Hamvoip AND DVS server on one rpi, I'll be building more.

73, Bryan - K6RBJ


John-EA5JAV
 

Bryan, I'm running allstar and DVSwitch together on one single RPi4. To get fixed IP address on router on MAC address set it to whatever IP address you want, and from DVS menu set it to DHCP. All works perfectly fine, have to install Allstarlink first on RPi4, followed by DVSwitch manually. I find using dynamic DNS easier to remember IP address, any issues feel free to drop me an email, details on QRZ. EA5JAV. John


Bryan Johnson
 

Ok Steve. Thank you for all your help! In the meantime I will test with my BM TG3176651 and maybe a TAC TG.

73, Bryan


Steve N4IRS
 

OK,
AR will mute the digital mode if Allstar is selected and vice versa. If you don't change modes on the HTML client, you have a bridge. I am out of time tonight. Play with it. DO NOT bridge anything over to 91, 93 or 3100. Be careful what you bridge. Next we will turn of automute. Have fun.

On 6/11/21 9:22 PM, Bryan Johnson wrote:
Mute was not checked for AB, but it was for Allstar 1999. I unchecked it and appear to have two way DMR<>Analog back.


Bryan Johnson
 

Mute was not checked for AB, but it was for Allstar 1999. I unchecked it and appear to have two way DMR<>Analog back.


Steve N4IRS
 

Have you not figured out we are taking this step by step?
Now uncheck the mute for Analog_Bridge



On 6/11/21 9:15 PM, Bryan Johnson wrote:
Yes. Now webserver is allowing TX and tune on Allstar, and I get audio both ways from/to webserver and repeater. Still no audio between analog and DMR.


Bryan Johnson
 

Yes. Now webserver is allowing TX and tune on Allstar, and I get audio both ways from/to webserver and repeater. Still no audio between analog and DMR.


Steve N4IRS
 

Did you run the netstat after you made the edit and restarted asterisk?

On 6/11/21 9:07 PM, Bryan Johnson wrote:
tcp        0      0 127.0.0.1:5038          127.0.0.1:35078         ESTABLISHED                                             348/asterisk


Bryan Johnson
 

K. Made the change.

[root@K6RBJ asterisk]# cd /
[root@K6RBJ /]# netstat -tnap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State                                                                                                                            PID/Program name
tcp        0      0 0.0.0.0:5038            0.0.0.0:*               LISTEN                                                                                                                           348/asterisk
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN                                                                                                                           303/httpd
tcp        0      0 192.168.0.75:53         0.0.0.0:*               LISTEN                                                                                                                           301/named
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN                                                                                                                           301/named
tcp        0      0 127.0.0.1:953           0.0.0.0:*               LISTEN                                                                                                                           301/named
tcp        0      0 0.0.0.0:222             0.0.0.0:*               LISTEN                                                                                                                           302/sshd: /usr/bin/
tcp        0      0 192.168.0.75:37918      172.67.139.3:80         TIME_WAIT                                                                                                                        -
tcp        0      0 192.168.0.75:38597      8.8.8.8:53              TIME_WAIT                                                                                                                        -
tcp        0      0 192.168.0.75:5038       192.168.0.78:39346      ESTABLISHED                                                                                                                      348/asterisk
tcp        0      0 192.168.0.75:54060      34.105.111.212:80       TIME_WAIT                                                                                                                        -
tcp        0      0 192.168.0.75:54058      34.105.111.212:80       TIME_WAIT                                                                                                                        -
tcp        0    272 192.168.0.75:222        192.168.0.3:1036        ESTABLISHED                                                                                                                      530/sshd: root@pts/
tcp        0      0 192.168.0.75:52188      216.146.43.71:8245      TIME_WAIT                                                                                                                        -
tcp        0      0 192.168.0.75:54074      34.105.111.212:80       TIME_WAIT                                                                                                                        -
tcp        0      0 192.168.0.75:80         192.168.0.3:1030        ESTABLISHED                                                                                                                      322/httpd
tcp        0      0 127.0.0.1:35078         127.0.0.1:5038          ESTABLISHED                                                                                                                      322/httpd
tcp        0      0 127.0.0.1:5038          127.0.0.1:35078         ESTABLISHED                                                                                                                      348/asterisk
tcp        0      0 192.168.0.75:54072      34.105.111.212:80       TIME_WAIT                                                                                                                        -
tcp6       0      0 :::222                  :::*                    LISTEN                                                                                                                           302/sshd: /usr/bin/
 


Steve N4IRS
 

OK,
Two things, one, I screwed up the command should be netstat -tnap.
Second, edit this:
bindaddr = 127.0.0.1   ; Local interface only!                                                          
;bindaddr = 0.0.0.0    ; Not secure

to this:

;bindaddr = 127.0.0.1   ; Local interface only!                                                          
bindaddr = 0.0.0.0    ; Not secure

restart asterisk and retest.

On 6/11/21 8:59 PM, Bryan Johnson wrote:
[root@K6RBJ asterisk]# cd /
[root@K6RBJ /]# netstat -unap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
udp        0      0 0.0.0.0:5198            0.0.0.0:*                           358/asterisk
udp        0      0 0.0.0.0:5199            0.0.0.0:*                           358/asterisk
udp        0      0 0.0.0.0:32001           0.0.0.0:*                           358/asterisk
udp        0      0 0.0.0.0:5060            0.0.0.0:*                           358/asterisk
udp        0      0 192.168.0.75:4570       0.0.0.0:*                           358/asterisk
udp        0      0 192.168.0.75:53         0.0.0.0:*                           295/named
udp        0      0 127.0.0.1:53            0.0.0.0:*                           295/named
 


Bryan Johnson
 

[root@K6RBJ asterisk]# cd /
[root@K6RBJ /]# netstat -unap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
udp        0      0 0.0.0.0:5198            0.0.0.0:*                           358/asterisk
udp        0      0 0.0.0.0:5199            0.0.0.0:*                           358/asterisk
udp        0      0 0.0.0.0:32001           0.0.0.0:*                           358/asterisk
udp        0      0 0.0.0.0:5060            0.0.0.0:*                           358/asterisk
udp        0      0 192.168.0.75:4570       0.0.0.0:*                           358/asterisk
udp        0      0 192.168.0.75:53         0.0.0.0:*                           295/named
udp        0      0 127.0.0.1:53            0.0.0.0:*                           295/named
 


Steve N4IRS
 

E: 21-06-12 00:45:22 AMI Error: connect ECONNREFUSED 192.168.0.75:5038
Post you /etc/asterisk/manager.conf
Also, post the result of netstat -unap on your HAMVOIP node. Run it as root.

On 6/11/21 8:50 PM, Bryan Johnson wrote:
I still get tune not allowed, even though tune is checked.


Bryan Johnson
 

When I check the tune box, it keeps unchecking itself.


Bryan Johnson
 

I still get tune not allowed, even though tune is checked.


Steve N4IRS
 

No,
Verify tune is checked. If it is, send me the Analog_Reflector log.

On 6/11/21 8:43 PM, Bryan Johnson wrote:
Should I change node stanza in rpt.conf back to 127.0.0.1, instead of 192.168.0.75? When I did that before, 1999 and 54464 would not connect to each other.


Bryan Johnson
 

Should I change node stanza in rpt.conf back to 127.0.0.1, instead of 192.168.0.75? When I did that before, 1999 and 54464 would not connect to each other.


Steve N4IRS
 

The there is nothing to forward.

On 6/11/21 8:41 PM, Bryan Johnson wrote:
Yes, DVS server 0.78 and Hamvoip 0.75


Steve N4IRS
 

On the Web client, on the Manage tab, verify tune is enabled for node 1999



On 6/11/21 8:37 PM, Bryan Johnson wrote:
Just dawned on me...should I port forward 5038 to my Hamvoip server?


Bryan Johnson
 

Yes, DVS server 0.78 and Hamvoip 0.75


Steve N4IRS
 

Is the DVS Server on the same LAN as your HAMVOIP? (192.168.0.0)

On 6/11/21 8:37 PM, Bryan Johnson wrote:
Just dawned on me...should I port forward 5038 to my Hamvoip server?