AllStar/DMR/D-Star Bridge


Steven Blackford
 

Hello all,
     A few weeks ago, with the assistance of Steve, N4IRS I was able to setup a DMR<->D-Star bridge using DummyRepeater, Analog_Bridge, & HB_Bridge.  This has been running perfectly on an ODroid C1 for the past couple of weeks.  Last night, I finally had time to patch the dahdi-linux-complete module to compile ODroid.  I'm running Ubuntu Xenial btw.  So I had to patch it be able to compile it w/ gcc-5.x.  NP.  I then compiled the latest asterisk-1.4.23-pre.   The secret to getting asterisk-1.4.23-pre to compile on Xenial w/ gcc-5.x is to add "-fgnu89-inline" to your CFLAGS in case you're curious.  So I got everything installed.  I setup my node as a hub & configured EchoLink as well.  I stopped Analog_Bridge, DummyRepeater, & HB_Bridge, started up asterisk, and then restarted everything else.  Here's my problem & I know it probably has something to do w/ the chan_usrp configuration.  As it stands, here's what I have in my rpt.conf:

[1999]                                 ; Change this to your assigned node numb
er

rxchannel = USRP/127.0.0.1:34001:32001  ; Use the USRP channel driver. Must be e
nabled in modules.conf

In Analog_Bridge, I have the following config:
; Information for USRP channel driver
;   This matches the rpt.conf ASL file with a setting like:
;   rxchannel = usrp/127.0.0.1:34001:32001 It's invoked as usrp/SendToIP:SendToP
ORT:ListenOnPORT
[USRP]
server = 127.0.0.1              ; IP address of Allstar/Asterisk
toASLPort = 34001               ; PCM to ASL
fromASLPort = 32001             ; PCM from ASL

and my Dummy Repeater conf for USRP is as follows:

USRP_IP=127.0.0.1
USRP_TXPORT=34001
USRP_RXPORT=32001

Since I started asterisk first & everything afterwards as expected, here's the problem I have:

DMR passes fine over to D-Star as expected.
D-Star no longer passes over to DMR at all.
When I connect to the echolink node:
D-Star<->EchoLink works perfectly both ways.  

DMR<->EchoLink nothing works.  If I swap the ports in Analog_Bridge,
DMR-->EchoLink works like it should, but not vice versa.

So my question is, what's the best way to configure my USRP channels so I can have audio pass between all three modes?  Do I need to setup a second node for EchoLink & connect them together?  I don't have any plans on adding in anything analog at the momemt.  Basically just wanting to allow others to connect to the AllStar node & via EchoLink.  Sorry, I'm really new at this & was happy I got this far. :-)  Thanks & 73 de K4SQI!

Steve, K4SQI


--
-----
Steve, kb7sqi@...