Topics

ASL <-> XLX No analog audio?

Stephen Miller
 

Hi everyone,

I apologize if someone else has already brought up / solved this situation, however I am experiencing some issues with analog audio from Allstar making it all the way through to XLX.

Digital audio from a hotspot or repeater into XLX makes it's way over to the ASL hub with no issues, and the audio quality is great. The conversations can be heard using Android IAXRPT, Echolink, and autopatch.

Analog audio on the ASL hub can be heard on the hub on Android IAXRPT, Echolink, and autopatch.

When analog audio is sent to ASL, it is picked up locally on a private node that pushes it up to USRP, is then sent to Analog_Bridge, then MMDVM_Bridge, and finally to DMRGateway to XLX. The logic seems sound, and I can see the traffic from ASL to XLX passing as intended. However, devices attached to XLX only receive for a second or two, and then stop, regardless of what is happening on ASL. The radios on the digital side will receive data, but very quickly stop. Pi-Star also shows that it's receiving data from XLX, but only very shortly.

I've tried a milliwatt test and a parrot on the node that connects through to XLX. The milliwatt test cannot be heard, and the parrot has the same result as a user transmitting analog audio to ASL.

Equipment under test is as follows:

Analog:
Android phone running Android IAXRPT
SIP phone to private PBX dialing autopach to ASL
Android phone running Echolink

Digital:
Zumspot Pi-Star #1 running DMRGateway
Zumspot Pi-Star #2 running ircDDBGateway
Icom ID-51a HT
Hytera AR482G HT

I've included a diagram of a high level overview of the way I have the system set up. If a copy paste of the config files are needed, I can send that up as well.

I appreciate any help! Thank you!

- Steve KC1AWV

Stephen Miller
 

Unfortunately, not yet. I am using the md380 software codec right now, and I would like to test a hardware AMBE dongle. I will have to purchase another pair and send the audio over to the transcoding server, as the ASL and XLX servers are housed in a colo data center that I do not have physical access to. I intended to do this anyway, to see if I can get DStar, DMR and YSF all on one module talking to each other.

Please let me know if you make any progress. I do want to keep this topic open to see if anyone else has input, as well as providing my own status updates with this project.

If there are people interested in testing the system I have in place, please do. The inbound connections available are:

ASL node 46550
Echolink KC1AWV-L
XLX740 Module B (Transcoding)

Thanks!
-Steve KC1AWV

On Sat, Dec 8, 2018, 8:39 PM adshar64 via Groups.Io <adshar64=yahoo.com@groups.io wrote:
Steve, Did you find a fix for this issue, i have the same here ?

Murray.