DMR/AllStar one way audio


Jim - K6JWN
 

I have a working DMR to Allstar setup (thanks for the help!). I have a friend of mine who wants to listen in to the monday night papa system roundtable through my allstar node. Is there a quick and easy way to configure my setup to pipe audio into Allstar from DMR while not allowing audio from Allstar to enter in DMR?

Jim, K6JWN


Mike KB8JNM
 

If I understand your question right
...
Just connect to your DMR Bridged node in RX (*2xxxx)


...mike/kb8jnm

On 10/2/2018 12:07 AM, Jim K6JWN wrote:
I have a working DMR to Allstar setup (thanks for the help!). I have a friend of mine who wants to listen in to the monday night papa system roundtable through my allstar node. Is there a quick and easy way to configure my setup to pipe audio into Allstar from DMR while not allowing audio from Allstar to enter in DMR?
Jim, K6JWN


Jim - K6JWN
 

yeah, i knew about that one, but i cant guarantee that the connecting station will connect in monitor mode :)

On Oct 1, 2018, at 9:11 PM, Mike KB8JNM <groupio@midnighteng.com> wrote:

If I understand your question right
...
Just connect to your DMR Bridged node in RX (*2xxxx)


...mike/kb8jnm

On 10/2/2018 12:07 AM, Jim K6JWN wrote:
I have a working DMR to Allstar setup (thanks for the help!). I have a friend of mine who wants to listen in to the monday night papa system roundtable through my allstar node. Is there a quick and easy way to configure my setup to pipe audio into Allstar from DMR while not allowing audio from Allstar to enter in DMR?
Jim, K6JWN


Jeff Wood
 

Running Allstarlink (ASL) with Analog_Bridge , md380-emu and MMDVM_Bridge......

Got it up and running last night, had a qso from allstar to dmr and DMR back to allstar with "PERFECT" audio quality!

after a reboot of the server only one way audio from DMR to ALLSTAR, no audio from allstar passes to DMR, any Ideas?? 
I have checked/rechecked all the settings and everything thing looks in order, My node is showing up fine on Allstar and also
showing fine on the brandmeister system...


Steve N4IRS
 

Jeff,
The logs are there to help in troubleshooting. Since your problem is ASL -> DMR, consider the following diagram:
ASL -> Analog_Bridge -> MMDVM_Bridge -> BrandMeister
When traffic is coming in from ASL do you see it in the Analog_Bridge log?
Do you see it in the MMDVM_Bridge log?

Steve N4IRS

On 10/2/2018 2:02 AM, jeff@... wrote:
Running Allstarlink (ASL) with Analog_Bridge , md380-emu and MMDVM_Bridge......

Got it up and running last night, had a qso from allstar to dmr and DMR back to allstar with "PERFECT" audio quality!

after a reboot of the server only one way audio from DMR to ALLSTAR, no audio from allstar passes to DMR, any Ideas?? 
I have checked/rechecked all the settings and everything thing looks in order, My node is showing up fine on Allstar and also
showing fine on the brandmeister system...


Eddie Lim 9W2LWK
 

I have md380-emu running too on my pi3, dmr to ASL audio is OK, but ASL to DMR , there are a lot of DMR stations complain that my audio is like a robot.

Any optimization can be done?

On Tue, Oct 2, 2018, 8:20 PM Steve N4IRS <szingman@...> wrote:
Jeff,
The logs are there to help in troubleshooting. Since your problem is ASL -> DMR, consider the following diagram:
ASL -> Analog_Bridge -> MMDVM_Bridge -> BrandMeister
When traffic is coming in from ASL do you see it in the Analog_Bridge log?
Do you see it in the MMDVM_Bridge log?

Steve N4IRS

On 10/2/2018 2:02 AM, jeff@... wrote:
Running Allstarlink (ASL) with Analog_Bridge , md380-emu and MMDVM_Bridge......

Got it up and running last night, had a qso from allstar to dmr and DMR back to allstar with "PERFECT" audio quality!

after a reboot of the server only one way audio from DMR to ALLSTAR, no audio from allstar passes to DMR, any Ideas?? 
I have checked/rechecked all the settings and everything thing looks in order, My node is showing up fine on Allstar and also
showing fine on the brandmeister system...


Mike KB8JNM
 

Well, it sounds like you have your bridge on a public node.
Hard to have 'selective control' that way.
Think of it a bit backwards.

I have dmr tg 91 set-up on 29999 for the last several months.
It's in rx only
Folks have been connecting and 'monitoring'.

If I wish to use it on 29285, in tx,
I can put a description on that server with the private node# ip, port for that direct connect on the other server. (rpt,conf)

1990 = radio@149.29.54.17:4569/1999,NONE ;29999 dmr

So I can still connect to that dmr bridge on the other server by using 1990 connection in what ever mode, but the node number is 1999 on the 29999 server.

1999 dmr bridge ->rx-> 29999 <-trx-> public connects
29285 <-> 1990(1999 on other server) private trx connect to my dmr bridge on other server.

hope this clears your thinking.

I actually have something like this on each of 5 servers even though each have there own dmr bridge, I can just use the connection of the others for my private trx connects. But i do not allow ASL to dmr on unmonitored high traffic dmr tg's. And I would encourage everyone to think about the implications of that.

Lots of control possibilities with this method. But there is always more than one way to skin that cat.

...mike/kb8jnm

On 10/2/2018 12:22 AM, Jim K6JWN wrote:
yeah, i knew about that one, but i cant guarantee that the connecting station will connect in monitor mode :)
On Oct 1, 2018, at 9:11 PM, Mike KB8JNM <groupio@midnighteng.com> wrote:

If I understand your question right
...
Just connect to your DMR Bridged node in RX (*2xxxx)


...mike/kb8jnm

On 10/2/2018 12:07 AM, Jim K6JWN wrote:
I have a working DMR to Allstar setup (thanks for the help!). I have a friend of mine who wants to listen in to the monday night papa system roundtable through my allstar node. Is there a quick and easy way to configure my setup to pipe audio into Allstar from DMR while not allowing audio from Allstar to enter in DMR?
Jim, K6JWN


Mike KB8JNM
 

This sounds like something (port#'s) in the file changed and not realized until the reboot.

Check the port data between ambe audio and analog bridge and then from there to mmdvm bridge.
OR
Follow the how2 a second time if you need guidance.
But you just have to verify each step to see where you are loosing it.

nobody can point you closer than that, you have to look.
But if you find the port mismatch, don't forget to restart that service after correction for a immediate check.

...mike/kb8jnm

On 10/2/2018 2:02 AM, jeff@n8ema.com wrote:
Running Allstarlink (ASL) with Analog_Bridge , md380-emu and MMDVM_Bridge......
Got it up and running last night, had a qso from allstar to dmr and DMR back to allstar with "PERFECT" audio quality!
after a reboot of the server only one way audio from DMR to ALLSTAR, no audio from allstar passes to DMR, any Ideas??
I have checked/rechecked all the settings and everything thing looks in order, My node is showing up fine on Allstar and also
showing fine on the brandmeister system...


Mike KB8JNM
 

On the surface, this sounds like a internet bandwidth issue/cpu bandwidth issue or perhaps some form of dropped packets in the stream.
Or even a combination.

But, don't be to quick to make adjustments since it is possible maintenance was being preformed on the host that slowed things down a bit.
Wait a day or two and check it again. And/Or Test on some other TG.
You really don't know how good the bandwidth is on the rxing end of your packets. It can be totally out of your control.

You will need to investigate further to find a answer. There are to many possibilities for anyone to just tell you 'just check/change this'.
And if you do 'just change this' you may be making issues that were not there before. Think of the larger picture of possibilities.

...mike/kb8jnm

On 10/2/2018 8:24 AM, Eddie Lim 9W2LWK wrote:
I have md380-emu running too on my pi3, dmr to ASL audio is OK, but ASL to
DMR , there are a lot of DMR stations complain that my audio is like a
robot.
Any optimization can be done?
On Tue, Oct 2, 2018, 8:20 PM Steve N4IRS <szingman@msgstor.com> wrote:

Jeff,
The logs are there to help in troubleshooting. Since your problem is ASL
-> DMR, consider the following diagram:
ASL -> Analog_Bridge -> MMDVM_Bridge -> BrandMeister
When traffic is coming in from ASL do you see it in the Analog_Bridge log?
Do you see it in the MMDVM_Bridge log?

Steve N4IRS

On 10/2/2018 2:02 AM, jeff@n8ema.com wrote:

Running Allstarlink (ASL) with Analog_Bridge , md380-emu and
MMDVM_Bridge......

Got it up and running last night, had a qso from allstar to dmr and DMR
back to allstar with "PERFECT" audio quality!

after a reboot of the server only one way audio from DMR to ALLSTAR, no
audio from allstar passes to DMR, any Ideas??
I have checked/rechecked all the settings and everything thing looks in
order, My node is showing up fine on Allstar and also
showing fine on the brandmeister system...




Mike KB8JNM
 

Just to add one more method of thinking to this...

If your dmr bridge is a private node,
Use 2 public nodes.
-1 connected to it in rx for public monitoring.
-1 you have selective 'who can use' using ASL whitelist enabled for trx

yet there are other methods, but I guess this has you thinking about it now.

...mike/kb8jnm

On 10/2/2018 8:38 AM, Mike KB8JNM wrote:
Well, it sounds like you have your bridge on a public node.
Hard to have 'selective control' that way.
Think of it a bit backwards.
I have dmr tg 91 set-up on 29999 for the last several months.
It's in rx only
Folks have been connecting and 'monitoring'.
If I wish to use it on 29285, in tx,
I can put a description on that server with the private node# ip, port for that direct connect on the other server. (rpt,conf)
1990 = radio@149.29.54.17:4569/1999,NONE ;29999 dmr
So I can still connect to that dmr bridge on the other server by using 1990 connection in what ever mode, but the node number is 1999 on the 29999 server.
1999 dmr bridge ->rx-> 29999  <-trx-> public connects
29285 <-> 1990(1999 on other server) private trx connect to my dmr bridge on other server.
hope this clears your thinking.
I actually have something like this on each of 5 servers even though each have there own dmr bridge, I can just use the connection of the others for my private trx connects. But i do not allow ASL to dmr on unmonitored high traffic dmr tg's. And I would encourage everyone to think about the implications of that.
Lots of control possibilities with this method. But there is always more than one way to skin that cat.
...mike/kb8jnm
On 10/2/2018 12:22 AM, Jim K6JWN wrote:
yeah, i knew about that one, but i cant guarantee that the connecting station will connect in monitor mode :)
On Oct 1, 2018, at 9:11 PM, Mike KB8JNM <groupio@midnighteng.com> wrote:

If I understand your question right
...
Just connect to your DMR Bridged node in RX (*2xxxx)


...mike/kb8jnm

On 10/2/2018 12:07 AM, Jim K6JWN wrote:
I have a working DMR to Allstar setup (thanks for the help!). I have a friend of mine who wants to listen in to the monday night papa system roundtable through my allstar node.  Is there a quick and easy way to configure my setup to pipe audio into Allstar from DMR while not allowing audio from Allstar to enter in DMR?
Jim, K6JWN



Jim - K6JWN
 

It does indeed have me thinking.  I like your idea of using a private node for the bridge (right now it's a public node).


Thanks for the help!


Jim, K6JWN


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Mike KB8JNM <groupio@...>
Sent: Tuesday, October 2, 2018 12:28 PM
To: main@DVSwitch.groups.io
Subject: Re: [DVSwitch] DMR/AllStar one way audio
 
Just to add one more method of thinking to this...

If your dmr bridge is a private node,
Use 2 public nodes.
-1 connected to it in rx for public monitoring.
-1 you have selective 'who can use' using ASL whitelist enabled for trx

yet there are other methods, but I guess this has you thinking about it now.

...mike/kb8jnm

On 10/2/2018 8:38 AM, Mike KB8JNM wrote:
> Well, it sounds like you have your bridge on a public node.
> Hard to have 'selective control' that way.
> Think of it a bit backwards.
>
> I have dmr tg 91 set-up on 29999 for the last several months.
> It's in rx only
> Folks have been connecting and 'monitoring'.
>
> If I wish to use it on 29285, in tx,
> I can put a description on that server with the private node# ip, port
> for that direct connect on the other server. (rpt,conf)
>
> 1990 = radio@...:4569/1999,NONE ;29999 dmr
>
> So I can still connect to that dmr bridge on the other server by using
> 1990 connection in what ever mode, but the node number is 1999 on the
> 29999 server.
>
> 1999 dmr bridge ->rx-> 29999  <-trx-> public connects
> 29285 <-> 1990(1999 on other server) private trx connect to my dmr
> bridge on other server.
>
> hope this clears your thinking.
>
> I actually have something like this on each of 5 servers even though
> each have there own dmr bridge, I can just use the connection of the
> others for my private trx connects. But i do not allow ASL to dmr on
> unmonitored high traffic dmr tg's. And I would encourage everyone to
> think about the implications of that.
>
> Lots of control possibilities with this method. But there is always more
> than one way to skin that cat.
>
> ...mike/kb8jnm
>
>
> On 10/2/2018 12:22 AM, Jim K6JWN wrote:
>> yeah, i knew about that one, but i cant guarantee that the connecting
>> station will connect in monitor mode :)
>>> On Oct 1, 2018, at 9:11 PM, Mike KB8JNM <groupio@...> wrote:
>>>
>>> If I understand your question right
>>> ...
>>> Just connect to your DMR Bridged node in RX (*2xxxx)
>>>
>>>
>>> ...mike/kb8jnm
>>>
>>>> On 10/2/2018 12:07 AM, Jim K6JWN wrote:
>>>> I have a working DMR to Allstar setup (thanks for the help!). I have
>>>> a friend of mine who wants to listen in to the monday night papa
>>>> system roundtable through my allstar node.  Is there a quick and
>>>> easy way to configure my setup to pipe audio into Allstar from DMR
>>>> while not allowing audio from Allstar to enter in DMR?
>>>> Jim, K6JWN
>>>
>>>
>>>
>>
>>
>>
>
>
>