DV Mobile stopped working?


Ken Arck AH6LE
 

Not sure if this is the right place for this but I took a working set of Pi ASL .conf files and used to build a AMD64 ASL running on a x86_64 platform under Debian Buster (used the ASL 64 bit package from github).

Everything works EXCEPT I am unable to get my previously working Android (running DVRSwitch Mobile of course) to connect now. Nothing has changed in my iax.conf file nor extensions.conf files

A bug in the 64 bit version or operator error?

Ken




At 11:20 AM 4/14/2022, you wrote:

[Edited Message Follows]
It looks like we have a connectivity issue with dvswitch.org Backhoe through primary and backup fiber conduits. Looks like 6 to 7 hours to repair.
Steve N4IRS
------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]


Steve N4IRS
 

Error messages on DVSwitch Mobile? Anything in the asterisk logs? Can you connect to the demo account?

On 4/27/22 20:14, Ken Arck AH6LE wrote:
Not sure if this is the right place for this but I took a working set of Pi ASL .conf files and used to build a AMD64 ASL running on a x86_64 platform under Debian Buster (used the ASL 64 bit package from github).

Everything works EXCEPT I am unable to get my previously working Android (running DVRSwitch Mobile of course) to connect now. Nothing has changed in my iax.conf file nor extensions.conf files

A bug in the 64 bit version or operator error?

Ken




At 11:20 AM 4/14/2022, you wrote:

[Edited Message Follows]
It looks like we have a connectivity issue with dvswitch.org Backhoe through primary and backup fiber conduits. Looks like 6 to 7 hours to repair.
Steve N4IRS
------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]


Ken Arck AH6LE
 

I can connect to (and use)the demo no problem.

Phone says
Registration: Not Registered
Node: Not Connected

Not very helpful.

log doesn't show anything related to anything phone (or iax) related but does report the following (don't remember ever seeing this on the Pi)


root@AH6LE-HUB:/var/log/asterisk# tail -f messages
[Apr 27 17:40:24] NOTICE[7183] dnsmgr.c: Managed DNS entries will be refreshed every 300 seconds.
[Apr 27 17:40:24] NOTICE[7183] cdr.c: CDR simple logging enabled.
[Apr 27 17:40:24] NOTICE[7183] loader.c: 56 modules will be loaded.
[Apr 27 17:40:24] NOTICE[7183] res_smdi.c: Unable to load config smdi.conf: SMDI disabled
[Apr 27 17:40:24] WARNING[7183] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.
[Apr 27 17:40:24] NOTICE[7190] app_rpt.c: Normal Repeater Init  1100
[Apr 27 17:40:25] NOTICE[7214] chan_simpleusb.c: Assigned USB device 3-1:1.0 to simpleusb channel usb_1100
[Apr 27 17:40:25] WARNING[7214] chan_simpleusb.c: Loaded parameters from simpleusb_tune_usb_1100.conf for device usb_1100 .




Not sure if this is the right place for this but I took a working set of Pi ASL .conf files and used to build a AMD64 ASL running on a x86_64 platform under Debian Buster (used the ASL 64 bit package from github).

Everything works EXCEPT I am unable to get my previously working Android (running DVRSwitch Mobile of course) to connect now. Nothing has changed in my iax.conf file nor extensions.conf files

A bug in the 64 bit version or operator error?

Ken




At 11:20 AM 4/14/2022, you wrote:

[Edited Message Follows]
It looks like we have a connectivity issue with dvswitch.org Backhoe through primary and backup fiber conduits. Looks like 6 to 7 hours to repair.
Steve N4IRS
------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]


Steve N4IRS
 

Actually, it tells us iax2 can not register with the server and then it can not connect.
So, first, do the UDP ports match? Is the host exposed to the internet or behind NAT?



On 4/27/22 20:45, Ken Arck AH6LE wrote:
I can connect to (and use)the demo no problem.

Phone says
Registration: Not Registered
Node: Not Connected

Not very helpful.

log doesn't show anything related to anything phone (or iax) related but does report the following (don't remember ever seeing this on the Pi)


root@AH6LE-HUB:/var/log/asterisk# tail -f messages
[Apr 27 17:40:24] NOTICE[7183] dnsmgr.c: Managed DNS entries will be refreshed every 300 seconds.
[Apr 27 17:40:24] NOTICE[7183] cdr.c: CDR simple logging enabled.
[Apr 27 17:40:24] NOTICE[7183] loader.c: 56 modules will be loaded.
[Apr 27 17:40:24] NOTICE[7183] res_smdi.c: Unable to load config smdi.conf: SMDI disabled
[Apr 27 17:40:24] WARNING[7183] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.
[Apr 27 17:40:24] NOTICE[7190] app_rpt.c: Normal Repeater Init  1100
[Apr 27 17:40:25] NOTICE[7214] chan_simpleusb.c: Assigned USB device 3-1:1.0 to simpleusb channel usb_1100
[Apr 27 17:40:25] WARNING[7214] chan_simpleusb.c: Loaded parameters from simpleusb_tune_usb_1100.conf for device usb_1100 .




Not sure if this is the right place for this but I took a working set of Pi ASL .conf files and used to build a AMD64 ASL running on a x86_64 platform under Debian Buster (used the ASL 64 bit package from github).

Everything works EXCEPT I am unable to get my previously working Android (running DVRSwitch Mobile of course) to connect now. Nothing has changed in my iax.conf file nor extensions.conf files

A bug in the 64 bit version or operator error?

Ken




At 11:20 AM 4/14/2022, you wrote:

[Edited Message Follows]
It looks like we have a connectivity issue with dvswitch.org Backhoe through primary and backup fiber conduits. Looks like 6 to 7 hours to repair.
Steve N4IRS
------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]


Ken Arck AH6LE
 

I thought looking at the ASL CLI might be useful but it shows nothing. from my phone.

The host is exposed to the internet and has no issues from authorized nodes connecting ( I run a private node).  I have port 4569 forwarded on the router to the IP of the host and that is good, as evidenced by the fact that a remote ASL node can connect to mine.



At 06:04 PM 4/27/2022, you wrote:
Actually, it tells us iax2 can not register with the server and then it can not connect.
So, first, do the UDP ports match? Is the host exposed to the internet or behind NAT?



On 4/27/22 20:45, Ken Arck AH6LE wrote:
I can connect to (and use)the demo no problem.

Phone says
Registration: Not Registered
Node: Not Connected

Not very helpful.

log doesn't show anything related to anything phone (or iax) related but does report the following (don't remember ever seeing this on the Pi)


root@AH6LE-HUB:/var/log/asterisk# tail -f messages
[Apr 27 17:40:24] NOTICE[7183] dnsmgr.c: Managed DNS entries will be refreshed every 300 seconds.
[Apr 27 17:40:24] NOTICE[7183] cdr.c: CDR simple logging enabled.
[Apr 27 17:40:24] NOTICE[7183] loader.c: 56 modules will be loaded.
[Apr 27 17:40:24] NOTICE[7183] res_smdi.c: Unable to load config smdi.conf: SMDI disabled
[Apr 27 17:40:24] WARNING[7183] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.
[Apr 27 17:40:24] NOTICE[7190] app_rpt.c: Normal Repeater Init  1100
[Apr 27 17:40:25] NOTICE[7214] chan_simpleusb.c: Assigned USB device 3-1:1.0 to simpleusb channel usb_1100
[Apr 27 17:40:25] WARNING[7214] chan_simpleusb.c: Loaded parameters from simpleusb_tune_usb_1100.conf for device usb_1100 .




Not sure if this is the right place for this but I took a working set of Pi ASL .conf files and used to build a AMD64 ASL running on a x86_64 platform under Debian Buster (used the ASL 64 bit package from github).

Everything works EXCEPT I am unable to get my previously working Android (running DVRSwitch Mobile of course) to connect now. Nothing has changed in my iax.conf file nor extensions.conf files

A bug in the 64 bit version or operator error?

Ken




At 11:20 AM 4/14/2022, you wrote:

[Edited Message Follows]
It looks like we have a connectivity issue with dvswitch.org Backhoe through primary and backup fiber conduits. Looks like 6 to 7 hours to repair.
Steve N4IRS
------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]  

------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]


Steve N4IRS
 

Best I can do is send me the IP. username and port. I'll try it from here.

On 4/27/22 21:09, Ken Arck AH6LE wrote:
I thought looking at the ASL CLI might be useful but it shows nothing. from my phone.

The host is exposed to the internet and has no issues from authorized nodes connecting ( I run a private node).  I have port 4569 forwarded on the router to the IP of the host and that is good, as evidenced by the fact that a remote ASL node can connect to mine.



At 06:04 PM 4/27/2022, you wrote:
Actually, it tells us iax2 can not register with the server and then it can not connect.
So, first, do the UDP ports match? Is the host exposed to the internet or behind NAT?



On 4/27/22 20:45, Ken Arck AH6LE wrote:
I can connect to (and use)the demo no problem.

Phone says
Registration: Not Registered
Node: Not Connected

Not very helpful.

log doesn't show anything related to anything phone (or iax) related but does report the following (don't remember ever seeing this on the Pi)


root@AH6LE-HUB:/var/log/asterisk# tail -f messages
[Apr 27 17:40:24] NOTICE[7183] dnsmgr.c: Managed DNS entries will be refreshed every 300 seconds.
[Apr 27 17:40:24] NOTICE[7183] cdr.c: CDR simple logging enabled.
[Apr 27 17:40:24] NOTICE[7183] loader.c: 56 modules will be loaded.
[Apr 27 17:40:24] NOTICE[7183] res_smdi.c: Unable to load config smdi.conf: SMDI disabled
[Apr 27 17:40:24] WARNING[7183] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.
[Apr 27 17:40:24] NOTICE[7190] app_rpt.c: Normal Repeater Init  1100
[Apr 27 17:40:25] NOTICE[7214] chan_simpleusb.c: Assigned USB device 3-1:1.0 to simpleusb channel usb_1100
[Apr 27 17:40:25] WARNING[7214] chan_simpleusb.c: Loaded parameters from simpleusb_tune_usb_1100.conf for device usb_1100 .




Not sure if this is the right place for this but I took a working set of Pi ASL .conf files and used to build a AMD64 ASL running on a x86_64 platform under Debian Buster (used the ASL 64 bit package from github).

Everything works EXCEPT I am unable to get my previously working Android (running DVRSwitch Mobile of course) to connect now. Nothing has changed in my iax.conf file nor extensions.conf files

A bug in the 64 bit version or operator error?

Ken




At 11:20 AM 4/14/2022, you wrote:

[Edited Message Follows]
It looks like we have a connectivity issue with dvswitch.org Backhoe through primary and backup fiber conduits. Looks like 6 to 7 hours to repair.
Steve N4IRS
------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]  

------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]


Steve N4IRS
 

Send it direct.

On 4/27/22 21:09, Ken Arck AH6LE wrote:
I thought looking at the ASL CLI might be useful but it shows nothing. from my phone.

The host is exposed to the internet and has no issues from authorized nodes connecting ( I run a private node).  I have port 4569 forwarded on the router to the IP of the host and that is good, as evidenced by the fact that a remote ASL node can connect to mine.



At 06:04 PM 4/27/2022, you wrote:
Actually, it tells us iax2 can not register with the server and then it can not connect.
So, first, do the UDP ports match? Is the host exposed to the internet or behind NAT?



On 4/27/22 20:45, Ken Arck AH6LE wrote:
I can connect to (and use)the demo no problem.

Phone says
Registration: Not Registered
Node: Not Connected

Not very helpful.

log doesn't show anything related to anything phone (or iax) related but does report the following (don't remember ever seeing this on the Pi)


root@AH6LE-HUB:/var/log/asterisk# tail -f messages
[Apr 27 17:40:24] NOTICE[7183] dnsmgr.c: Managed DNS entries will be refreshed every 300 seconds.
[Apr 27 17:40:24] NOTICE[7183] cdr.c: CDR simple logging enabled.
[Apr 27 17:40:24] NOTICE[7183] loader.c: 56 modules will be loaded.
[Apr 27 17:40:24] NOTICE[7183] res_smdi.c: Unable to load config smdi.conf: SMDI disabled
[Apr 27 17:40:24] WARNING[7183] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.
[Apr 27 17:40:24] NOTICE[7190] app_rpt.c: Normal Repeater Init  1100
[Apr 27 17:40:25] NOTICE[7214] chan_simpleusb.c: Assigned USB device 3-1:1.0 to simpleusb channel usb_1100
[Apr 27 17:40:25] WARNING[7214] chan_simpleusb.c: Loaded parameters from simpleusb_tune_usb_1100.conf for device usb_1100 .




Not sure if this is the right place for this but I took a working set of Pi ASL .conf files and used to build a AMD64 ASL running on a x86_64 platform under Debian Buster (used the ASL 64 bit package from github).

Everything works EXCEPT I am unable to get my previously working Android (running DVRSwitch Mobile of course) to connect now. Nothing has changed in my iax.conf file nor extensions.conf files

A bug in the 64 bit version or operator error?

Ken




At 11:20 AM 4/14/2022, you wrote:

[Edited Message Follows]
It looks like we have a connectivity issue with dvswitch.org Backhoe through primary and backup fiber conduits. Looks like 6 to 7 hours to repair.
Steve N4IRS
------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]  

------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]


Steve N4IRS
 

BTW, the demo server is on 64 bit.

On 4/27/22 21:09, Ken Arck AH6LE wrote:
I thought looking at the ASL CLI might be useful but it shows nothing. from my phone.

The host is exposed to the internet and has no issues from authorized nodes connecting ( I run a private node).  I have port 4569 forwarded on the router to the IP of the host and that is good, as evidenced by the fact that a remote ASL node can connect to mine.



At 06:04 PM 4/27/2022, you wrote:
Actually, it tells us iax2 can not register with the server and then it can not connect.
So, first, do the UDP ports match? Is the host exposed to the internet or behind NAT?



On 4/27/22 20:45, Ken Arck AH6LE wrote:
I can connect to (and use)the demo no problem.

Phone says
Registration: Not Registered
Node: Not Connected

Not very helpful.

log doesn't show anything related to anything phone (or iax) related but does report the following (don't remember ever seeing this on the Pi)


root@AH6LE-HUB:/var/log/asterisk# tail -f messages
[Apr 27 17:40:24] NOTICE[7183] dnsmgr.c: Managed DNS entries will be refreshed every 300 seconds.
[Apr 27 17:40:24] NOTICE[7183] cdr.c: CDR simple logging enabled.
[Apr 27 17:40:24] NOTICE[7183] loader.c: 56 modules will be loaded.
[Apr 27 17:40:24] NOTICE[7183] res_smdi.c: Unable to load config smdi.conf: SMDI disabled
[Apr 27 17:40:24] WARNING[7183] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.
[Apr 27 17:40:24] NOTICE[7190] app_rpt.c: Normal Repeater Init  1100
[Apr 27 17:40:25] NOTICE[7214] chan_simpleusb.c: Assigned USB device 3-1:1.0 to simpleusb channel usb_1100
[Apr 27 17:40:25] WARNING[7214] chan_simpleusb.c: Loaded parameters from simpleusb_tune_usb_1100.conf for device usb_1100 .




Not sure if this is the right place for this but I took a working set of Pi ASL .conf files and used to build a AMD64 ASL running on a x86_64 platform under Debian Buster (used the ASL 64 bit package from github).

Everything works EXCEPT I am unable to get my previously working Android (running DVRSwitch Mobile of course) to connect now. Nothing has changed in my iax.conf file nor extensions.conf files

A bug in the 64 bit version or operator error?

Ken




At 11:20 AM 4/14/2022, you wrote:

[Edited Message Follows]
It looks like we have a connectivity issue with dvswitch.org Backhoe through primary and backup fiber conduits. Looks like 6 to 7 hours to repair.
Steve N4IRS
------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]  

------------------------------------------------------------------------------
President and CTO - Arcom Controllers
Makers of repeater controllers and accessories
Phone: (503) 678 6182
https://www.arcomcontrollers.com/
Authorized Dealers for Kenwood and Telewave.
We offer complete turn-key repeater packages!
"We don't just make 'em. We use 'em!"
[]