Topics

DVSwitch-System-Builder 404 error


Derek William Haden
 
Edited

Followed instructions
cd /tmp
wget 
https://github.com/DVSwitch/DVSwitch-System-Builder/archive/master.zip
cd /srv
unzip /tmp/master.zip
mv DVSwitch-System-Builder-master DVSwitch-System-Builder
cd DVSwitch-System-Builder
./DVSwitch-System-Builder.sh

404 error not found.
???


Steve N4IRS
 



On 9/25/2020 10:13 AM, Derek William Haden wrote:root@dvswitch:
/# mkdir test
root@dvswitch:/# cd test

root@dvswitch:/test# wget https://github.com/DVSwitch/DVSwitch-System-Builder/archive/master.zip
--2020-09-25 10:05:39--  https://github.com/DVSwitch/DVSwitch-System-Builder/archive/master.zip
Resolving github.com (github.com)... 140.82.112.4
Connecting to github.com (github.com)|140.82.112.4|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://codeload.github.com/DVSwitch/DVSwitch-System-Builder/zip/master [following]
--2020-09-25 10:05:40--  https://codeload.github.com/DVSwitch/DVSwitch-System-Builder/zip/master
Resolving codeload.github.com (codeload.github.com)... 140.82.114.9
Connecting to codeload.github.com (codeload.github.com)|140.82.114.9|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/zip]
Saving to: ‘master.zip’

master.zip                                             [   <=>                                                                                                             ]   1.70M  2.89MB/s   in 0.6s

2020-09-25 10:05:40 (2.89 MB/s) - ‘master.zip’ saved [1781536]

root@dvswitch:/test# ls -la
total 1748
drwxr-xr-x  2 root root    4096 Sep 25 10:05 .
drwxr-xr-x 24 root root    4096 Sep 25 10:05 ..
-rw-r--r--  1 root root 1781536 Sep 25 10:05 master.zip

[Edited Message Follows]

Followed instructions
cd /tmp
wget 
https://github.com/DVSwitch/DVSwitch-System-Builder/archive/master.zip
cd /srv
unzip /tmp/master.zip
mv DVSwitch-System-Builder-master DVSwitch-System-Builder
cd DVSwitch-System-Builder
./DVSwitch-System-Builder.sh

404 error not found.
???



Derek William Haden
 

Error 404 occurs when I try to run the script ./DVSwitch-System-Builder.sh

Here's the reported error
---
./DVSwitch-System-Builder.sh
--2020-09-25 16:49:44--  http://dvswitch.org/install-dvswitch-repo
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2020-09-25 16:49:44 ERROR 404: Not Found.
------
If I try to run
wget http://dvswitch.org/install-dvswitch-repo   ### first line of the script
I get the error


Steve N4IRS
 

root@backup:~# wget http://dvswitch.org/install-dvswitch-repo
--2020-09-25 11:58:44--  http://dvswitch.org/install-dvswitch-repo
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 782
Saving to: ‘install-dvswitch-repo’

install-dvswitch-repo         100%[=================================================>]     782  --.-KB/s    in 0s

2020-09-25 11:58:44 (128 MB/s) - ‘install-dvswitch-repo’ saved [782/782]

root@backup:~# ls -la in*
-rw-r--r-- 1 root root 782 Jun 22  2018 install-dvswitch-repo


On 9/25/2020 11:54 AM, Derek William Haden wrote:
Error 404 occurs when I try to run the script ./DVSwitch-System-Builder.sh

Here's the reported error
---
./DVSwitch-System-Builder.sh
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2020-09-25 16:49:44 ERROR 404: Not Found.
------
If I try to run
wget http://dvswitch.org/install-dvswitch-repo   ### first line of the script
I get the error


Derek William Haden
 

I can only report what I see happening.

This on 2 different computers.

The wget from github works, the wget from the script doesn't.


Steve N4IRS
 

./DVSwitch-System-Builder.sh
--2020-09-25 13:37:00--  http://dvswitch.org/install-dvswitch-repo
Resolving dvswitch.org (dvswitch.org)... 44.103.34.4
Connecting to dvswitch.org (dvswitch.org)|44.103.34.4|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 782
Saving to: ‘install-dvswitch-repo’

install-dvswitch-repo                                       100%[========================================================================================================================================>]     782  --.-KB/s    in 0s

2020-09-25 13:37:00 (4.73 MB/s) - ‘install-dvswitch-repo’ saved [782/782]

I'm testing it here on a remote RPi I don't want the whole script to execute because I am running it on the DVSwitch-Server RPi image which has all the programs already installed. So, I stopped the script (exit 0) after the wget from dvswitch.org. See below.

#!/usr/bin/env bash
set -o errexit

# N4IRS 02/10/2020

#################################################
#                                               #
#    Build a DVSwitch Server on a clean disk    #
#                                               #
#################################################

# Install DVSwitch Repository
cd /tmp

wget http://dvswitch.org/install-dvswitch-repo
chmod +x install-dvswitch-repo

exit 0


On 9/25/2020 1:32 PM, Derek William Haden wrote:

I can only report what I see happening.

This on 2 different computers.

The wget from github works, the wget from the script doesn't.