Topics

mmdvm_bridge won’t start on boot after update #mmdvm_bridge


Chris Whitam
 

Good Evening, I have a pi setup with The Quantar bridge suite of software which has been running with no problem for a year or two now. (When I turn it on). As there
had been no updates to the os or dvswitch since then, I went ahead and did a apt-get update and apt-get upgrade.  Now the mmdvm_bridge will no longer automatically start on boot up, however quantar_bridge, p25gateway, etc all still work fine.  If I do systemctl mmdvm_bridge the mmdvm bridge starts running right away and then everything works like normal, it just will not automatically start.  I tried a systemctl disable mmdvm_bridge, then reboot, then systemctl enable mmdvm_bridge and that had no effect.  Anyone have any other ideas so that I do not have to manually start mmdvm_bridge every time the pi powers up. Thanks!  


Steve N4IRS
 

Chris,
Here is the output of enable disable and status:

root@dvswitch-server:/home/dvswitch# systemctl disable mmdvm_bridge
Removed /etc/systemd/system/multi-user.target.wants/mmdvm_bridge.service.

root@dvswitch-server:/home/dvswitch# systemctl enable mmdvm_bridge
Created symlink /etc/systemd/system/multi-user.target.wants/mmdvm_bridge.service → /lib/systemd/system/mmdvm_bridge.service.

root@dvswitch-server:/home/dvswitch# systemctl status mmdvm_bridge
● mmdvm_bridge.service - MMDVM_Bridge Service
   Loaded: loaded (/lib/systemd/system/mmdvm_bridge.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2020-07-31 06:42:48 EDT; 24h ago
 Main PID: 3091 (MMDVM_Bridge)
    Tasks: 3 (limit: 2068)
   CGroup: /system.slice/mmdvm_bridge.service
           └─3091 /opt/MMDVM_Bridge/MMDVM_Bridge /opt/MMDVM_Bridge/MMDVM_Bridge.ini

Jul 31 06:42:48 dvswitch-server systemd[1]: Starting MMDVM_Bridge Service...
Jul 31 06:42:48 dvswitch-server systemd[1]: Started MMDVM_Bridge Service.

I bolded the important info for troubleshooting

73, Steve N4IRS


On 7/31/20 11:12 PM, Chris Whitam wrote:
Good Evening, I have a pi setup with The Quantar bridge suite of software which has been running with no problem for a year or two now. (When I turn it on). As there
had been no updates to the os or dvswitch since then, I went ahead and did a apt-get update and apt-get upgrade.  Now the mmdvm_bridge will no longer automatically start on boot up, however quantar_bridge, p25gateway, etc all still work fine.  If I do systemctl mmdvm_bridge the mmdvm bridge starts running right away and then everything works like normal, it just will not automatically start.  I tried a systemctl disable mmdvm_bridge, then reboot, then systemctl enable mmdvm_bridge and that had no effect.  Anyone have any other ideas so that I do not have to manually start mmdvm_bridge every time the pi powers up. Thanks!  


Chris Whitam
 

So it appears I have an issue when I do the status.

mmdvm_bridge.service - MMDVM_Bridge Service

   Loaded: loaded (/lib/systemd/system/mmdvm_bridge.service; enabled; vendor preset: enabled)

   Active: inactive (dead)

 

Jul 31 22:49:49 DVSWITCH systemd[1]: Dependency failed for MMDVM_Bridge Service.

Jul 31 22:49:49 DVSWITCH systemd[1]: mmdvm_bridge.service: Job mmdvm_bridge.servic




Steve N4IRS
 

Show me your /lib/systemd/system/mmdvm_bridge.system

On 8/1/20 9:59 PM, Chris Whitam wrote:

So it appears I have an issue when I do the status.

mmdvm_bridge.service - MMDVM_Bridge Service

   Loaded: loaded (/lib/systemd/system/mmdvm_bridge.service; enabled; vendor preset: enabled)

   Active: inactive (dead)

 

Jul 31 22:49:49 DVSWITCH systemd[1]: Dependency failed for MMDVM_Bridge Service.

Jul 31 22:49:49 DVSWITCH systemd[1]: mmdvm_bridge.service: Job mmdvm_bridge.servic





Chris Whitam
 

On Sat, Aug 1, 2020 at 10:11 PM, Steve N4IRS wrote:
mmdvm_bridge.system
Here is what it looks like

[Unit]

Description=MMDVM_Bridge Service

# Description=Place this file in /lib/systemd/system

# Description=N4IRS 04/20/2018

 

# The device name should point to the

# port the mmdvm is plugged into.

# For USB ports (Arduino Due)

# BindTo=dev-ttyACM0.device

#

# To make the network-online.target available

# systemctl enable systemd-networkd-wait-online.service

 

After=network-online.target syslog.target netcheck.service

Requires=netcheck.service

Wants=network-online.target

 

[Service]

Type=simple

Restart=always

RestartSec=3

Restart=on-abort

StandardOutput=null

WorkingDirectory=/opt/MMDVM_Bridge

ExecStartPre = /bin/sh -c 'echo "Starting MMDVM_Bridge: [`date +%%T.%%3N`]" >> $

ExecStart=/opt/MMDVM_Bridge/MMDVM_Bridge /opt/MMDVM_Bridge/MMDVM_Bridge.ini

ExecReload=/bin/kill -HUP $MAINPID

 

KillMode=process

[Install]

WantedBy=multi-user.target

 

 

 

 


Steve N4IRS
 

Chris,
It sounds like netcheck does not think your internet connection is coming up fast enough.
Make a backup of mmdvm_bridge.system and edit the file:
 
[Unit]

Description=MMDVM_Bridge Service
# Description=Place this file in /lib/systemd/system
# Description=N4IRS 04/20/2018

# The device name should point to the
# port the mmdvm is plugged into.
# For USB ports (Arduino Due)
# BindTo=dev-ttyACM0.device
#
# To make the network-online.target available
# systemctl enable systemd-networkd-wait-online.service

After=network-online.target syslog.target # netcheck.service
# Requires=netcheck.service
Wants=network-online.target

[Service]
Type=simple
Restart=always
RestartSec=3
Restart=on-abort
StandardOutput=null
WorkingDirectory=/opt/MMDVM_Bridge
ExecStartPre = /bin/sh -c 'echo "Starting MMDVM_Bridge: [`date +%%T.%%3N`]" >> $
ExecStart=/opt/MMDVM_Bridge/MMDVM_Bridge /opt/MMDVM_Bridge/MMDVM_Bridge.ini
ExecReload=/bin/kill -HUP $MAINPID
KillMode=process

[Install]
WantedBy=multi-user.target

I bolded the 2 places to comment out netcheck.
reboot and verify mmdvm_bridge is starting.

Steve N4IRS


On 8/1/20 10:53 PM, Chris Whitam wrote:
On Sat, Aug 1, 2020 at 10:11 PM, Steve N4IRS wrote:
mmdvm_bridge.system
Here is what it looks like

[Unit]

Description=MMDVM_Bridge Service

# Description=Place this file in /lib/systemd/system

# Description=N4IRS 04/20/2018

 

# The device name should point to the

# port the mmdvm is plugged into.

# For USB ports (Arduino Due)

# BindTo=dev-ttyACM0.device

#

# To make the network-online.target available

# systemctl enable systemd-networkd-wait-online.service

 

After=network-online.target syslog.target netcheck.service

Requires=netcheck.service

Wants=network-online.target

 

[Service]

Type=simple

Restart=always

RestartSec=3

Restart=on-abort

StandardOutput=null

WorkingDirectory=/opt/MMDVM_Bridge

ExecStartPre = /bin/sh -c 'echo "Starting MMDVM_Bridge: [`date +%%T.%%3N`]" >> $

ExecStart=/opt/MMDVM_Bridge/MMDVM_Bridge /opt/MMDVM_Bridge/MMDVM_Bridge.ini

ExecReload=/bin/kill -HUP $MAINPID

 

KillMode=process

[Install]

WantedBy=multi-user.target

 

 

 

 



Chris Whitam
 

That did it!  Awesome, thank you!