New Analog_Bridge Setup Audio Issue


Ed W8VT
 

The SD card in my ASL->DMR Bridge went belly up so just redid everything on new card using the latest ASL Stretch image on RPi 2 with DV3000 (do not use cheap SD cards and make config backups - lessons learned!)
Anyway, works and sounds great ASL -> DMR BM. DMR -> ASL sounds funny. There is a pulsing - stutter to the audio and I swear it sounds like it is a little low and slow, like sampling issue or something. Again sounds great going the other direction. Thoughts and ideas? Sure I have a config messed up somewhere but so far have not found it.

Ed W8VT


Steve N4IRS
 

Ed,
try this:
cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
cat /sys/bus/usb-serial/devices/ttyUSB1/latency_timer

What value do you get?

Then:

echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
echo 1 > /sys/bus/usb-serial/devices/ttyUSB1/latency_timer

retest


On 05/05/2018 01:43 PM, Ed W8VT wrote:
The SD card in my ASL->DMR Bridge went belly up so just redid everything on new card using the latest ASL Stretch image on RPi 2 with DV3000 (do not use cheap SD cards and make config backups - lessons learned!)
Anyway, works and sounds great ASL -> DMR BM. DMR -> ASL sounds funny. There is a pulsing - stutter to the audio and I swear it sounds like it is a little low and slow, like sampling issue or something. Again sounds great going the other direction. Thoughts and ideas? Sure I have a config messed up somewhere but so far have not found it.

Ed W8VT


Ed W8VT
 

Was 16, then 1 when did retest. Audio is now good.

Ed W8VT

On 05/05/2018 01:58 PM, Steve N4IRS wrote:
Ed,
try this:
cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
cat /sys/bus/usb-serial/devices/ttyUSB1/latency_timer

What value do you get?

Then:

echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
echo 1 > /sys/bus/usb-serial/devices/ttyUSB1/latency_timer

retest


On 05/05/2018 01:43 PM, Ed W8VT wrote:
The SD card in my ASL->DMR Bridge went belly up so just redid everything on new card using the latest ASL Stretch image on RPi 2 with DV3000 (do not use cheap SD cards and make config backups - lessons learned!)
Anyway, works and sounds great ASL -> DMR BM. DMR -> ASL sounds funny. There is a pulsing - stutter to the audio and I swear it sounds like it is a little low and slow, like sampling issue or something. Again sounds great going the other direction. Thoughts and ideas? Sure I have a config messed up somewhere but so far have not found it.

Ed W8VT



Ed W8VT
 

Steve,

After a reboot it reverts back to 16. How does one make this "sticky"?

When set to 1 system works great.

Many thanks for all your help.

Ed W8VT

On 05/05/2018 01:58 PM, Steve N4IRS wrote:
Ed,
try this:
cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
cat /sys/bus/usb-serial/devices/ttyUSB1/latency_timer

What value do you get?

Then:

echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
echo 1 > /sys/bus/usb-serial/devices/ttyUSB1/latency_timer

retest


On 05/05/2018 01:43 PM, Ed W8VT wrote:
The SD card in my ASL->DMR Bridge went belly up so just redid everything on new card using the latest ASL Stretch image on RPi 2 with DV3000 (do not use cheap SD cards and make config backups - lessons learned!)
Anyway, works and sounds great ASL -> DMR BM. DMR -> ASL sounds funny. There is a pulsing - stutter to the audio and I swear it sounds like it is a little low and slow, like sampling issue or something. Again sounds great going the other direction. Thoughts and ideas? Sure I have a config messed up somewhere but so far have not found it.

Ed W8VT



Steve N4IRS
 

Ed,
You should be able to put the commands in /etc/rc.local above the exit 0.

Steve

On 05/05/2018 03:03 PM, Ed W8VT wrote:
Steve,

After a reboot it reverts back to 16. How does one make this "sticky"?

When set to 1 system works great.

Many thanks for all your help.

Ed W8VT

On 05/05/2018 01:58 PM, Steve N4IRS wrote:
Ed,
try this:
cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
cat /sys/bus/usb-serial/devices/ttyUSB1/latency_timer

What value do you get?

Then:

echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
echo 1 > /sys/bus/usb-serial/devices/ttyUSB1/latency_timer

retest


On 05/05/2018 01:43 PM, Ed W8VT wrote:
The SD card in my ASL->DMR Bridge went belly up so just redid everything on new card using the latest ASL Stretch image on RPi 2 with DV3000 (do not use cheap SD cards and make config backups - lessons learned!)
Anyway, works and sounds great ASL -> DMR BM. DMR -> ASL sounds funny. There is a pulsing - stutter to the audio and I swear it sounds like it is a little low and slow, like sampling issue or something. Again sounds great going the other direction. Thoughts and ideas? Sure I have a config messed up somewhere but so far have not found it.

Ed W8VT