Topics

new install working but cannot get BM to TGIF to work

John K1IF
 

Ive created the additional .ini files in MB directory:
MMDVM_Bridge_TGIF
MMDVM_Bridge_BM

i then created the .sh files in AB directory:
TGIF_chng.sh
BM_chng.sh

I also edited the file dvsm.macro and added:
13 = /opt/MMDVM_Bridge/BM_chng.sh
14 = /opt/MMDVM_Bridge/TGIF_chng.sh

i read that dvsm.ini has to be edited but there isn't a file that I can find named that

I keep getting this in the AB log...
I: 2020-05-18 18:46:07.074 Tune macro: *14 will invoke "/opt/MMDVM_Bridge/TGIF_chng.sh"
I: 2020-05-18 18:46:07.080 Macro result was 32256

been reading all the messages but still cannot figure out after several hours :(

please help

Steve N4IRS
 

John,
Below you said you created the .sh files in the AB directory. But your macros are trying to run them out of the MB directory.
See below.

On 5/18/20 3:06 PM, John K1IF via groups.io wrote:
Ive created the additional .ini files in MB directory:
MMDVM_Bridge_TGIF
MMDVM_Bridge_BM

i then created the .sh files in AB directory:
TGIF_chng.sh
BM_chng.sh

I also edited the file dvsm.macro and added:
13 = /opt/MMDVM_Bridge/BM_chng.sh
14 = /opt/MMDVM_Bridge/TGIF_chng.sh

i read that dvsm.ini has to be edited but there isn't a file that I can find named that

I keep getting this in the AB log...
I: 2020-05-18 18:46:07.074 Tune macro: *14 will invoke "/opt/MMDVM_Bridge/TGIF_chng.sh"
I: 2020-05-18 18:46:07.080 Macro result was 32256

been reading all the messages but still cannot figure out after several hours :(

please help

John K1IF
 

Steve, Thank you for the quick reply..
I changed the dvsm.macro to :
13 = /opt/Analog_Bridge/BM_chng.sh
14 = /opt/Analog_Bridge/TGIF_chng.sh

It is still on Brandmeister network
here is the AB log now:

I: 2020-05-18 19:38:58.192 Tune macro: *14 will invoke "/opt/Analog_Bridge/TGIF_chng.sh"
I: 2020-05-18 19:38:58.203 Macro result was 32256
I: 2020-05-18 19:39:20.066 USRP reset server IP address to 169.254.42.42:46001
I: 2020-05-18 19:39:20.066 USRP unregister client
I: 2020-05-18 19:39:22.420 USRP server ip change from 169.254.42.42 to new ip:port 192.168.1.7:46001
I: 2020-05-18 19:39:23.404 INFO packet sent to USRP client
I: 2020-05-18 19:39:23.404 codec=slin
I: 2020-05-18 19:39:23.743 USRP packet type: USRP_TYPE_TEXT (K1IF) -> 3100128
I: 2020-05-18 19:39:23.743 USRP packet type: USRP_TYPE_TEXT (K1IF) -> 3100128
I: 2020-05-18 19:41:18.582 txTg=: 4000
I: 2020-05-18 19:41:21.943 Begin TX: src=4000 rpt=0 dst=3100128 slot=2 cc=128 call=4000
I: 2020-05-18 19:41:32.159 txTg=: 91
I: 2020-05-18 19:41:32.589 Begin TX: src=3020845 rpt=0 dst=91 slot=2 cc=0 call=VE3RIA
I: 2020-05-18 19:42:03.855 Begin TX: src=3142386 rpt=0 dst=91 slot=2 cc=0 call=KC3PEX
I: 2020-05-18 19:42:14.050 txTg=: 4000
I: 2020-05-18 19:42:17.441 Begin TX: src=4000 rpt=0 dst=3100128 slot=2 cc=128 call=4000


Thanks

Steve N4IRS
 

What happens when you run /opt/Analog_Bridge/BM_chng.sh from the command line?

On 5/18/20 3:49 PM, John K1IF via groups.io wrote:
Steve, Thank you for the quick reply..
I changed the dvsm.macro to :
13 = /opt/Analog_Bridge/BM_chng.sh
14 = /opt/Analog_Bridge/TGIF_chng.sh

It is still on Brandmeister network
here is the AB log now:

I: 2020-05-18 19:38:58.192 Tune macro: *14 will invoke "/opt/Analog_Bridge/TGIF_chng.sh"
I: 2020-05-18 19:38:58.203 Macro result was 32256
I: 2020-05-18 19:39:20.066 USRP reset server IP address to 169.254.42.42:46001
I: 2020-05-18 19:39:20.066 USRP unregister client
I: 2020-05-18 19:39:22.420 USRP server ip change from 169.254.42.42 to new ip:port 192.168.1.7:46001
I: 2020-05-18 19:39:23.404 INFO packet sent to USRP client
I: 2020-05-18 19:39:23.404 codec=slin
I: 2020-05-18 19:39:23.743 USRP packet type: USRP_TYPE_TEXT (K1IF) -> 3100128
I: 2020-05-18 19:39:23.743 USRP packet type: USRP_TYPE_TEXT (K1IF) -> 3100128
I: 2020-05-18 19:41:18.582 txTg=: 4000
I: 2020-05-18 19:41:21.943 Begin TX: src=4000 rpt=0 dst=3100128 slot=2 cc=128 call=4000
I: 2020-05-18 19:41:32.159 txTg=: 91
I: 2020-05-18 19:41:32.589 Begin TX: src=3020845 rpt=0 dst=91 slot=2 cc=0 call=VE3RIA
I: 2020-05-18 19:42:03.855 Begin TX: src=3142386 rpt=0 dst=91 slot=2 cc=0 call=KC3PEX
I: 2020-05-18 19:42:14.050 txTg=: 4000
I: 2020-05-18 19:42:17.441 Begin TX: src=4000 rpt=0 dst=3100128 slot=2 cc=128 call=4000


Thanks

John K1IF
 

permission denied when ran from #

John K1IF
 

I changed permissions to 777 on each .sh and now getting...
AB LOG
I: 2020-05-18 20:23:26.901 Tune macro: *14 will invoke "/opt/Analog_Bridge/TGIF_chng.sh"
I: 2020-05-18 20:23:27.263 rxport=: 30000
M: 2020-05-18 20:23:27.264 TLV rx socket reopened for 127.0.0.1:30000
I: 2020-05-18 20:23:28.549 MESSAGE packet sent to USRP client: Setting mode to DMR
I: 2020-05-18 20:23:28.621 ambeMode = DMR, size = 72
M: 2020-05-18 20:23:28.621 Connecting to DV3000 hardware......
M: 2020-05-18 20:23:28.633 Begin DV3000 decode
M: 2020-05-18 20:23:28.633 DV3000 latency is currently set to 1
I: 2020-05-18 20:23:28.688 txport=: 31103
I: 2020-05-18 20:23:28.759 rxport=: 31100
E: 2020-05-18 20:23:28.759 Can not bind port 31100, error code = 98 (Address already in use)
M: 2020-05-18 20:23:28.759 TLV rx socket reopened for 127.0.0.1:31100
I: 2020-05-18 20:23:31.383 Macro result was 0
I: 2020-05-18 20:24:15.123 txTg=: 4000
M: 2020-05-18 20:24:53.782 TLV tx socket re-opened for 127.0.0.1:415496
M: 2020-05-18 20:24:53.782 PTT on
M: 2020-05-18 20:24:56.197 Short transmission, extend hang time by 85 ms
M: 2020-05-18 20:24:56.317 PTT off (keyed for 2535 ms)
from command line:
cp:  missing destination file operand after /opt/MMDVM_Bridge/MMDVM_Bridge_TGIF.ini/optMMDVM_Bridge/MMDVM_Bridge.ini

John K1IF
 

went back over everything and found error in my script. it appears to be working now!! HURRY burn image 

Thanks for pointing me in correct path Steve !

73 John

Tim Porter
 

Don't feel bad John I can't get it working either


On Mon, May 18, 2020, 5:14 PM John K1IF via groups.io <izzy_y2k=yahoo.com@groups.io> wrote:
went back over everything and found error in my script. it appears to be working now!! HURRY burn image 

Thanks for pointing me in correct path Steve !

73 John

Steve N4IRS
 

John,
Happy to hear you got it working.

73, Steve N4IRS

On 5/18/20 5:14 PM, John K1IF via groups.io wrote:
went back over everything and found error in my script. it appears to be working now!! HURRY burn image 

Thanks for pointing me in correct path Steve !

73 John