"Node 1998" message when connected to the node


Bryan
 

Hello,
I can successfully connect the DVSwitch app on my android phone to my Allstarlink node.  However, when it connects, the voice says "Node 1998".  Is this normal?
In the extensions.conf and iax.conf files I changed all the instances where 1998 occurs to my node number.

Also, in my Allstarlink Node information page, it shows no relevant information when I am connected, just "NOCID".  Again, is this to be expected?
Do I have an incorrect setting somewhere.

Thanks,
Bryan, KF1D


Steve N4IRS
 

I'm guessing HamVoIP

look at extensions.conf

[phone-iaxrpt]    ;;; Stanza is the context from iax.conf
exten => 2153,1,Answer
exten => 2153,n,Playback,rpt/node
exten => 2153,n,Playback,digits/1 <------------------
exten => 2153,n,Playback,digits/9 <------------------
exten => 2153,n,Playback,digits/9 <------------------
exten => 2153,n,Playback,digits/8 <------------------
exten => 2153,n,Set(CALLERID(num)=0)
exten => 2153,n,Rpt,1998|P|${CALLERID(name)} ;;; The "CallerID" from IAXRpt

On 1/28/22 00:04, Bryan wrote:
Hello,
I can successfully connect the DVSwitch app on my android phone to my Allstarlink node.  However, when it connects, the voice says "Node 1998".  Is this normal?
In the extensions.conf and iax.conf files I changed all the instances where 1998 occurs to my node number.

Also, in my Allstarlink Node information page, it shows no relevant information when I am connected, just "NOCID".  Again, is this to be expected?
Do I have an incorrect setting somewhere.

Thanks,
Bryan, KF1D


Bryan
 

Hi Steve,
Thanks for your reply.  Yes, all those values, including the one that you show as 1998, have my node number written instead.  The same is true for the node values in the iax.conf file.  But still, I get the voice saying "Node 1998" when I connect.  I think it's actually working fine, it's just strange that it's saying the default node number.


Steve N4IRS
 

Post your stanza. You did see the 1998 vertically?

On 1/28/2022 3:09 PM, Bryan wrote:
Hi Steve,
Thanks for your reply.  Yes, all those values, including the one that you show as 1998, have my node number written instead.  The same is true for the node values in the iax.conf file.  But still, I get the voice saying "Node 1998" when I connect.  I think it's actually working fine, it's just strange that it's saying the default node number.


Bryan
 

Hi Steve,
DVSwitch username is my callsign, KF1D

From iax.conf:
[KF1D] ;;; The stanza is the "Username" from IAXRpt
type=friend
context=android-iaxrpt
host=dynamic
auth=md5
secret=*****;;; The "Password" from IAXRpt
disallow=all
allow=ulaw
transfer=no
calltokenoptional=0.0.0.0/0.0.0.0
requirecalltoken=no

From extensions.conf:
[android-iaxrpt] ;;; Stanza is the context from iax.conf
exten => 53450,1,Answer ;;; The "Node" from IAXRpt is 1998
exten => 53450,n,Playback,rpt/node
exten => 53450,n,Playback,digits/1
exten => 53450,n,Playback,digits/9
exten => 53450,n,Playback,digits/9
exten => 53450,n,Playback,digits/8
exten => 53450,n,Set(KF1D(num)=0)
exten => 53450,n,Rpt,53450|P|${KF1D(name)} ;;; The "CallerID" from IAXRpt

Thanks,
Bryan, KF1D


Steve N4IRS
 

From extensions.conf:
[android-iaxrpt] ;;; Stanza is the context from iax.conf
exten => 53450,1,Answer ;;; The "Node" from IAXRpt is 1998
exten => 53450,n,Playback,rpt/node
exten => 53450,n,Playback,digits/1  <---- 1
exten => 53450,n,Playback,digits/9 <----- 9
exten => 53450,n,Playback,digits/9 <----- 9
exten => 53450,n,Playback,digits/8 <------8
exten => 53450,n,Set(KF1D(num)=0)
exten => 53450,n,Rpt,53450|P|${KF1D(name)} ;;; The "CallerID" from IAXRpt

David,
If you are reading the PLEASE fix this!


On 1/28/2022 3:29 PM, Bryan wrote:
Hi Steve,
DVSwitch username is my callsign, KF1D

From iax.conf:
[KF1D] ;;; The stanza is the "Username" from IAXRpt
type=friend
context=android-iaxrpt
host=dynamic
auth=md5
secret=*****;;; The "Password" from IAXRpt
disallow=all
allow=ulaw
transfer=no
calltokenoptional=0.0.0.0/0.0.0.0
requirecalltoken=no

From extensions.conf:
[android-iaxrpt] ;;; Stanza is the context from iax.conf
exten => 53450,1,Answer ;;; The "Node" from IAXRpt is 1998
exten => 53450,n,Playback,rpt/node
exten => 53450,n,Playback,digits/1
exten => 53450,n,Playback,digits/9
exten => 53450,n,Playback,digits/9
exten => 53450,n,Playback,digits/8
exten => 53450,n,Set(KF1D(num)=0)
exten => 53450,n,Rpt,53450|P|${KF1D(name)} ;;; The "CallerID" from IAXRpt

Thanks,
Bryan, KF1D


Bryan
 

Hi Steve and Dave,
I fixed the "NOCID" showing up in the allstarlink node information webpage.  That is no longer an issue.

Currently everything is working fine.  I can connect to my node and other nodes fine.  But I still have these two issues:
1.  I still get the automated announcement "Node 1998" message when I initially connect to my node. 
2. I noticed that the Status page on the app does not show any connections.  I remember, on my last node, when I connected to East Coast Reflector, I would see all the connections on the status page. Now it is blank.

I am running the node with the latest system updates.  See below for the stanzas.  Again, everything is working ok, but I just have these odd issues.

iax.conf
[KF1D]   ; The stanza is the Username from the phone app
type=friend
context=android-iaxrpt
host=dynamic
auth=md5
secret=****; PASSWORD
disallow=all
allow=ulaw
transfer=no
calltokenoptional=0.0.0.0/0.0.0.0
requirecalltoken=no

extensions.conf
[android-iaxrpt]    ;;; Stanza is the context from iax.conf
exten => 53450,1,Answer
exten => 53450,n,Playback,rpt/node
exten => 53450,n,Playback,digits/1
exten => 53450,n,Playback,digits/9
exten => 53450,n,Playback,digits/9
exten => 53450,n,Playback,digits/8
exten => 53450,n,Set(CALLERID(num)=0)
exten => 53450,n,Rpt,53450|P|${CALLERID(name)} ;;; The "CallerID" from IAXRpt
Thanks,
Bryan


Steve N4IRS
 

extensions.conf
[android-iaxrpt]    ;;; Stanza is the context from iax.conf
exten => 53450,1,Answer
exten => 53450,n,Playback,rpt/node
exten => 53450,n,Playback,digits/1 <--------- This is digit 1
exten => 53450,n,Playback,digits/9 <--------- This is digit 9
exten => 53450,n,Playback,digits/9 <----------This is digit 9
exten => 53450,n,Playback,digits/8 <----------This is digit 8
exten => 53450,n,Set(CALLERID(num)=0)
exten => 53450,n,Rpt,53450|P|${CALLERID(name)} ;;; The "CallerID" from IAXRpt

On 1/29/22 22:29, Bryan wrote:
Hi Steve and Dave,
I fixed the "NOCID" showing up in the allstarlink node information webpage.  That is no longer an issue.

Currently everything is working fine.  I can connect to my node and other nodes fine.  But I still have these two issues:
1.  I still get the automated announcement "Node 1998" message when I initially connect to my node. 
2. I noticed that the Status page on the app does not show any connections.  I remember, on my last node, when I connected to East Coast Reflector, I would see all the connections on the status page. Now it is blank.

I am running the node with the latest system updates.  See below for the stanzas.  Again, everything is working ok, but I just have these odd issues.

iax.conf
[KF1D]   ; The stanza is the Username from the phone app
type=friend
context=android-iaxrpt
host=dynamic
auth=md5
secret=****; PASSWORD
disallow=all
allow=ulaw
transfer=no
calltokenoptional=0.0.0.0/0.0.0.0
requirecalltoken=no

extensions.conf
[android-iaxrpt]    ;;; Stanza is the context from iax.conf
exten => 53450,1,Answer
exten => 53450,n,Playback,rpt/node
exten => 53450,n,Playback,digits/1
exten => 53450,n,Playback,digits/9
exten => 53450,n,Playback,digits/9
exten => 53450,n,Playback,digits/8
exten => 53450,n,Set(CALLERID(num)=0)
exten => 53450,n,Rpt,53450|P|${CALLERID(name)} ;;; The "CallerID" from IAXRpt
Thanks,
Bryan


Bryan
 

Hi Steve,
I compared your stanza text with my stanza text in the message directly below your message and it looks the same.
With that text, I still get the "1998" and also no information on the status page.

Thanks,
Bryan


Mike KB8JNM
 

try it like this....

[android-iaxrpt]    ;;; Stanza is the context from iax.conf
exten => 53450,1,Answer
exten => 53450,n,Set(CALLERID(num)=0)
exten => 53450,n,Rpt,53450|P|${CALLERID(name)} ;;; The "CallerID" from IAXRpt


Bryan
 

Hi Mike,
Yes, that removed the automated announcement of "Node 1998" when connecting.
Now, it connects without any announcement.  Thanks.

So the only issue that I have now, is no data showing up in the Status page on the app.

Bryan


Mike KB8JNM
 

If you are connected to 53450
I don't think it shows in the list, it should show what is connected to "it"/53450

It is not connected to itself.


Bryan
 

Hi Mike,
Yes, I agree.  I wouldn't expect my node number to show up in the Status page.  I connected my node to another node and the other node's information doesn't show up in the status page.  I seem to recall, that with my old node, I would connect to East Coast Reflector and the status page would display all the callsigns and nodes utilizing that reflector.  However, with this latest build, nothing is displayed.

Thanks,
Bryan


Steve N4IRS
 

Wow, you really did not see the vertical row of the numbers 1999?

Sent by smoke signal (AT&T)


From: main@DVSwitch.groups.io <main@DVSwitch.groups.io> on behalf of Bryan <kf1d@...>
Sent: Saturday, January 29, 2022 11:27:01 PM
To: main@DVSwitch.groups.io <main@DVSwitch.groups.io>
Subject: Re: [DVSwitch] "Node 1998" message when connected to the node
 
Hi Mike,
Yes, that removed the automated announcement of "Node 1998" when connecting.
Now, it connects without any announcement.  Thanks.

So the only issue that I have now, is no data showing up in the Status page on the app.

Bryan


Steve N4IRS
 

On 1/29/22 23:45, Bryan wrote:
Hi Mike,
Yes, I agree.  I wouldn't expect my node number to show up in the Status page.  I connected my node to another node and the other node's information doesn't show up in the status page.  I seem to recall, that with my old node, I would connect to East Coast Reflector and the status page would display all the callsigns and nodes utilizing that reflector.  However, with this latest build, nothing is displayed.

Thanks,
Bryan


Bryan
 

Yes, strangely I did.  I guess I kept on thinking that I had done something wrong since I am seeing issues with the status page also.


Steve N4IRS
 

Status page on DVSwitch Mobile?

On 1/30/22 12:37, Bryan wrote:
Yes, strangely I did.  I guess I kept on thinking that I had done something wrong since I am seeing issues with the status page also.


Bryan
 

Yes, when I connect to another node, nothing shows up on the status page on the DVSwitch Mobile app.  Also, I tend to remember that, with my old node, if I connected to East Coast Reflector, I would see all the nodes connected on the status page.  I have yet to see any nodes listed on the status page when connected to another node.

Thanks,
Bryan


Steve N4IRS
 

HamVoIP has made a change to how it works:


; THIS IS AN IMPORTANT FILE! EDIT CAREFULLY AND
; MAKE A BACKUP FIRST!

; The first node definition

[12345]	; This will be YOUR node number
phonesendlinks=1 ; <<<<<<<<<<<<< add this and reboot.
On 1/30/22 13:55, Bryan wrote:

Yes, when I connect to another node, nothing shows up on the status page on the DVSwitch Mobile app.  Also, I tend to remember that, with my old node, if I connected to East Coast Reflector, I would see all the nodes connected on the status page.  I have yet to see any nodes listed on the status page when connected to another node.

Thanks,
Bryan


Bryan
 

Hi Steve,
Where is this code located?