Topics

Stacato audio on DVSM


Steve N4IRS
 

OK, let's leave it that way for now.
stop AMBEServer
edit Analog_Bridge.ini
[DV3000]
; address = 127.0.0.1                   ; IP address of AMBEServer
; rxPort = 2460                         ; Port of AMBEServer
address = /dev/ttyUSB0              ; Device of DV3000U on this machine
baud = 460800                       ; Baud rate of the dongle (230400 or 460800)
serial = true                       ; Use serial=true for direct connect or serial=false for AMBEServer

restart Analog_Bridge an retest

On 8/27/2020 12:01 PM, Derek William Haden wrote:
Booted to console as you asked.
So running headless.
still same problem


Steve N4IRS
 

Do you have results from my last request? If so, I have one more thing to look at.

Steve N4IRS

On 8/27/2020 12:01 PM, Derek William Haden wrote:
Booted to console as you asked.
So running headless.
still same problem


Derek William Haden <facebook@...>
 

So basically cutting out the middle man?

OK i'll look at it in the morning.


Derek William Haden <facebook@...>
 

I'll look at it in the morning.


Steve N4IRS
 

If you have not switched over direct yet you can try one quick thing.


On 8/27/2020 2:40 PM, Derek William Haden wrote:

So basically cutting out the middle man?

OK i'll look at it in the morning.



Derek William Haden <facebook@...>
 

On Thu, Aug 27, 2020 at 10:22 AM, Steve N4IRS wrote:
I have one more thing to look at.
OK I'll try the none ambe server, then what?


Steve N4IRS
 

Leave AMBE server alone.
Show me the output of "cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer"

On 8/27/2020 2:42 PM, Derek William Haden wrote:
On Thu, Aug 27, 2020 at 10:22 AM, Steve N4IRS wrote:
I have one more thing to look at.
OK I'll try the none ambe server, then what?


Steve N4IRS
 

If not using AMBEServer works, then I suspect the serial latency is not set for optimal.

To verify this look at the output of:
cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
If the output is 16, that is a problem.

Analog_Bridge sets the for you, AMBEServer does not. If you revert to AMBEServer then before you start AMBEServer:
echo 1 >/sys/bus/usb-serial/devices/ttyUSB0/latency_timer

Then start AMBEServer and retest

I am out in the field today, so I will not have time to work with you on this today.

Steve N4IRS



On 8/27/20 2:42 PM, Derek William Haden wrote:
On Thu, Aug 27, 2020 at 10:22 AM, Steve N4IRS wrote:
I have one more thing to look at.
OK I'll try the none ambe server, then what?


Derek William Haden <facebook@...>
 

Steve

thanks for all your help so far.

I too am busy for a while, so this will have to wait.


Derek William Haden <facebook@...>
 

Well that works fine, disabled the ambe server and just went direct to the dongle.

using ambe-server seems a more elegant solution, as it means I can use Blue DV ambe also on another device.


Derek William Haden <facebook@...>
 

When I ran "cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer"

when running ambe server it was 16

disabling the ambe server the output is 1


Steve N4IRS
 

As I said, we were not done yet. It does prove where the issue is.
Put Analog_Bridge.ini back to using AMBEServer
stop AMBEServer
Show me the output of "cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer"


On 8/29/20 8:19 AM, Derek William Haden wrote:
Well that works fine, disabled the ambe server and just went direct to the dongle.

using ambe-server seems a more elegant solution, as it means I can use Blue DV ambe also on another device.


Steve N4IRS
 

Is Analog_Bridge reconfigured to use AMBEServer?
stop AMBEServer:
echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer

start AMBEServer
retest.

On 8/29/20 8:21 AM, Derek William Haden wrote:
When I ran "cat /sys/bus/usb-serial/devices/ttyUSB0/latency_timer"

when running ambe server it was 16

disabling the ambe server the output is 1


Derek William Haden <facebook@...>
 

OK
AB set for Ambeserver, but server not started

cat returns 1

AB set for Ambeserver,
Rebooted
server started
cat returns 16

stopped ambeserver

and tried to run echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer

however even with sudo I get permission denied


Derek William Haden <facebook@...>
 

The DVLink image works fine, the only difference I can think of is that on the DVLink image I installed the amber server from

https://nw-digital-radio.groups.io/g/ambe/topic/how_to_install_ambeserver_on/25743616?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,0,25743616

On the DVSwitch image I used

https://github.com/nwdigitalradio/ambeserver-install

could this have any bearing on the problem?


Steve N4IRS
 

sudo -s
echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer


On 8/30/20 4:40 AM, Derek William Haden wrote:
OK
AB set for Ambeserver, but server not started

cat returns 1

AB set for Ambeserver,
Rebooted
server started
cat returns 16

stopped ambeserver

and tried to run echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer

however even with sudo I get permission denied



Derek William Haden <facebook@...>
 

OK if I restart everything, from fresh reboot, with AB configured for ambe server, but ambe server not yet started.
stop AB
do echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer

start amber server and restart AB

all seems to work correctly I do not get the stacato audio.

So I am guessing that somehow the command echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
Needs to to part of the ambe server start up? which I have no idea how to do.


Steve N4IRS
 

I don't know if you use a systemd unit file to start/stop/restart your AMBEServer.
If you do, You could add:
ExecStartPre = /bin/sh -c 'echo "1" >> /sys/bus/usb-serial/devices/ttyUSB0/latency_timer'

to the [SERVICE] stanza in the unit file that controls AMBEServer

On 9/2/2020 10:34 AM, Derek William Haden wrote:

OK if I restart everything, from fresh reboot, with AB configured for ambe server, but ambe server not yet started.
stop AB
do echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer

start amber server and restart AB

all seems to work correctly I do not get the stacato audio.

So I am guessing that somehow the command echo 1 > /sys/bus/usb-serial/devices/ttyUSB0/latency_timer
Needs to to part of the ambe server start up? which I have no idea how to do.



Derek William Haden <facebook@...>
 

yes, the ambeserver is started by a systemd unit file.

I am out most of day tomorrow, but will give it a try before the weekend.

again thanks for all the help.


Derek William Haden <facebook@...>
 

I added the line

ExecStartPre = /bin/sh -c 'echo "1" >> /sys/bus/usb-serial/devices/ttyUSB0/latency_timer'

To the systemd unit file and enabled the service, and all is now working fine.

I guess another snippet of information to add to the install process.

Again, many thanks for the help.